• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Strategy not placing orders... yellow tab forever...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Strategy not placing orders... yellow tab forever...

    Hello All !!!

    Yes... that's me... yet another person to add their voice to the "my strategy won't place trades" chorus. I'm connected to a live CQG feed and I'm in SIM mode. I'm also working strictly in the wizard.

    I've looked into the various reasons this could be happening, and I've gone down the list... and now... I'm at a dead end... the only thing I can imagine now is maybe the strategy is waiting for a "flat" condition which never occurs? (although I've not placed a "marketPosition == flat" check within the conditions pane of the wizard).

    I'm not getting any error messages in the Log tab, and the output window is not telling me anything either.

    The setup for the strategy itself is very simple:

    RSI Avg line is < n
    RSI Main line CrossAbove n
    EnterLong
    Draw a green dot below entry bar

    For short sells...

    RSI Avg line is > n
    RSI Main line CrossBelow n
    EnterShort
    Draw a red dot above entry bar

    There are no other conditions. I get the dots drawn, but no order placed, and no error messages anywhere.

    I've attached screenshots of my setup.

    Can a kind, knowledgeable, NinjaTrader expert please have a quick look at these and let me know if maybe there's some setting I may be missing, or which can be more correctly configured?

    Again... the strategy trades if I have the Options section set to "Immediately submit live working historical orders." But, if I have "wait until flat" selected, the strategy never places an order, and the strategy tab just stays yellow... even though it is getting trade setups, and placing dots on the chart where the orders should go... it never places the orders.

    I'm thinking maybe we should start a "troubleshooting" thread with all the possible reasons a strategy won't place trades. Kind of a checklist for people to follow. Just a thought.

    Thank you again for all your help on this. It is very much appreciated.

    -V
    Attached Files

    #2
    Aurum, generally this would mean the script is waiting for an opposite signal here to reach a flat state in the historical strategy position to start taking live trades for you. This does not need to be a true flat state, but could also be just crossing over / reversing to a new position since technically you will have a flat state then in between offsetting the prior virtual execution you see coming from historical data. When you check your enabled strategy does it show any historical backtest executions then? Do you use ExitOnClose for this reversal script?
    BertrandNinjaTrader Customer Service

    Comment


      #3
      Hi Bertrand! Thanks for getting back to me so quickly.

      I had a feeling it was something like what you describe.

      When you ask: "When you check your enebled strategy, does it show any historical backtest executions then?" I don't know how to check the enabled strategy or this information. Could you please guide me here?

      I can see that there are dots drawn all the way back to the far left of the chart... as if there had been orders taken. I suppose the last dot on the chart before the current bar would indicate an open order. (This strategy doesn't yet have a profit target. It only has a stop loss). Profit is taken when the strategy reverses position, closes the current direction, and begins the new direction. I'm planning a sophisticated trailing stop over the next few days, but at the moment, there is no set profit target other than what is captured as the market reverses into an opposite position. I didn't think this could be the issue, but maybe it is. I didn't think so because the strategy was drawing dots, where the market was reversing, but it still did not place any orders in those spots.

      Also, I set ExitOnClose to "false" since I'm trading the European session as well. (I'm using the "CME US Index Futures ETH2" session template for both the chart and the strategy).

      Thanks for your help on this... and thanks again for getting back to me so quickly.

      -V

      Comment


        #4
        You're welcome Aurum. To check the peformance just right click on your chart > select Strategy Performance > select Historical. What return would you get? Is it just one trade that is held open as no exit triggers and ExitOnClose is false?
        BertrandNinjaTrader Customer Service

        Comment


          #5
          Just about to give up on NT...

          Hello Bertrand...

          Thanks for your reply. Nothing I try seems to allow this strategy to place an order.

          It is drawing dots where it is supposed to. There are no error messages in the log tab. There are no error messages in the output window.

          The strategy stays yellow. it will not place orders.

          It ran all night, and didn't take one order.

          Needless to say, I'm becoming very frustrated at this point with NinjaTrader. Days are passing, the lease is running, and I'm making zero progress on this issue. Two-line answers on a forum are proving to be very unsatisfactory.

          I followed the instructions you gave me, but I have no idea what I'm supposed to be looking for. Could you please type out a few more lines of text and tell me as clearly as possible exactly what I'm supposed to be looking for? I need to get NT up and running so I can actually use it.

          -V

          Comment


            #6
            Aurum, I'm sorry to hear about your frustration and can understand - however there's not much more I could write as of now unfortunately, for example check my previous reply that asked for important info to understand your setup better, however so far this was not provided.

            If you like we can of course also give the script a run on our end here to test - if you like to proceed please email us with the script attached via Help > Mail to Support.

            Thanks much,
            BertrandNinjaTrader Customer Service

            Comment


              #7
              Hi Bertrand... thank you for your reply... in it you wrote:

              check my previous reply that asked for important info to understand your setup better, however so far this was not provided.
              I, then replied with:

              I followed the instructions you gave me, but I have no idea what I'm supposed to be looking for. Could you please type out a few more lines of text and tell me as clearly as possible exactly what I'm supposed to be looking for?
              Can you see why I'm becoming frustrated? I've stated that I am not sure of what I'm supposed to be providing. I'm new to NinjaTrader and the instructions you gave me seem to be geared toward someone who is very familiar with the program. I've requested that you more clearly state here what I'm supposed to be looking for. Is that possible?

              For example, Bertrand... in your instructions, you ask:

              "What return would you get?"
              I don't know what this means. I've done what you've instructed, and a window comes up which contains a ton of information (it looks like the strategy analyzer window). But it is full of information. I'm not sure what you mean when you say: "What return would you get?" I don't know what "return" means.

              Then you ask:

              Is it just one trade that is held open as no exit triggers and ExitOnClose is false?
              Again, I'm not sure what this means.

              -V
              Last edited by Aurum; 07-31-2014, 08:42 AM. Reason: Further clarification...

              Comment


                #8
                Hi Aurum, here's my reply from post #4 -

                To check the performance just right click on your chart > select Strategy Performance > select Historical. What return would you get? Is it just one trade that is held open as no exit triggers and ExitOnClose is false?
                BertrandNinjaTrader Customer Service

                Comment


                  #9
                  I think to continue troubleshoot and resolve for you, it would be best if we gave the script a testrun here.
                  BertrandNinjaTrader Customer Service

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by tonynt, Today, 12:39 PM
                  0 responses
                  8 views
                  0 likes
                  Last Post tonynt
                  by tonynt
                   
                  Started by Martyb, 06-13-2019, 05:14 AM
                  10 responses
                  77 views
                  0 likes
                  Last Post iq200
                  by iq200
                   
                  Started by Erwin Beckers, 11-04-2018, 02:39 AM
                  4 responses
                  71 views
                  2 likes
                  Last Post brucerobinson  
                  Started by ntbone, Today, 01:25 AM
                  0 responses
                  6 views
                  0 likes
                  Last Post ntbone
                  by ntbone
                   
                  Started by bomanpbm, Yesterday, 09:27 PM
                  0 responses
                  8 views
                  0 likes
                  Last Post bomanpbm  
                  Working...
                  X