• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

CBOT(ZN, ZB, ZF) Charts not updating through Rithmic

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    CBOT(ZN, ZB, ZF) Charts not updating through Rithmic

    Hi,

    There is a gap between 1:25am - 4:30am in Treasuries.

    1) Interval of chart (5-min)
    Have tried other intervals as well, problem stays the same.

    2) Datafeed: Rithmic.

    3) Have restarted a couple of times, and reload historical data a couple of times as well. Problem stays the same.

    4) Contract expiry: 12-14

    5) Session Template: CBOT Interest Rate ETH
    Tried "Use instrument settings", problem stays the same.

    6) NinjaTrader version: 7.0.1000.26

    Please fix this issue.

    #2
    Just to add another question, why are there consistent gaps when the chart is set to 1-min?

    The chart does not flow consistently in 1-min, it jumps.

    i.e, 18:05 - 18:07
    18:15 - 18:20
    19:20 - 19:23
    etc

    Comment


      #3
      Hello EthanC,

      I can confirm this data is missing from the historical data server for Rithmic users.

      I have alerted the IT department this data is missing. They have let me know the data is scheduled to be restored this weekend.

      Thank you for reporting this data is missing.
      Chelsea B.NinjaTrader Customer Service

      Comment


        #4
        Hi,

        May I also know why are there inconsistent gaps when the chart is set to 1-min?

        The chart does not flow consistently in 1-min, it jumps.

        i.e,
        18:05 - 18:07
        18:15 - 18:20
        19:20 - 19:23
        etc

        Comment


          #5
          Hello EthanC,

          I have checked several data feeds and found all of them to be missing data on these bars.

          I believe there was not any new last price changes (no new ticks) during this minute due to low volume. A new bar will not be created unless there is a tick during that minute.
          Chelsea B.NinjaTrader Customer Service

          Comment


            #6
            Hi,

            Thanks for your reply.

            My friend is using Kinetick and both of us are using "Jigsaw Depth of Sales", but there is a HUGE difference in our cumulative volume profile.

            I understand that different datafeeds calculate differently, and I don't mind a small difference in volume. But the difference is a few thousand contracts on a couple of prices.

            Comment


              #7
              Hello EthanC,

              Compare the data itself using a time based bar.

              Over the data that is being used for the indicator, is the data the same? Is the volume the same?

              Are you using the same session template?
              Chelsea B.NinjaTrader Customer Service

              Comment


                #8
                Hi,

                For most days we have almost the same amount of volume, the difference is around 1-500 contracts on a couple of prices. But for most part, it is the same.

                Yes we have the same session template using the default Ninjatrader setting.

                Days like today and yesterday are rare, but when they do happen, the difference is HUGE.

                I strongly suspect it is because of the inconsistent 1min gaps which cause these differences in volume, if there is no uptick/downtick like you said, the chart could just print the next minute. During the overnight session, there are some periods where the price just remains the same but the chart continues to print the next minute.

                Comment


                  #9
                  Hello EthanC,

                  I am seeing these missing 1 minute bars with Kinetick data. Are you not seeing these bars as missing with Kinetick?
                  Chelsea B.NinjaTrader Customer Service

                  Comment


                    #10
                    Hi,

                    I have sent my Config file over to tech support. They said that there should not be any gaps on a 1min chart, and will rectify this issue.

                    Thanks alot by the way.

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by chnh1, Yesterday, 11:51 PM
                    0 responses
                    7 views
                    0 likes
                    Last Post chnh1
                    by chnh1
                     
                    Started by Jasper99, Yesterday, 10:29 PM
                    0 responses
                    11 views
                    0 likes
                    Last Post Jasper99  
                    Started by Jasper99, Yesterday, 09:50 PM
                    0 responses
                    5 views
                    0 likes
                    Last Post Jasper99  
                    Started by StevenNelson, Yesterday, 05:57 PM
                    0 responses
                    7 views
                    0 likes
                    Last Post StevenNelson  
                    Started by srbdoc, Yesterday, 03:59 PM
                    1 response
                    17 views
                    0 likes
                    Last Post NinjaTrader_EricB  
                    Working...
                    X