• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

gap on historical data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    gap on historical data

    Hi
    I created a new EURUSD chart, from "data series". The parameters are:

    Price based on: last
    Type: minute
    Value: 60

    load data based: Custom Range
    start: 2014. 01. 01
    end: 2014. 02. 15
    session template: <use instrument settings>

    I have a gaps fe. between 1/09 and 1/16, there are no data. When I reload, the situation is same.
    I would like make some backtest with my scripts, and running the backtest there are gaps too.
    The connection is to fxcm.
    What is the solution to get date without gaps to backtests on 5Min and 60Min.

    Thank You for Your attention
    Akos
    Attached Files

    #2
    Hello,

    Thank you for your post.

    Which version of NinjaTrader are you using? (Help > About)

    Are you using NinjaTrader historical data servers or FXCM servers? To check:
    Open the Account Connections menu (Tools > Account Connections)
    Select your FXCM connection then click Change
    Click Next once in the menu which appears - on the page which you've moved to you will find the connection's historical data setting.
    KyleNinjaTrader Customer Service

    Comment


      #3
      Hello Kyle

      Oh, I have used rhe fxcm as historical data provider. I switched on the ninja, and the gaps disappeared! Thank You. But I have a new question. What is the right setting on the session manager, when I work on forex, on Budapest (Hungary, Central Europe), and I would like to see the the vertical line in the chart to mark the 00h time position? What is the good settings on the session template? (Because when I use the "default 24/7" , on the chart the vertical line shows 5PM)
      Thank You in advance
      Akos

      Comment


        #4
        Hello,

        I'm glad to hear that you were able to load data in full after switching the connection to the NinjaTrader historical data servers.

        No Session Template which exists by default meets the specifications which you've outlined however it would be possible to create a custom template which uses these exact settings via the Session Manager. Please see the following link to our Help Guide for more information about creating a custom Session Template: http://www.ninjatrader.com/support/h...on_manager.htm
        KyleNinjaTrader Customer Service

        Comment


          #5
          Hello Kyle,
          As I see, the session template is not very simple task, but I will study this section.
          Your instructions were very useful, I'm impressed on the very fast replays
          Thank You
          Akos

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by teafortwo, Yesterday, 04:26 AM
          4 responses
          12 views
          0 likes
          Last Post bltdavid  
          Started by borjanews, Yesterday, 06:13 PM
          0 responses
          4 views
          0 likes
          Last Post borjanews  
          Started by Austiner87, Yesterday, 05:13 PM
          0 responses
          2 views
          0 likes
          Last Post Austiner87  
          Started by Austiner87, Yesterday, 04:59 PM
          0 responses
          4 views
          0 likes
          Last Post Austiner87  
          Started by Austiner87, Yesterday, 04:58 PM
          0 responses
          1 view
          0 likes
          Last Post Austiner87  
          Working...
          X