• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Not possible activate strategy

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Not possible activate strategy

    Hello,
    i cant activate strategy. I check Enabled a strategy, but not turn to green. And in Control Centrum right down corner new message "Saving".
    In Log not new message.
    I included screen.
    Please help.
    Thank a lot
    Attached Files

    #2
    Hello fLife,

    All of the strategies in this screenshot show the Enabled as checked. This indicates the strategies are enabled.

    The item on the top is selected so we cannot see the color of this, but the Enabled shows it as enabled.

    Are you getting any error messages in the log tab of the Control Center when enabling the script?

    After you enable the script, does the check mark in the Enabled for that row become unchecked?
    Chelsea B.NinjaTrader Customer Service

    Comment


      #3
      Hi,

      Sometimes the check mark stays, but the strategy does not turn green. And sometimes even the chekcmark disappears.No error messages in log tab.

      Comment


        #4
        Hi fLife,

        Thanks for letting me know.

        I'd like to test this script on my end. Is this a script you can share an export of on the forums?

        If so, please attach an export so that I may test.

        To export your script do the following:
        1. Click File -> Utilities -> Export NinjaScript
        2. Enter a unique name for the file in the value for 'File name:'
        3. Select the strategy from the objects list on the left -> click the right facing arrow ">" to add the strategy to the export
        4. Click the 'Export' button -> click 'yes' to add any referenced indicators to the export -> click OK to clear the export location message


        By default your exported file will be in the following location:
        • (My) Documents/NinjaTrader 7/bin/Custom/ExportNinjaScript/<export_file_name.zip>


        Below is a link to the help guide on Exporting NinjaScripts.
        http://www.ninjatrader.com/support/h...nt7/export.htm



        If not, please send an export of the script to platformsupport [at] ninjatrader [dot] com so that I can try running the script. In the email, please add a link to this forum thread.
        Chelsea B.NinjaTrader Customer Service

        Comment


          #5
          Hi,
          unfortunately it is not possible for us to send any strategy scripts.

          Summing up the facts - 1) it is the same strategy script, that all other 10 instruments are (without any problem) running on.
          2)Without any changes in the script, this strategy was working allright with CAC40.
          3) Once we did changes in symbol map (by assistance of ninja trader support via teamviewer - which solved problem we had with CAC40 before), we are not able to enable strategy on this specific symbol

          -> therefore I believe there is a way to solve the problem without needing to send any scripts (which is unfortunately not possible for us).

          Is there any possible explanation based on these points?

          Thank you for your help.

          Comment


            #6
            I also tried running CAC40 on different strategies (that work with other symbols) of ours and I cannot enable it.
            In order to exclude the probability of our script preventing the CAC from working, I tried turning default ninja strategies such as SampleMACross or SampleAtmStrategy.
            Same problem with default scripts.
            The checkmark stays, but strategy does not turn green.

            Comment


              #7
              Also tried that specific script on cac using different computer. All works fine. So the problem is somewhere within this specific ninja, not the script, i believe.

              Comment


                #8
                Hi fLife,

                Thank you for letting me know you are having difficulty with an instrument and not the strategy.

                If you open a chart to the CAC40 do you get up to the minute historical data? Are you receiving live Bid / Ask / Last quotes for the CAC40?

                Are you 100% sure there are no errors in the Log tab of the Control Center?

                Can you place a manual order to the CAC40?

                What connect type are you using?

                If Interactive Brokers, do you have the |||10 multiplier set for the symbol mapping for the CAC40?
                Chelsea B.NinjaTrader Customer Service

                Comment


                  #9
                  Yes TF 1M is not problem. Data is corecct(i mean). Ask Bid Last OK.
                  Yes i am 100%sure no message in Log tab.
                  Yes manual order is no problem for Sim101 and DU******608.
                  What are you mean type connect? I have Kinetick data.
                  Yes i have CAC40|||10 multiplier set for the symbol CAC40.


                  PS:
                  Im sorry, but now i get in Log tab this message:
                  13.1.2015 16:10:58 Default Kinetick.Adapter.L1Worker: msg='U,4A|AUDCAD.FXCMf5g37,Cm74t97216i-1b97216g12,101044g26,101044000a97245g13,101044g27, 101044000g23,01z101044g24,101044000': K uvolněnému objektu nelze přistupovat.
                  Název objektu: System.Net.Sockets.Socket

                  All NT frozen, i must restart. And in specifict time, this message:
                  13.1.2015 16:10:58 Default Kinetick.Adapter.L1Worker: msg='U,4A
                  What is it?
                  Thank you for help me

                  Comment


                    #10
                    Hello fLife,

                    I would like to schedule a call with you to assist.

                    Please send an email to platformsupport [at] ninjatrader [dot] com.

                    In the email please add a link to this forum thread.
                    Chelsea B.NinjaTrader Customer Service

                    Comment


                      #11
                      I send mail with link to this thread.
                      Well, I do discuss with colleagues, who will hear tomorrow. My English is bad enough live chat.
                      Thanks a lot

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by digibob, Today, 01:13 AM
                      0 responses
                      2 views
                      0 likes
                      Last Post digibob
                      by digibob
                       
                      Started by kemoleena, Today, 12:31 AM
                      0 responses
                      5 views
                      0 likes
                      Last Post kemoleena  
                      Started by aligator, 09-18-2019, 12:15 PM
                      12 responses
                      104 views
                      0 likes
                      Last Post Lancer
                      by Lancer
                       
                      Started by StevenNelson, Yesterday, 05:45 PM
                      0 responses
                      7 views
                      0 likes
                      Last Post StevenNelson  
                      Started by calebsandfort, Yesterday, 05:16 PM
                      1 response
                      7 views
                      0 likes
                      Last Post calebsandfort  
                      Working...
                      X