• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

IB and Market Depth / Level II data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IB and Market Depth / Level II data

    First off I am new to NT, so I appologise if this a silly question.

    I am using 6.5.1000.1 with IB TWS 884.2

    I am trying to use the stock symbol VLCM (Volcom) and have edited it using the Instrument Manager to have the following Exchanges (when I add it to the List, I leave Exchange as "Default")

    Arca, Default, IBIdeal, Ise, Island, Nasdaq, Phlx

    When I go into Level II using NT/IB my Level II data only shows about half (and sometimes even less) of the depth that I see in IB/TWS. Also it seems many of the Nasdaq Bids and Asks are missing. When I start a new Dynamic SuperDOM window (still on VLCM symbol) and try to turn on "Show Market Depth" to properties window will not let me change this value to True, just keeps it locked on False.

    I am subscribed to Nasdaq TotalView from IB and using TWS am able to see all market depth.

    Any assistance is appreciated.
    Last edited by bigtrade5; 05-02-2008, 08:35 AM.

    #2
    Hi Bigtrade5,

    Welcome to the NinjaTrader community and thank you for your post.

    Can you please downgrade your TWS as version 882 is the official supported version. You can download this version from our website here:
    http://www.ninjatrader.com/webnew/su...ivebrokers.htm

    It is normal behavior you don't see market depth from Stocks in the SuperDOM. Level II is not the same as Market Depth. It's the total size buying of major market makers of stocks.
    Vince B.NinjaTrader Customer Service

    Comment


      #3
      I will try downgrading TWS and see if that helps the Level II quotes. Is that link the best place to check the currently supported TWS version and is the info at that link maintained/updated as newer versions are supported? Obviously IB is making monthly updates to TWS, but I want to stay on whatever is the most current NT supported version.
      Last edited by bigtrade5; 05-02-2008, 01:56 PM.

      Comment


        #4
        That is correct, on this page we have the current compatible TWS version and we'll update when we're compatible with a later release of TWS.
        Vince B.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by ttodua, Today, 01:52 PM
        1 response
        13 views
        0 likes
        Last Post NinjaTrader_Jim  
        Started by muisca, 05-19-2017, 11:49 AM
        8 responses
        6,463 views
        0 likes
        Last Post NinjaTrader_Tyler  
        Started by NinjaTrader_Brandon, Today, 12:08 PM
        0 responses
        65 views
        0 likes
        Last Post NinjaTrader_Brandon  
        Started by iq200, Today, 12:00 PM
        2 responses
        11 views
        0 likes
        Last Post iq200
        by iq200
         
        Started by valhallafutures, Today, 11:33 AM
        1 response
        18 views
        0 likes
        Last Post NinjaTrader_PatrickG  
        Working...
        X