• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Predefine Stop Limit offset value.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Predefine Stop Limit offset value.

    Hi,

    I'm about to switch over to NT 5 version. In version 4 there is appearing a small windowto definean offset value of a stop limit order as soon as I choose that order type for example when creating a new strategy. Unfortunately I miss that way to define an offset value in version 5. I know its possible by usingthe middle mouse button and clicking on the Buy, or Sell row in the superDom. Doesthis featuresupersede the feature in version 4Imentioned above?

    One of my ESstrategies uses only a stop loss limitorder (no target)with an emergency stop of 3.5 points and an offset value of 5 points. No problems here in version 4. But in version 5I got an error messagethat it is not possible to place buy stop or sell stop orders below the market.

    Much thanks in advance!



    Best regards

    Saico




    #2
    imported post

    Hi,

    When you place a Stop Limit order in V5, a small window pops up as well where you can enter the limit offset. More info on this can be found here:

    http://www.ninjatrader-support.com/H...ingOrders.html



    Vince
    Vince B.NinjaTrader Customer Service

    Comment


      #3
      imported post

      Thanks Vincent! I have nowset "Stop limit offset" to an integer value of 6, so every Stop Limit order should now have an offset value of 6 points, right? Lets assume I trade the ES. Soa cmestop lossorder fora simplestrategy, lets assume: Stop loss: -3.5would be transmitted automatically as astop limit order in my case with an offset of 6 points, right? Tia!



      Best regards

      Saico
      Attached Files

      Comment


        #4
        imported post

        Saico,

        it's not 6 points, but 6 ticks.

        Vince
        Vince B.NinjaTrader Customer Service

        Comment


          #5
          imported post

          Although I have set in Properties''Parameter Type'' to ''Price''?

          Comment


            #6
            imported post

            Correct. Price is not points. Price is absolute price. Stop loss of 6 would be 6 not 6 points from entry.
            RayNinjaTrader Customer Service

            Comment


              #7
              imported post

              Dear NT team,

              in version 5 I have set my stop limit offset value to 24 ticks, which is 6points when trading the ES. Nevertheless my log window is showing me that a limit order of only 5 points +/- the stop price has been submitted. Even if I set the offset value higher it seems NT doesnt accepta higher valueandonly submit a maximumoffsetof 20 ticks.

              In version 4 I noticed in my log window that with thestrategy mentioned belowevenno limit orderfor the stoplimit has been submitted, only the stop order.The strategy was: Stop limit: -3.25, limitoffset -5.0 points, no target order.

              Much thanks in advance.



              Best regards

              Saico







              Attached Files

              Comment


                #8
                imported post

                Stop Limit Offset in V5 (the box that pops up when placing a stop limit order) is used for that order only, not the stop loss. Stop loss orders that use stop limit is hard coded of 20 ticks for CME.
                RayNinjaTrader Customer Service

                Comment


                  #9
                  imported post

                  Thanks, I think I got you regarding my first question on version 5.

                  But the second problem occured in version 4. Here I have a predefined offset value for every new order.



                  Regards

                  Saico

                  Comment


                    #10
                    imported post

                    In V4 Instrument Manager, set the "Use Stop Market for Stop Loss" to false (uncheck)
                    RayNinjaTrader Customer Service

                    Comment


                      #11
                      imported post

                      Thanks, I guess that was the problem.

                      Best regards

                      Saico

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by ntbone, Today, 09:54 PM
                      0 responses
                      1 view
                      0 likes
                      Last Post ntbone
                      by ntbone
                       
                      Started by rwilliam, Today, 03:14 PM
                      0 responses
                      5 views
                      0 likes
                      Last Post rwilliam  
                      Started by rwilliam, Today, 03:10 PM
                      1 response
                      4 views
                      0 likes
                      Last Post NinjaTrader_ChelseaB  
                      Started by rontronimous, Today, 03:04 PM
                      2 responses
                      8 views
                      0 likes
                      Last Post rontronimous  
                      Started by zacharydw00, Today, 03:14 PM
                      0 responses
                      5 views
                      0 likes
                      Last Post zacharydw00  
                      Working...
                      X