• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

'ProcessorNameString' not found

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    'ProcessorNameString' not found

    I'm progressing on getting NT7 working on linux via wine but I keep getting message in the log:

    Failed to retrieve processor information to build machine ID: 'ProcessorNameString' not found

    Please see attached photo.

    Is this important? If so, please give me some insight on what I need to do to correct the matter or redirect me to another possible source with the answer.

    Thanks
    Attached Files
    Last edited by davidbrooke; 08-28-2015, 09:30 AM.

    #2
    Originally posted by davidbrooke View Post
    I'm progressing on getting NT7 working on linux via wine but I keep getting message in the log:

    Failed to retrieve processor information to build machine ID: 'ProcessorNameString' not found

    Please see attached photo.

    Is this important? If so, please give me some insight on what I need to do to correct the matter or redirect me to another possible source with the answer.

    Thanks
    You will have to get that into the registry at the correct key. Between these 2 posts, you should be able to handle that.

    ref: https://www.winehq.org/pipermail/win...il/076543.html
    http://wiki.winehq.org/UsefulRegistryKeys

    The correct key is:
    Code:
    HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0]
    "ProcessorNameString"="..."
    There will be one key for each Core, 0, 1, 2, 3 etc

    Comment


      #3
      There is a character string in the data field for each core (0-7) but not the correct info. The string is "Intel(R) Pentium(R) 4 CPU 2.40GHz" and I have a CI7-3770. The string is the same for all cores.
      So there is a value in the data field for "ProcessorNameString" but it can't be read for some reason?

      Comment


        #4
        Attached is a photo of the registry.
        Attached Files

        Comment


          #5
          Originally posted by davidbrooke View Post
          Attached is a photo of the registry.
          If it is there and not being read, maybe you will have to report to the Wine developers?

          Comment


            #6
            Hello davidbrooke,

            Thank you for your post.

            Can you please send me your log and trace files for today so that I may look into what occurred.

            You can do this by going to the Control Center-> Help-> Mail to Platform Support.

            Please reference this thread in the e-mail: "http://ninjatrader.com/support/forum/showthread.php?t=77211"
            Patrick H.NinjaTrader Customer Service

            Comment


              #7
              This is the response I received:

              I see no setting incorrect within the NinjaTrader files. We would not be able to provide additional assistance as Linux is not supported.

              Sincerely,
              Brandon
              NinjaTrader Customer Service

              Comment


                #8
                To better understand....what negative effects or repercussions would one expect with this error message?

                Code:
                Failed to retrieve processor information to build machine ID: 'ProcessorNameString' not found

                Comment


                  #9
                  Originally posted by davidbrooke View Post
                  To better understand....what negative effects or repercussions would one expect with this error message?

                  Code:
                  Failed to retrieve processor information to build machine ID: 'ProcessorNameString' not found
                  Issues with add-on developer indicators/strats...

                  NT7 isn't exactly multicore so there shouldn't be any issues related to that??

                  Comment


                    #10
                    Originally posted by davidbrooke View Post
                    To better understand....what negative effects or repercussions would one expect with this error message?

                    Code:
                    Failed to retrieve processor information to build machine ID: 'ProcessorNameString' not found
                    NT cannot calculate your MachineID, so anything that requires that ID for validation purposes will not work correctly.

                    Comment


                      #11
                      Meaning 3rd party add-ons, internal NT7 processes, etc....If possible I would like to find out more specific issues.
                      Thanks

                      Comment


                        #12
                        For example...
                        everytime I connect to a datafeed I get the error message. Is this a problem?

                        Comment


                          #13
                          Below is the open issues of an Issues List that relates to the topic of this thread (and item #9):

                          9. Failed to retrieve processor information to build machine ID: 'ProcessorNameString' not found.
                          On going Wine forums discussion:
                          https://forum.winehq.org/viewtopic.php?f=8&t=25108
                          POSSIBLE SOLUTION - Wine version 1.7.49

                          11. IQFeed does not work correctly in Wine. I can get IQFeed to start using it's programs such as Diagnostic but not IQwatchquote on Demo but live?
                          WORK-AROUND - Changed from IQFeed to Kinetick. Kinetick EOD worked everytime as expected, as was the case when Kinetick was tested.
                          POSSIBLY RELATED TO ITEM #9

                          12. Reload data after internet outage. Using Control Center>Tools>Historical Data Manager>Reload>Reload All, causes an error per instrument.
                          WORK-AROUND - close and restart NT7.
                          POSSIBLY RELATED TO ITEM #9

                          13. Datafeeds do not re-connect correctly after internet outage. The datafeeds re-connect but the charts and DOM do not continue to populate.
                          WORK-AROUND - close and restart NT7.
                          POSSIBLY RELATED TO ITEM #9

                          14. 3rd party indicator requires license input on every startup.
                          WORK-AROUND - Input license.
                          POSSIBLY RELATED TO ITEM #9

                          I'm showing that issues 11 - 14 are related or a direct cause of item #9. If someone from NT would comment, it would be very appreciated.
                          Thanks

                          Comment


                            #14
                            Hello davidbrooke,

                            Thank you for your update.

                            Unfortunately, Wine is unsupported and has not been tested to ensure it works properly. NinjaTrader is a Windows based application and we would recommend using a Windows based machine.
                            Patrick H.NinjaTrader Customer Service

                            Comment


                              #15
                              Originally posted by NinjaTrader_PatrickH View Post
                              Hello davidbrooke,

                              Thank you for your update.

                              Unfortunately, Wine is unsupported and has not been tested to ensure it works properly. NinjaTrader is a Windows based application and we would recommend using a Windows based machine.
                              I understand that wine isn't supported but does the log error "Failed to retrieve processor information to build machine ID: 'ProcessorNameString' not found." effect items 11-14 in post 13. Thanks

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by refine, Today, 05:02 PM
                              0 responses
                              1 view
                              0 likes
                              Last Post refine
                              by refine
                               
                              Started by White Fork, Today, 01:57 PM
                              2 responses
                              6 views
                              0 likes
                              Last Post NinjaTrader_Jim  
                              Started by martyn73, Today, 02:45 PM
                              2 responses
                              8 views
                              0 likes
                              Last Post martyn73  
                              Started by ct, Today, 12:48 PM
                              4 responses
                              22 views
                              0 likes
                              Last Post eDanny
                              by eDanny
                               
                              Started by BrandonT1292, 07-30-2018, 07:32 PM
                              11 responses
                              400 views
                              0 likes
                              Last Post EllisEdi  
                              Working...
                              X