• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Problems with NTConnected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems with NTConnected

    Guys,

    I am trying to write my ATI and can seemingly place an order but I am not getting the right returns from functions such as NTOrders etc. When looking at NTConnected I keep getting that my EFS is not connected to NT5.

    Also the order I place does not seem to have the OrderID I supplied to it. Are all these issues related to the same thing? Can someone send me a sample EFS that truly works?

    TIA
    MuthaF

    #2
    imported post

    See the sample NT EFS in the Help Guide (also installed on your PC) that does work.
    RayNinjaTrader Customer Service

    Comment


      #3
      imported post

      Thanks for the reply. If I modify that script to represent the NTConnected status in the formula output window I get "false".

      Comment


        #4
        imported post

        Is Automated Trading Enabled via the File menu in the Control Center window?
        RayNinjaTrader Customer Service

        Comment


          #5
          imported post

          Hi,

          Yes the Automated Trading is enabled, the ATI at the bottom right is green and the log says that NT has established a connection to the eSignal Data Manager.

          Since I posted last I have downloaded the very latest version and still have the same problem.

          Regards,
          MuthaF

          Comment


            #6
            imported post

            For clarification, when you call this function, it returns a value of "-1" ?
            RayNinjaTrader Customer Service

            Comment


              #7
              imported post

              Yes

              Comment


                #8
                imported post

                Will get back to you Monday morning, have escalated this.
                RayNinjaTrader Customer Service

                Comment


                  #9
                  imported post

                  Many thanks

                  Comment


                    #10
                    imported post

                    Please try the the sample script unaltered. Does this work as intended?
                    RayNinjaTrader Customer Service

                    Comment


                      #11
                      imported post

                      It loads but does not buy any contracts which is why I started to look into the reasons why and the state of NTConnected

                      Comment


                        #12
                        imported post

                        On what instrument?
                        RayNinjaTrader Customer Service

                        Comment


                          #13
                          imported post

                          FDAX instrument. I've retried the NTSample.efs script and this time it seems to be trying to reinstall NinjaTrader. It's trying to install (very slowly) but will let you know what happens. It seems to be a DLL registration issue which would make sense except I was able to run NT by itself and it's only he ATI interface that seems to be the issue.

                          Comment


                            #14
                            imported post

                            FDAX is not supported out of the box since the instrument mapping will not work since eSignal has a "-d" at the end of the instrument. You have to create a new wrapper function for NTCommand() that passes in the correct instrument name for FDAX which is "FDAX 06-06". Trythat. If you use the script on another instrument like ES you will that it works as designed.
                            RayNinjaTrader Customer Service

                            Comment


                              #15
                              imported post

                              I've found that out and changed my code for NTCommand. What is still the issue is NTConnected. For NTCommand I've got an EFS object that is loading all the stuff I need into that structure.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by gngmpwdws, Today, 09:58 PM
                              0 responses
                              1 view
                              0 likes
                              Last Post gngmpwdws  
                              Started by darkgreen, Today, 03:35 PM
                              1 response
                              13 views
                              0 likes
                              Last Post lmatiukas  
                              Started by imalil, Today, 09:46 PM
                              0 responses
                              6 views
                              0 likes
                              Last Post imalil
                              by imalil
                               
                              Started by SAITON, Today, 09:03 PM
                              0 responses
                              5 views
                              0 likes
                              Last Post SAITON
                              by SAITON
                               
                              Started by suprsnipes, Today, 08:26 PM
                              0 responses
                              5 views
                              0 likes
                              Last Post suprsnipes  
                              Working...
                              X