• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

frozen chart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    frozen chart

    See attached chart. NT not updating again. This time, the culprit is a Forex chart, $AUDUSD, weekly. Just stopped updating at the beginning of October. All my other charts in that workspace update fine. "Reload all historical data" didn't work. Why does this keep happening?
    Attached Files

    #2
    Hello,

    Thank you for your post.

    Please right click in the chart and select Data Series. On the right side of the menu which date is used in the End Date field?
    KyleNinjaTrader Customer Service

    Comment


      #3
      why is End Date not updating automatically?

      Thanks, Kyle,
      The end date for that one chart is stuck back on 9/28/15, as you'd expect because the chart is not updating.
      The question is why is the End Date not updating automatically on this one chart, whereas the End Date on all the other charts in the workspace (and all the charts in my 25 workspaces) are all updating automatically? Why is this one chart stuck, or rather, HOW did it get stuck so that it's End Date is not updating automatically? Did I inadvertently do something to make it so that the End Date would get stuck and not update? If so, what could I have done to cause this (or is this just a random glitch?).

      Tasuki

      Comment


        #4
        Hello Tasuki,

        Thank you for your post,

        What is selected for Load days based on? Days, bars, custom range.
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          Hi EricB,
          Days to load, 1825, just like the other weekly chart in this workspace that's updating perfectly. So, apparently there's some other problem (?).
          Thanks. I sure would love to figure out this mystery!
          Tasuki

          Comment


            #6
            Hello Tasuki,

            Thank you for your reply,

            Will it let you change the End Date setting, or does it always revert back to 9/28/15?

            What Session Template is applied to the chart? (Also in the Data Series menu)

            Also, what time zone is your PC set to?
            Eric B.NinjaTrader Customer Service

            Comment


              #7
              Thanks, Eric. Session template is just "use instrument settings". I tend not to change that much. Time zone is for California. I was able to manually change the end date, but it remains to be seen whether it will properly update tomorrow or not. Will keep you posted!
              From the diverse sorts of questions you're asking, I gather that you don't have a simple answer as to why this happens. If you look back at my previous posts to this forum, several of them are about this exact problem. When I look at a chart, I have to trust that it's updating properly. If I have to inspect every chart I use every time I use it to determine whether it's accurate or not, well, I'll find another charting package! As I have mentioned before, this vexing problem is the main reason I haven't adopted Ninjatrader as the charting package I use for live trading.

              Comment


                #8
                Hello Tasuki,

                Thank you for the follow up, certainly let me know how the test goes.

                I understand your frustration about that chart. Because the other charts in your workspace seem to be taking the End date correctly, as a workaround, I suggest opening a new chart (File > New) to replace the one with the unexpected End Date.

                You can create a chart template of your settings in the first chart so you don't have to rebuild it manually.

                To do this, right click on the chart and select Templates > Save As... You can name the template anything you would like (I recommend something that will remind you of the function of the template). Press OK to save the template.

                Now, when opening up a new chart, you can recall your saved settings by selecting the template from the bottom right of the Data Series window, or on an open chart, right click > Templates > Load...
                Eric B.NinjaTrader Customer Service

                Comment


                  #9
                  Thanks, Eric. I've been using the workaround that you suggest for the past few years (this has been happening for a long while) and that's OK when I'm just using NT for nightly study of EOD charts. But to go live, I need to have reliable charts.
                  BTW, am I the only person who has reported this problem? It's happened on two of my computers, both XP Pro. Could there be some glitch with this older operating system?
                  Taz

                  Comment


                    #10
                    I have seen similar behavior before with other cases -- the causes are related to the time zone the PC is using and the Session Template. In these instances, however, the date was always a day behind or ahead.

                    I don't think this would be related to the operating system, but because it's happened in multiple instances, I suggest checking what is similar between the two charts (indicators, addons) to see if you can narrow down what might be causing this to occur.
                    Eric B.NinjaTrader Customer Service

                    Comment


                      #11
                      Thanks, Eric.
                      In this case, it was a naked chart. Just price, nothing else, as shown in the attached file. So, no indicators, not even volume. The session template, as mentioned, is also just "use instrument settings" like all the other charts which are not "misbehaving".

                      What I can't recall, however, is whether I had originally put indicators on the chart and took them off, or whether I may have changed symbols. I have found that NT doesn't seem to like it when you change something in "Data Series".

                      Well, I'm very disappointed that there is no clear solution to this problem because it prevents me from using NT for live trading. Heaven forbid if a chart were to freeze like this while I was in a trade. yipes!

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by BabyWhaler, Today, 05:06 PM
                      4 responses
                      15 views
                      0 likes
                      Last Post BabyWhaler  
                      Started by bouncetherubble, Today, 05:56 PM
                      0 responses
                      4 views
                      0 likes
                      Last Post bouncetherubble  
                      Started by claxxical, Today, 05:48 PM
                      0 responses
                      4 views
                      0 likes
                      Last Post claxxical  
                      Started by 7robert, Today, 03:09 PM
                      1 response
                      11 views
                      0 likes
                      Last Post NinjaTrader_Jonathan  
                      Started by Johnny, Today, 02:54 PM
                      0 responses
                      10 views
                      0 likes
                      Last Post Johnny
                      by Johnny
                       
                      Working...
                      X