• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

You have custom NinjaScript files on your PC...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    You have custom NinjaScript files on your PC...

    When I try to import a custom indicator zip file, I get the following error: "You have custom NinjaScript files on your PC that have programming errors. These errors must be resolved before you can import a NinjaScript Archive File."

    When I go to Tools to select Edit NinjaScript to compile, that option is not there for me. Can you help me get that feature?

    I just installed the latest version of NInjaTrader, but that didn't fix anything.

    My Machine ID: 8EDDEA4004FBB9654190E8E56CDD99D5





    Thanks,
    Shane
    Last edited by shaneaw; 01-10-2016, 12:42 PM.

    #2
    Please redo your post, blanking out your license key. You do not want anyone else using it because it would look like you are logging in simultaneously from 2 computers and violating your NT license.
    Last edited by koganam; 01-10-2016, 01:24 PM. Reason: Deleted sensitive info.

    Comment


      #3
      Originally posted by koganam View Post
      Please redo your post, blanking out your license key. You do not want anyone else using it
      Thanks, but you quoted my original post, so can you please edit yours now to remove it from there as well?

      Thanks,
      Shane

      Comment


        #4
        Originally posted by shaneaw View Post
        Thanks, but you quoted my original post, so can you please edit yours now to remove it from there as well?

        Thanks,
        Shane
        My mistake. I apologize for routinely quoting the original message in my response.

        Comment


          #5
          Originally posted by koganam View Post
          My mistake. I apologize for routinely quoting the original message in my response.
          No problem. Thanks again!

          Comment


            #6
            Hello shaneaw,

            Thank you for your post.

            Please follow the instructions below to see where the errors are coming from after compiling the indicator. This will allow you to debug the indicator/strategy or remove it from your PC. If you are wondering why you receive an error when compiling only one indicator, it is because NinjaTrader always compiles all indicators and strategies - not just one. This is done to give you the highest runtime performance possible.

            Open NinjaTrader
            From the Control Center select the Tools menu--> select the Edit NinjaScript menu item--> select Indicator
            Select any indicator and double click on it (we need only to open and compile one script to see all compile errors for all files).
            A new window will appear and you will need to right click in the window and select Compile to compile the indicators.
            At the bottom of the window a new section will appear where you can find the error locations.
            From there you have the option to comment out offending code sections, remove the complete indicator or debug it to be able to compile again.
            If you are unsure as to what the error is indicating, please send me a screenshot of the error with the name and description fields clearly readable.

            To send a screenshot with Windows 7 or newer I would recommend using Window's Snipping Tool.

            Click here for instructions


            Alternatively to send a screenshot press Alt + PRINT SCREEN to take a screen shot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

            Click here for detailed instruction

            We have also collected more comprehensive steps for resolving NinjaScript programming errors in this tip on our forums - http://www.ninjatrader.com/support/f...ead.php?t=4678
            KyleNinjaTrader Customer Service

            Comment


              #7
              Originally posted by NinjaTrader_Kyle View Post
              Hello shaneaw,

              Thank you for your post.

              Please follow the instructions below to see where the errors are coming from after compiling the indicator. This will allow you to debug the indicator/strategy or remove it from your PC. If you are wondering why you receive an error when compiling only one indicator, it is because NinjaTrader always compiles all indicators and strategies - not just one. This is done to give you the highest runtime performance possible.

              Open NinjaTrader
              From the Control Center select the Tools menu--> select the Edit NinjaScript menu item--> select Indicator
              Select any indicator and double click on it (we need only to open and compile one script to see all compile errors for all files).
              A new window will appear and you will need to right click in the window and select Compile to compile the indicators.
              At the bottom of the window a new section will appear where you can find the error locations.
              From there you have the option to comment out offending code sections, remove the complete indicator or debug it to be able to compile again.
              If you are unsure as to what the error is indicating, please send me a screenshot of the error with the name and description fields clearly readable.

              To send a screenshot with Windows 7 or newer I would recommend using Window's Snipping Tool.

              Click here for instructions


              Alternatively to send a screenshot press Alt + PRINT SCREEN to take a screen shot of the selected window. Then go to Start--> Accessories--> Paint, and press CTRL + V to paste the image. Lastly, save as a jpeg file and send the file as an attachment.

              Click here for detailed instruction

              We have also collected more comprehensive steps for resolving NinjaScript programming errors in this tip on our forums - http://www.ninjatrader.com/support/f...ead.php?t=4678
              When I go to Tools to select Edit NinjaScript to compile, that option is not there for me. That is the reason I created this thread. Can you help me get that feature?

              Comment


                #8
                Hello,

                Please contact me by email at PlatformSupport [AT] NinjaTrader [DOT] com. In the message please include a link to this forum thread and a copy of your license key. You will find the key in the Help > License Key menu.
                KyleNinjaTrader Customer Service

                Comment


                  #9
                  Originally posted by NinjaTrader_Kyle View Post
                  Hello,

                  Please contact me by email at PlatformSupport [AT] NinjaTrader [DOT] com. In the message please include a link to this forum thread and a copy of your license key. You will find the key in the Help > License Key menu.
                  Email sent. Thanks!

                  Comment


                    #10
                    You have custom NinjaScript files on your PC...

                    Same problem ... I think I broke it

                    Email sent with licence key included as per post #8.

                    Thanks

                    David

                    Comment


                      #11
                      Hi..... I have the following error can you help ?

                      "you have the custom Ninjascript files on your PC that have programming errors. These errors must be resolved before you can import a ninjascript archive file."

                      I also get the following errors when I try to compile an indicator : see attached file

                      Thanks in advance

                      Rob
                      Attached Files

                      Comment


                        #12
                        Originally posted by Rob001 View Post
                        Hi..... I have the following error can you help ?

                        "you have the custom Ninjascript files on your PC that have programming errors. These errors must be resolved before you can import a ninjascript archive file."

                        I also get the following errors when I try to compile an indicator : see attached file

                        Thanks in advance

                        Rob
                        Your "references" are defective. Before we can tell you how or why, we shall have to see the entire error message that is in that picture.

                        Comment


                          #13
                          Hi....thanks for your help..... see attached file for the full error :
                          Not sure why it is reporting this error as I have these indicators working in Ninja
                          Attached Files

                          Comment


                            #14
                            Originally posted by Rob001 View Post
                            Hi....thanks for your help..... see attached file for the full error :
                            Not sure why it is reporting this error as I have these indicators working in Ninja
                            The message seems to be pretty clear.
                            • Did you perchance relocate your "Documents" folder?
                            • Are you logged on as user Rob?
                            • Have you maybe deleted the referenced files?
                            • Check and be sure that the files are at the referenced location.

                            Comment


                              #15
                              Hi ..... the files do exist but they exist in a directory that is :-

                              C:\Users\RV\..... Not C:\Users\Rob\...

                              what do i need to do to rectify this ?

                              Thanks

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Bionian, Today, 02:47 PM
                              1 response
                              5 views
                              0 likes
                              Last Post NinjaTrader_Kate  
                              Started by RickB60, Today, 01:55 PM
                              1 response
                              10 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by filopearson, Today, 01:18 PM
                              6 responses
                              11 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by kujista, Today, 12:28 PM
                              3 responses
                              14 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by mroberts_nos, Today, 11:47 AM
                              1 response
                              11 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Working...
                              X