• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

ATM is using "Stop Limit" order type for Stop Loss

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ATM is using "Stop Limit" order type for Stop Loss

    Hi there,

    Please take a look at the attached two screenshots - each showing an open position on crude. In both screenshots you can see that my Stop Losses are getting executed as "Stop Limit" orders. Also, it seems that the default "limit" price of the "Stop Limit" order is 20 ticks from the stop - irrespective of the "Stop Loss" or "Target Size" I set in the ATM.

    Question 1: How is the "limit" size of the "Stop Limit" order being determined, is it different for each market?

    Question 2: Where can I change the limit size of the "Stop Limit" order?

    Question 3: What order type(s) could I use so that "if price hits my stop just get me out of the market immediately"?

    Question 4: How do I then change the order type of my "Stop Loss" ? At the moment the way I submit my orders is I select the ATM in the chart trader, then I right click the chart and then click, for instance, "Buy Limit 2 @ 28.11" - see attached place_ATM_order.png

    Thank-you once again for the continued support,
    Michelle
    Attached Files

    #2
    Hello Michelle,

    Thank you for your post.

    1 & 2.) When an ATM strategy uses a Stop Limit order to act as a Stop Loss that order will have a 20 tick offset between the Stop and Limit prices. Unfortunately, there is no way to specify another offset for ATM Strategy Stop Limit orders.

    3 & 4.) To ensure that ATM Strategies use Stop orders for Stop Losses, please right click in the window where you are submitting your orders and select Properties. In the Properties menu set the 'Use Stop Market for Stop Loss Orders' property to True then click OK.

    If other questions come up which I could assist with please let me know.
    KyleNinjaTrader Customer Service

    Comment


      #3
      Hi Kyle. I think you and I are working a 24 hour shift?? Thanks for the reply.

      Originally posted by NinjaTrader_Kyle View Post
      3 & 4.) To ensure that ATM Strategies use Stop orders for Stop Losses, please right click in the window where you are submitting your orders and select Properties. In the Properties menu set the 'Use Stop Market for Stop Loss Orders' property to True then click OK.
      I struggled to follow your instructions, I did the below:

      1. Right click the CHART TRADER panel
      2. Select "Chart Trader Properties"
      3. set the 'Use Stop Market for Stop Loss Orders' property to True
      4. Click "Apply"
      5. Click "Set Default"
      6. Click OK



      Question: s this correct and will it hold for all newly created charts going forward??
      Attached Files
      Last edited by michellepace; 01-21-2016, 12:27 AM.

      Comment


        #4
        Hello michellepace,

        This is correct

        This setting will now be the default setting for all new charts
        Christopher S.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by tradykat, Today, 06:07 PM
        0 responses
        6 views
        0 likes
        Last Post tradykat  
        Started by tradykat, Today, 05:09 PM
        0 responses
        10 views
        0 likes
        Last Post tradykat  
        Started by jeronymite, Today, 04:57 PM
        0 responses
        7 views
        0 likes
        Last Post jeronymite  
        Started by caveat_lector, Today, 04:34 PM
        0 responses
        6 views
        0 likes
        Last Post caveat_lector  
        Started by Futurestrader00, Today, 04:30 PM
        0 responses
        17 views
        0 likes
        Last Post Futurestrader00  
        Working...
        X