• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Connecting to Simulated Feed Erases Historical data and template on chart

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Connecting to Simulated Feed Erases Historical data and template on chart

    I'm working on automated strategies.

    When I load a template, my historical data shows up.

    When I then connect to the simulated data feed, to work on my stops and targets, the data disappears, and all indicators are wiped from my chart.

    Yesterday, it was working fine, load chart template, with indicators, work on strategy, connect to simulated data feedback, then the simulated feed, with trend control worked, just picking up where the historical data left off.

    Today, doing same thing, doesn't work..

    I checked, my instrument template is set to 24/5, but if I put it at 24/7 no change (it was working fine yesterday, Saturday might, anyway). I also made sure chart data was initially instrument default, then I manually changed it to 24/7 and 24/5, no difference.

    Also, if I connect to the simulated feed, my template won't actually load. This is now happening across all my chart templates (not loading if connected to sim feed).

    #2
    Hell _Cujo, and thank you for your question.

    The simulated data feed provides internally generated market data and is not reflective of the actual market. This connection is ideal for training, and becoming familiar with the NinjaTrader application. Because simulated prices are not reflective of actual market conditions, and as a result your simulated prices may vary dramatically from the market, historical data is not automatically loaded.

    If you would like historical data to appear on one of your charts while connected to the simulated data feed,

    • Load your chart, with your desired bar type and period value
    • Connect to your live data feed provider
    • Select your chart and press ctrl + shift + r
    • Disconnect from your live data feed provider
    • Connect to the simulated data feed

    If you would like a more reliable way to work with historical data, I would like to suggest using the Market Replay connection (renamed Playback Connection in NinjaTrader 8). That is documented here,


    http://ninjatrader.com/support/helpG...ket_replay.htm
    http://ninjatrader.com/support/helpG...connection.htm


    Please let us know if there are any other ways we can help.
    Jessica P.NinjaTrader Customer Service

    Comment


      #3
      Hi Jessica,

      Thanks for the advice. I fixed it.

      I'm not sure what the problem was, but I was also having trouble with loading the Bloodhound strategy I was working with.

      I restored a backup, and NT is working fine now, simulated feed picking up from historical so I can keep working on the stops.

      Thanks!

      Comment

      Latest Posts

      Collapse

      Topics Statistics Last Post
      Started by Tradarr, Today, 06:25 PM
      2 responses
      12 views
      0 likes
      Last Post Tradarr
      by Tradarr
       
      Started by cocopod, Today, 04:47 PM
      1 response
      6 views
      0 likes
      Last Post NinjaTrader_JoshG  
      Started by digibob, Today, 02:47 AM
      2 responses
      14 views
      0 likes
      Last Post NinjaTrader_Kate  
      Started by mntemel, Today, 03:31 PM
      4 responses
      23 views
      0 likes
      Last Post mntemel
      by mntemel
       
      Started by mrlucky1x, Today, 03:14 PM
      2 responses
      7 views
      0 likes
      Last Post mrlucky1x  
      Working...
      X