• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Roll-Over to ZB 03-17 having errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Roll-Over to ZB 03-17 having errors

    This evening, I rolled my GC and ZB workspaces (using CQG). The GC 02-17 workspace displays and behaves normally. The ZB 03-17 workspace does NOT. For example, the attached file shows a 1 min chart; and the chart starts from the SUN Open with the
    GC 12-16 data, then after 3 minutes, there's a huge gap down to the correct currently trading values. I've shutdown NT, restared, and created the 1m chart in a New Workspace, but still the bug remains. Any suggestions????
    Attached Files
    Last edited by ohtrader; 11-27-2016, 07:41 PM. Reason: Add pix of ZB 1m Chart

    #2
    Hello ohtrader,

    By default, NinjaTrader automatically merges data from previous expiries in charts. For example, if you create an ZB 03-17 chart before 11/30/2016, historical data is loaded from the 12-16 expiry. Realtime data is received from the 03-17 expiry. There is a price difference between the two expiry months which causes the gap.

    You can change the rollover dates or disable merging of data to solve the issue.

    Please go to Control Center-->Tools-->Instrument Manager, highlight the ZB and click Edit. Select the Misc-tab and click the 'Contract Months' option at the bottom. Click the '...' button that appears. Select the 03-17 expiry month and change the rollover date to today or an earlier date.

    Click OK. Remove and re-add the ZB 03-17 in your instrument list for the change to take effect and click OK in the Instrument Manager. Instructions can be found at the link below.
    http://www.ninjatrader.com/support/h...ment_lists.htm

    Create a new ZB 03-17 chart and check if data is loaded as expected.

    You can disable the merging of data after you clicked Edit while the ZB instrument is highlighted in the Instrument Manager. Subsequently, set 'Merge policy' to DoNotMerge. Click OK. Remove and re-add the ZB 03-17 as well and create a new chart. It will now only load historical data from the 03-17 expiry in the chart.
    JasonNinjaTrader Customer Service

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by saeed, Today, 12:32 PM
    3 responses
    27 views
    0 likes
    Last Post NinjaTrader_PatrickG  
    Started by motog4, Today, 11:42 AM
    3 responses
    14 views
    0 likes
    Last Post NinjaTrader_PatrickG  
    Started by derivtrader, Today, 11:20 AM
    5 responses
    27 views
    0 likes
    Last Post derivtrader  
    Started by TAJTrades, Today, 10:34 AM
    1 response
    7 views
    0 likes
    Last Post NinjaTrader_ChrisL  
    Started by timcjpfx, Today, 10:20 AM
    1 response
    6 views
    0 likes
    Last Post NinjaTrader_ChelseaB  
    Working...
    X