Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Bug in time scale in Charts?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bug in time scale in Charts?

    Hi. I'm not sure why I am having this problem on 2 different machines.

    If you open up a Chart window and select 15 minute time interval (actually this happens on 1 minute time frames too, but its very noticeable on 15 minutes), when the time is at 21:03, the chart window will show you that it is updating the bar for 21:15 and not 21:00 which is what is expected. I am developing custom indicators and I scanned all the various topics under Charts and cant believe if this was a bug that no one reported it before? I have it on both machines, including one machine where I deleted my custom indicator, it still shows the same "time frame ahead" problem. I am not loading my indicator yet when I observe this, so I dont believe its my indicator.

    Also regarding my custom indicator development, I am trying towiden the intervals between the bars. I have used my mouse to drag to do this, but it seems to stop at a certain point and I was wondering if there was a way to widen it further. My indicators involve plotting text on the price points and right now, the text from different bars run into each other.

    Also is there a way to set the y-axis to plot all the price points on the e-mini by default? In other words, I would like the y-axis to show 1256, 1255.75, 1255.5, 1255.25, 1254, etc.

    Thanks







    #2
    imported post

    richard wrote:
    Hi. I'm not sure why I am having this problem on 2 different machines.

    If you open up a Chart window and select 15 minute time interval (actually this happens on 1 minute time frames too, but its very noticeable on 15 minutes), when the time is at 21:03, the chart window will show you that it is updating the bar for 21:15 and not 21:00 which is what is expected. I am developing custom indicators and I scanned all the various topics under Charts and cant believe if this was a bug that no one reported it before? I have it on both machines, including one machine where I deleted my custom indicator, it still shows the same "time frame ahead" problem. I am not loading my indicator yet when I observe this, so I dont believe its my indicator.

    >>> This is by design. All ticks betwenn 21:00:00 and 21:01:00 make it into the 21:01 bar (on a 1-minute chart). This e.g. prevents you from potentially using data which is in the future.

    Also regarding my custom indicator development, I am trying towiden the intervals between the bars. I have used my mouse to drag to do this, but it seems to stop at a certain point and I was wondering if there was a way to widen it further. My indicators involve plotting text on the price points and right now, the text from different bars run into each other.

    >>> There are NT internal limits which you can not exceed.


    Also is there a way to set the y-axis to plot all the price points on the e-mini by default? In other words, I would like the y-axis to show 1256, 1255.75, 1255.5, 1255.25, 1254, etc.

    >>> Not doable

    Thanks





    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by M_ichel, 01-29-2023, 11:17 AM
    4 responses
    64 views
    0 likes
    Last Post NinjaTrader_Jason  
    Started by rc5781, 06-16-2022, 07:18 AM
    4 responses
    82 views
    0 likes
    Last Post RoboTrader  
    Started by carnitron, 09-20-2022, 10:35 AM
    13 responses
    225 views
    0 likes
    Last Post jeronymite  
    Started by Douglee, Yesterday, 08:00 PM
    0 responses
    51 views
    0 likes
    Last Post Douglee
    by Douglee
     
    Started by DT215, Yesterday, 07:49 PM
    0 responses
    50 views
    0 likes
    Last Post DT215
    by DT215
     
    Working...
    X