• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Visual Studio not found by Ninja Trader

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Visual Studio not found by Ninja Trader

    I have NinjaTrader 8 and Visual Studio 2017 installed on windows. In the NinjaScriptEditor I

    1) Enable debugging
    2) Compile the script
    3) Select "Open project in visual studio" button

    and I get a dialog box that says "Failed to find Visual Studio installation".

    However, if I have Visual Studio already open on the desktop, I get a dialog box with the message "Please shut down all running instances of Visual Studio", which tells me NinjaTrader is aware of visual studio.

    Is there a configuration setting for the visual studio location? Or is this possibly a Visual Studio version issue?

    Doug

    #2
    Hello dougservice,

    Thank you for the post.

    This is likely due to the visual studio installation, can you tell me when you installed VS was this the only version installed on this PC and what specifically did you select when installing VS? In the installation tool, you can select many different programming languages and options, for ninja trader you would need the C#/ .net desktop development pack. Did you select the packages you are presented with or do a selective install?

    Alternatively are you able to directly open the project successfully in visual studio? You can double-click the project file in the folder: Documents\NinjaTrader 8\bin\Custom\NinjaTrader.Custom.csproj. If prompted, select Visual Studio 2017 or Visual Studio Version Selector.

    I look forward to being of further assistance.

    JesseNinjaTrader Customer Service

    Comment


      #3
      Hello Jesse,

      A couple of days ago I set up a new machine for running NinjaTrader. I installed Windows, NinjaTrader 8, and then Visual Studio 2017.

      When I go directly to the project file in the file manager, as you suggested, and double-click, the project opens in Visual Studio 2017, I can attach to the NinjaTrader process and set breakpoints that get hit on the strategy running in a chart window.

      You made me realize this might be a path variable problem, so I typed devenv.exe in a powershell window and it could not find Visual Studio. I then added the directory for devenv.exe to the path and I was able to run Visual Studio 2017 from powershell after I restared it. I restarted NinjaTrader, but it still cannot find Visual Studio.

      Maybe NinjaTrader has to be installed after Visual Studio? Or is Ninja Trader looking for the version selector?

      Comment


        #4
        Hello dougservice,

        Yes, this still sounds like the VS install. When you installed VS, did you select the .net development package in total or did you pick and choose the features that you wanted? I have only tested VS by using the total install options if you are selectively choosing components that may be why it's not being found. Did you also install VS to the standard location it suggested?

        The platform should not need to be installed before visual studio it should be able to pick it up after it is installed. You may try reinstalling the platform to see if that helps but this still sounds like it is just not picking up the specific version you have installed. Which specific version of VS did you install? Is this community or one of the other editions?

        typing devenv.exe in a command prompt is also not the normal way to open VS so I wouldnt expect that to work anyway, you would generally need to supply the full path to the exe if you start it from a command prompt. Adding the bin folder to the path would not help with NinjaTrader specifically.


        I look forward to being of further assistance.
        JesseNinjaTrader Customer Service

        Comment


          #5
          Hello Jesse,

          Visual Studio now launches properly from the strategy editor. Under the .NET section of the Visual Studio installer, I had left the F# language and .NET Core 1.0 - 1.1 options unchecked. I reran the Visual Studio installer, added those components, and now Visual Studio launched properly from the strategy editor.

          Thanks

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by Orden33, Today, 10:09 AM
          2 responses
          7 views
          0 likes
          Last Post Orden33
          by Orden33
           
          Started by martyn73, Today, 10:18 AM
          4 responses
          10 views
          0 likes
          Last Post NinjaTrader_ChelseaB  
          Started by silverm3170, Today, 10:03 AM
          3 responses
          3 views
          0 likes
          Last Post NinjaTrader_Jesse  
          Started by diff24rac, 04-04-2018, 05:32 AM
          6 responses
          481 views
          0 likes
          Last Post fx.practic  
          Started by gma17, Today, 08:58 AM
          3 responses
          11 views
          0 likes
          Last Post NinjaTrader_ChelseaB  
          Working...
          X