• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT IDE problem?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ttodua
    replied
    kevinenergy thanks for tip!

    Leave a comment:


  • kevinenergy
    replied
    You can manually set the language version in Visual studio so that it stops proposing code completions for C# 6 or 7 which are not supported by Ninjatrader's compiler. The attached screenshot shows how to do this.

    If you're using resharper, then add this to your sln.DotSettings file:

    <s:String x:Key="/Default/CodeInspection/CSharpLanguageProject/LanguageLevel/@EntryValue">CSharp50</s:String>
    Last edited by kevinenergy; 02-20-2019, 03:51 AM.

    Leave a comment:


  • NinjaTrader_Jim
    replied
    Hello TazoTodua,

    Thanks for your post.

    This is correct that this sort of custom C# code would not be supported by NinjaTrader. We are tracking interest to update the versions of .NET and C# that NinjaTrader uses under the ticket ID SFT-3124. I have added a vote on your behalf.

    As with other feature requests, we cannot offer an ETA or promise of fulfillment, but your interest is tracked.

    Please let us know if we can be of further assistance.

    Leave a comment:


  • NinjaTrader_Jim
    replied
    Hello TazoTodua,

    Thanks for your post.

    This is correct that this sort of custom C# code would not be supported by NinjaTrader. We are tracking interest to update the versions of .NET and C# that NinjaTrader uses under the ticket ID SFT-3124. I have addded a vote on your behalf.

    As with other req

    Leave a comment:


  • ttodua
    replied
    Ah, I see this is still similar to my old topic: https://ninjatrader.com/support/foru...e-not-possible

    it's not supported in NT. ok.

    Leave a comment:


  • ttodua
    started a topic NT IDE problem?

    NT IDE problem?

    NT ide marks as syntex error such lines:

    Code:
    public Brush xyz => somebrush;
    I think because NT ide doenst fully support Lambda expressions?

    in ide, this comes out:
    Click image for larger version  Name:	t5SOfbm.png Views:	1 Size:	3.6 KB ID:	1048239

    similarly, we cant use this:

    public int smth { get; set; } = 123;

    but Visual Studio allows.
    Last edited by ttodua; 02-14-2019, 02:15 PM.

Latest Posts

Collapse

Topics Statistics Last Post
Started by qewcool, Today, 01:14 AM
0 responses
2 views
0 likes
Last Post qewcool
by qewcool
 
Started by fredrikn, 05-08-2019, 04:01 AM
17 responses
669 views
1 like
Last Post emtrader  
Started by zacharydw00, Yesterday, 10:19 PM
0 responses
3 views
0 likes
Last Post zacharydw00  
Started by chafan11, Yesterday, 09:28 PM
0 responses
7 views
0 likes
Last Post chafan11  
Started by GreenspanAlec, Yesterday, 05:32 PM
0 responses
7 views
0 likes
Last Post GreenspanAlec  
Working...
X