• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

AddBar Question

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Hello Zeos6,

    Yes, that is correct. You would need to fill in the details like the existing ES instrument and provide a new name for your custom instrument that you can find it by.

    Please let me know if I may be of further assistance.
    JesseNinjaTrader Customer Service

    Comment


      #17
      Hi Jesse,

      I have tried this. NT is not recognizing the symbol. I get the error

      Time Category Message 4/23/2018 4:06:10 PM Default Error on requesting bars series: 'Unknown instrument 'ES1 06-18''

      Comment


        #18
        Hello Zeos6,

        Have you defined the new symbols name as ES1 and also added a 06-18 contract rollover date?

        You would need to also copy the rollovers if you are creating a Futures instrument. The Rollover dates can be managed using the editor below the symbol mapping section. There is further information on creating rollover dates in the help guide here: https://ninjatrader.com/support/help...tMonthsSection

        Please let me know if I may be of further assistance.
        JesseNinjaTrader Customer Service

        Comment


          #19
          Hi Jesse,
          Yes. I duplicated the ES futures contract parameters, symbol maps and rollovers. The only thing I changed is the Master Instrument name in the General Tab. When I tried to create a chart based off the new instrument, that's when I got the error. Am I missing something?

          Comment


            #20
            Hello Zeos6,

            I would be unsure what may have gone wrong during the setup, could you provide an image of the values you entered into the new instrument configuration? I was able to see this working on my end by creating an instrument named ES2 and setting the same values/rollover as the ES future instrument.

            Please let me know if I may be of further assistance.
            JesseNinjaTrader Customer Service

            Comment


              #21
              Hi Jesse,

              The pic of the values I used is attached. Please let me know what I am missing. I would really appreciate it. Thank you.
              Attached Files

              Comment


                #22
                Hello,

                Thank you for the image.

                Yes, that looks to be set up I am not certain why the chart would be unable to see the instrument. Can you tell me, from a chart if you click the spyglass next to the instrument picker to search for the instrument, can you select it there? If you double click the instrument from this search, the chart should load it if possible. Do you get the same message or is it listed in the overall list?

                I look forward to being of further assistance.
                JesseNinjaTrader Customer Service

                Comment


                  #23
                  Hi Jesse,

                  When I click the spyglass next to the instrument picker to search for the instrument, I can select it there. It is present there so yes, I can select it. No problem so far. When I double click the instrument from this search, the chart should does not load. That is when I get the error message.

                  Actually I use the name ES_1. Do you think the underscore might be an issue here?
                  EDIT: The underscore is not the issue. I tried adding a new version names ES1 and still had the error.

                  Does this actually work for you? Have you tried to actually put a chart up?

                  Also, is there an easy way to copy the information for an instrument? It is a pain inputting the roll over dates manually. It would be nice to simply copy the information over to a new instrument.
                  Last edited by Zeos6; 04-23-2018, 04:30 PM.

                  Comment


                    #24
                    Hello Zeos6,

                    The underscore wouldn't be a problem, I can also see that both underscores and not are working on my end. As noted previously I do see this working on my end during my tests so I am not certain why you would be getting an error here.

                    Can you tell me, what connection provider are you using? Potentially this has something to do with the connection setup you are using opposed to what I am.

                    Regarding duplicating the instrument, there is currently not a way to directly duplicate the instrument each instrument would need to be configured from start to finish.

                    I look forward to being of further assistance.
                    JesseNinjaTrader Customer Service

                    Comment


                      #25
                      Hi Jesse,

                      So are you telling me you can actually get a chart loaded with the "new" instrument?
                      I am using Rithmic for my data.

                      Comment


                        #26
                        Hello Zeos6,

                        Yes, I can see this working on my end.

                        I will need to explore this further to see if the outcome changes while using the same connection as you are. The settings you have used seem to be correct. Once I have further details I will reply back here.

                        Please let me know if I may be of further assistance.
                        JesseNinjaTrader Customer Service

                        Comment


                          #27
                          Thanks Jesse. I really appreciate it.

                          Comment


                            #28
                            Hello Zeos6,

                            After further research, it appears this is due to the connection being used. I see that creating the second symbol does work on some of the other connection adapters but does produce the error you have when using rithmic. In this case, as there is no way to disable the way the adapter is checking the instrument, it would not be possible for rithmic it seems.

                            A workaround may be to preload the data on the rithmic connection for the normal primary instrument and then disconnect and reconnect to the Simulated data feed or another feed which doesn't have this limitation.


                            Please let me know if I may be of additional assistance.
                            JesseNinjaTrader Customer Service

                            Comment


                              #29
                              Thanks Jesse,

                              That's really inconvenient but I get it. I really think we do need a way to duplicate an instrument and a wait to paint our own bars. However, thank you for your help.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by indy73, Today, 04:42 PM
                              0 responses
                              9 views
                              0 likes
                              Last Post indy73
                              by indy73
                               
                              Started by Italianforex, Today, 06:20 AM
                              2 responses
                              12 views
                              0 likes
                              Last Post gplatis
                              by gplatis
                               
                              Started by alextrd, Today, 01:51 PM
                              1 response
                              13 views
                              0 likes
                              Last Post NinjaTrader_JoshG  
                              Started by Boonfly8, Today, 12:10 PM
                              1 response
                              5 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by NinjaTrader_PaulH, Today, 11:24 AM
                              0 responses
                              7 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Working...
                              X