• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Exporting an indicator doesn't detect dependencies

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Exporting an indicator doesn't detect dependencies

    I'm attempting to export an indicator, which uses EMA and ATR under the hood. Unfortunately, the export process is not detecting them as dependency and I have no other way to add them to the compiled assembly. Has anyone been able to figure out how to deal with this problem?

    Thanks.

    #2
    Hello xsgex,

    In some complex scenarios this can occur, to get around this you would need to select "System Indicators" in the drop down in the export menu. This will let you pick any of the system indicators reported missing and add them to allow the export to continue, could you try this and make sure this works for you?

    I would also like to ask if you are able to create a sample of just the structure you used which fails the export. I can likely report this item to development depending on how your script has been coded. I would not be able to directly debug the script/s to find why this is happening but we can work together to isolate this further to make a report. If you can reproduce this with a new empty indicator that simply replicates the structure of yours, that would be helpful for making a report. Working toward a simplified way to reproduce the problem is the best path to a better solution here.

    I look forward to being of further assistance.
    JesseNinjaTrader Customer Service

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by liquid150, Today, 06:22 AM
    0 responses
    6 views
    0 likes
    Last Post liquid150  
    Started by liquid150, Today, 06:20 AM
    0 responses
    4 views
    0 likes
    Last Post liquid150  
    Started by bubblegum, Yesterday, 01:13 AM
    2 responses
    12 views
    0 likes
    Last Post bubblegum  
    Started by Atilla, Yesterday, 04:05 PM
    1 response
    57 views
    1 like
    Last Post im197
    by im197
     
    Started by vevbarrq, Today, 12:11 AM
    0 responses
    4 views
    0 likes
    Last Post vevbarrq  
    Working...
    X