Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Alert priority

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Alert priority

    Hello

    I am working with three indicators and each of them has different priority alerts (High, Medium and Low).

    Despite I filter priority in Alerts Log, all of them are displayed...

    What would be the solution for dealing with this issue?

    Thanks


    #2
    Hello Impeesa,

    Are you saying that the filter in the alerts log is not filtering when un checking the other options?

    What version of the platform are you currently using? You can find that in the Help -> About menu.

    I look forward to being of further assistance.
    JesseNinjaTrader Customer Service

    Comment


      #3
      Hello, Jesse

      Version 8.0.22.2 64-bit

      Comment


        #4
        Hello Impeesa,

        I tried a quick test using the alert sample from the help guide and see the filtering is working. Can you provide more specifics on what you are doing and the specific actions you are doing in the alert window?

        I look forward to being of further assistance.
        JesseNinjaTrader Customer Service

        Comment


          #5
          I think it is a platform problem, not indicator neither strategies. I just created an alert on the chart and it does not work as you can see in images attached...
          Attached Files

          Comment


            #6
            Hello Impeesa,

            I see this working as expected on my end, do you have more specific steps of what you did to see that?

            You may want to try to close all workspaces and work from a new empty workspace to ensure this doesn't have anything to do with something in those workspaces.

            Another item may be to reinstall the platform to refresh the stock files, I currently am not able to see the filtering leaving alerts which are matching the unchecked priority.


            I look forward to being of further assistance.

            JesseNinjaTrader Customer Service

            Comment


              #7
              Hello

              I have reinstalled the platform, a new one. No templates, no workspaces, new Ninjatrader.sdf... Last release 8.23.0.2.
              I open three alerts log windows, one of them with each priority (low, medium and high). I draw an horizontal line, use it as an alert, and when price crosses above the line, message appears in all of three alert logs windows.

              Am I doing something wrong?

              Thanks

              Comment


                #8
                Hello Impeesa,

                Thank you for the reply.

                Just to confirm, in each alert window you only have a single priority checked in the right click menu? When you select a priority it will not uncheck any of the others in case you are duplicating the window it should retain the first checked option as well.

                If you otherwise toggle the priority does the filter then happen? You can toggle it by enabling one of the other priorities and then disabling it.

                I tried this on my end and see the priority working as expected.

                I look forward to being of further assistance.
                JesseNinjaTrader Customer Service

                Comment


                  #9
                  Hello

                  Yes, in each alert window I only have a single priority check. And If i toogle the priority nothing happens, enable low, disable low, enable high... All remains...

                  What can I do?
                  Attached Files

                  Comment


                    #10
                    and Instrument Type selection works as expected... Priority does not.
                    Attached Files

                    Comment


                      #11
                      Hello Impeesa,

                      Thank you for the reply.

                      I so far have not been able to reproduce this happening in any way. Do you have an image of the alert you configured?

                      The only other step that I may be able to suggest with the given details would be to try a completely new user folder. I can provide further steps on how to do that if you would like.


                      I look forward to being of further assistance.
                      JesseNinjaTrader Customer Service

                      Comment


                        #12
                        Hello Jesse

                        Some of your colleagues is already working to fix this bug in NT8.

                        Thanks a lot

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by PeterInBrisbane, Today, 01:07 AM
                        0 responses
                        2 views
                        0 likes
                        Last Post PeterInBrisbane  
                        Started by fdalgoi, Today, 12:44 AM
                        0 responses
                        5 views
                        0 likes
                        Last Post fdalgoi
                        by fdalgoi
                         
                        Started by thomaswilleford, Today, 12:07 AM
                        0 responses
                        3 views
                        0 likes
                        Last Post thomaswilleford  
                        Started by dlygorivw, Yesterday, 10:55 PM
                        0 responses
                        3 views
                        0 likes
                        Last Post dlygorivw  
                        Started by dlygorivw, Yesterday, 10:53 PM
                        0 responses
                        4 views
                        0 likes
                        Last Post dlygorivw  
                        Working...
                        X