Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Drawings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Drawings

    1. What's the static name of "Slate Gray - Text Color"? I can't find it in guide.
    2. Is it possible to assign drawings to different data series? I wanna make it bc I trade MES on ES chart and my drawings don't save properly. When I launch NT8 next day all of them in the wrong place. The only thing that helps it's when I manually change data series (MES -> ES) in properties window. I tried like this:

    Code:
    foreach (var obj in chartWindow.ActiveChartControl.ChartObjects)
    {
    var draw = obj as DrawingTool;
    if (draw != null)
    {
    if (draw.IsVisible && draw.IsUserDrawn)
    {
    draw.AttachedTo.Instrument.FullName = "ES 12-20";
    break;
    }
    }
    Property or indexer 'Instrument.FullName' cannot be assigned to -- it is read only.

    #2
    Hello Leeroy_Jenkins,

    1. What's the static name of "Slate Gray - Text Color"? I can't find it in guide.
    Are you asking about the key in the skin for the text color or are you asking how to access this color in your code?

    2. Is it possible to assign drawings to different data series? I wanna make it bc I trade MES on ES chart and my drawings don't save properly. When I launch NT8 next day all of them in the wrong place. The only thing that helps it's when I manually change data series (MES -> ES) in properties window. I tried like this:
    Can you provide an example of what you are doing that's not working instead of what you tried to fix it?
    How are you currently drawing the objects and what specifically is in the wrong place? It looks like you are trying to change the instrument to the ES, is the script that drew the object on the MES or what are the specifics on the situation?

    I look forward to being of further assistance.
    JesseNinjaTrader Customer Service

    Comment


      #3
      1. I wanna access this color in my code (Brushes. //name)
      2. I got this bug since May 2019. Now I use latest NT8.
      So I use 2 data series. ES 2000tick, + MES daily fully transparent. Chart trader set to MES, and all my drawings are ploted on daily MES. Default setting for every line/arrow etc set to "Attatch to MES(all charts)." Everything good until I close NT8. I save the workspace, open next day and NT screws all drawings. No always but most of the time. They all on chart but some of them in the wrong spot.
      I trade MNQ too, only 1 data series and no problems at all. Drawings are fine.

      Comment


        #4
        Hello Leeroy_Jenkins,

        I believe in that case it would be: ChartControl.Properties.ChartText

        For the other question, are you drawing the objects from an indicator or is this in regard to manually drawing them?

        Can you provide a sample that I can test of how you draw the object (if using an indicator, a sample of an indicator, if manual then a set of steps). Also could you provide the general chart configuration? I mean the order you added the data series in the dataseries window or indicator.

        If we can get the specific steps to reproduce what you are seeing we can better understand the problem or report it in case its a bug.

        I look forward to being of further assistance.

        JesseNinjaTrader Customer Service

        Comment


          #5
          Manually drawings using Mahtoolbar https://ninjatraderecosystem.com/use...-mahtoolbar-2/ , 95% of them are simple lines.
          I forgot to mention - if I change some indicator setting it might causes same problem.
          Maybe it helps but I have more than 7000 lines, maybe it's too much lol. Those lines since April 2020, they don't even appear on chart - I always load <30 days.
          Attached Files

          Comment


            #6
            Hello Leeroy_Jenkins,

            Thanks for the reply.

            Do you see this when you don't use the toolbar to draw and just use the standard chart options?

            I forgot to mention - if I change some indicator setting it might causes same problem.
            Do you mean if you change any indicator that is applied to the chart, making the chart recalculate?

            JesseNinjaTrader Customer Service

            Comment


              #7
              Do you see this when you don't use the toolbar to draw and just use the standard chart options?
              I actually never use standard options. I'll give a try for couple of days and let you know.

              Do you mean if you change any indicator that is applied to the chart, making the chart recalculate?
              Yes. When indicator is already on chart.

              Comment


                #8
                So yeah it works smoothly now.

                Comment


                  #9
                  Hello Leeroy_Jenkins,

                  Thank you for the update. I just wanted to clarify here, are you just not able to see the problem currently or was the issue being caused by the custom indicator that drew the objects?

                  I look forward to being of further assistance.

                  JesseNinjaTrader Customer Service

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by guilhem, Today, 07:17 AM
                  0 responses
                  0 views
                  0 likes
                  Last Post guilhem
                  by guilhem
                   
                  Started by manueldecastro, Today, 04:57 AM
                  1 response
                  6 views
                  0 likes
                  Last Post NinjaTrader_PaulH  
                  Started by YevhenShynkarenko, Today, 12:16 AM
                  2 responses
                  41 views
                  0 likes
                  Last Post YevhenShynkarenko  
                  Started by JChien, Today, 06:26 AM
                  1 response
                  8 views
                  0 likes
                  Last Post NinjaTrader_PatrickG  
                  Started by dastaan, Today, 06:24 AM
                  0 responses
                  6 views
                  0 likes
                  Last Post dastaan
                  by dastaan
                   
                  Working...
                  X