Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

2 Positions with StopLoss & ProfitTarget (OCO)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    2 Positions with StopLoss & ProfitTarget (OCO)

    Hey together, iam very new in NinjaTrader and i need your help.
    I want to set 2 positions. One Long and one short for a breakout trade. Both Positions with a Stop Loss and a Profit Target. If one of the Long or short Position is filled, the other one has to cancel. Furthermore, the stop loss has to cancel the Profit target if filled and vice versa. is this possible with an ATM Strategie? I cant figure it out.

    many thanks for help

    #2
    Hello,

    Than you for your post.

    You can accomplish this approach via the steps below.

    Right click in the SuperDOM or Chart Trader and select the menu "OCO Order" to enable this function
    For your first order, select the desired option from the "ATM Strategy" drop down list
    Submit your stop order to buy above the market
    For your second order, select the desired option from the "ATM Strategy" drop down list
    Submit your stop order to sell below the market
    CRITICAL Right click in the SuperDOM or Chart Trader and select the menu "OCO Order" to disable this function

    Please let us know if we may be of further assistance.
    Eric B.NinjaTrader Customer Service

    Comment


      #3
      Thank you for answering. This was my first idea, but that doesnt work. Submit stop order to buy with stop loss and Profit target -> works. When i try to submit second order with the same atm strategy to sell the market, Ninja Trader says, "You cant submit an Exit order to a strategy until any of ist entry orders has been filled"

      and now ? :-)

      Comment


        #4
        Thank you for your reply,

        I see, before submitting your second ATM order, please select an ATM Strategy from the drop down menu again that does not list with a lightning bolt to the left of the template name.

        The lightning bolt indicates the first active ATM, select either Custom or a saved template below the ATM menu None option before submitting the second order.
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          I was having the same problem when trying to enter the second OCO order using the same ATM strategy.

          Frankly, this seems an unnecessary and non-intuitive step. NT should simply apply a second number automatically. Just my two cents.

          Comment


            #6
            Thank you for your post.

            You may want to explore your ATM Strategy Selection mode. There are a few different ways this can be configured. In your case you may want to explore the setting "Keep selected ATM Strategy template on order submission"
            To change this setting right click within the Chart Trader if you are using a chart and go to Properties. Next Change your ATM strategy selection mode to "Keep selected ATM strategy template on order submission"
            If you are using a SuperDOM this can be changed by right clicking in the SuperDOM and going to Properties.
            Below is a link to our help guide that gives more details on the different selection modes available.
            https://ninjatrader.com/support/help...ction_mode.htm
            Please let me me know if I may be of any further assistance.
            Dennis E.NinjaTrader Customer Service

            Comment


              #7
              Ok. that works. Thanks.

              Now, if I want to add contracts to the StopLoss (to reverse a position) I find that right clicking on the SuperDOM does not offer Buy or Sell options when I right click as does the Trade Chart (I have no OCO and no ATM). This forces me to use the Trade Chart window.
              Last edited by ronhb107; 11-27-2017, 12:09 PM.

              Comment


                #8
                Thank you for your post.

                This behaviour is expected. When your right click in the SuperDOM there are not options to place orders. To increase the order quantity for an order from the SuperDOM you can simply click on the pending order and then increase or decrease the number of contracts with the up or down arrow.

                Please let me me know if I may be of any further assistance.
                Dennis E.NinjaTrader Customer Service

                Comment


                  #9
                  Actually, you can't increase the size of the StopLoss order when it's part of an ATM (the message: You can't change the size of a predefined strategy stop/target order). The ATM Strategy Selector has already been set to None.

                  Also, although the Auto Center has been unchecked, the SuperDOM does move the price levels around by one or more ticks (which makes it difficult to maintain alignment with another window).

                  One last question. Can an Add-on be used to control what displays on the SuperDOM window? I would like to add other columns next to the Buy and Sell columns showing the net change in Bid/Ask pending orders..
                  Last edited by ronhb107; 11-27-2017, 01:17 PM.

                  Comment


                    #10
                    Thank you for your post.

                    Sorry for the confusion in the last post. I thought you meant that you were not in an ATM strategy or and OCO order when trying to modify the contract quantity.

                    To answer you question there are 4 columns that come pre-installed with NinjaTrader that can be added to the SuperDOM. Those columns are APQ, Notes, PnL, and Volume. There may be additional columns that can be added with 3rd party software or they may also be found in the NinjaScript section of this forum as well.

                    Please let me me know if I may be of any further assistance.
                    Dennis E.NinjaTrader Customer Service

                    Comment


                      #11
                      Thanks for the reply, Dennis.

                      There are two questions: First, why is the SuperDOM still moving when centering is disabled? (This appears to be a bug).

                      And second, can new columns be placed directly next to the SuperDOM table (both on the left and right) using a NinjaScript Add-on? That is, is there full control of the column's position? (This is different than just adding or enabling columns to the right of the SuperDOM table).

                      Comment


                        #12
                        Hello,

                        Thank you for your post.

                        Which type of SuperDOM are you using?
                        Below is a link to our Help Guide that gives more details on the differences between the two types of SuperDOMS. If you are using a Dynamic SuperDOM this behavior is expected.

                        https://ninjatrader.com/support/help...ice_ladder.htm

                        Currently it is not possible to add columns next to the SuperDOM itself by default. This may be possible with custom programming. I was unable to locate any add ons on this forum that would accomplish this either.

                        Please let me me know if I may be of any further assistance.
                        Dennis E.NinjaTrader Customer Service

                        Comment

                        Latest Posts

                        Collapse

                        Topics Statistics Last Post
                        Started by wftrrdt, Today, 05:01 AM
                        0 responses
                        2 views
                        0 likes
                        Last Post wftrrdt
                        by wftrrdt
                         
                        Started by wellbeingcbd, Today, 04:41 AM
                        0 responses
                        1 view
                        0 likes
                        Last Post wellbeingcbd  
                        Started by piydasuknu, Today, 03:45 AM
                        0 responses
                        3 views
                        0 likes
                        Last Post piydasuknu  
                        Started by ajdfkgjiojjhfihjg, Today, 03:20 AM
                        0 responses
                        3 views
                        0 likes
                        Last Post ajdfkgjiojjhfihjg  
                        Started by keravitahere, Today, 01:56 AM
                        0 responses
                        2 views
                        0 likes
                        Last Post keravitahere  
                        Working...
                        X