• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Alerts won't rearm on condition reversed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Alerts won't rearm on condition reversed

    Hi. I can't get alerts to rearm on condition reversed. That looks like a bug. Here are the steps to reproduce:

    - Im using the latest version 8.0.16.3 (simulation only)
    - Using the playback connection with my own history data.
    - In market analyzer there is only 2 columns: instrument and last price
    - Put an alert like in the picture attached
    - Alert triggers once, but won't rearm on condition changed. Other rearm options (like never or bar close) seem to work ok.
    Last edited by Roger_1120; 12-04-2018, 05:23 PM.

    #2
    Hello Roger_1120,

    Thank you for your patience.

    I see my colleague is assisting you via email. I will be following up with you here and via email once we have details on this matter.
    Patrick H.NinjaTrader Customer Service

    Comment


      #3
      Hello Roger_1120,

      I am able to reproduce the same undesired behavior on my end. This will be reported to our development team and I will follow up when I have further details.
      Patrick H.NinjaTrader Customer Service

      Comment


        #4
        Hello Roger_1120,

        Thank you for your patience.

        Alerts are not intended to be used with Playback while using an increased speed. Alerts are checked every 200 milliseconds, so using them in Playback could result in an alert not triggering.

        You can find more details on using Alerts at the following link: https://ninjatrader.com/support/help...ing_alerts.htm

        Please let me know if you have any questions.
        Patrick H.NinjaTrader Customer Service

        Comment


          #5
          Hi.
          thanks for the response, but I have to say this looks like a bad implementation to me. If ninjatrader were 'truly event driven' like it is boasted all troughout the manual, the alerts should work in Playback too, and not being checked based on a timer.
          So maybe a feature request I guess?

          Comment


            #6
            Hello Roger_1120,

            Thank you for your post.

            I will forward your request to our development team.
            Patrick H.NinjaTrader Customer Service

            Comment


              #7
              I don't know if it relates to this, but in the release notes for the newest version it says fixed to the issue #13442. Tried with the new version but same thing. The alarms always work the first time, just don't rearm on condition reversed.
              I used playback connection, I know I wasn't supposed to but the alarms work there, just don't rearm.

              Comment


                #8
                Fix #13442 was not a resolution for the behavior you reported. This fix addressed "Alert 'Rearm type' of 'On condition reversed' unintendedly waited for ALL conditions to become false versus the condition set itself becoming false to trigger." specifically, which sounds similar but is not identical.

                In your screenshots in your first post, I see you're replaying at 100x speed. Alerts are not intended to be used with Playback while using an increased speed. Alerts are checked every 200 milliseconds, so using them in Playback could result in an alert not triggering. See note #2 here:

                https://ninjatrader.com/support/help...ing_alerts.htm

                Is this behavior reproducible at 1x playback speed, or when using live data?
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  Like I said, even when using playback, the alerts trigger once, so it works. It just does not rearm.
                  Tried with slow speeds too. Not with live though.

                  Comment


                    #10
                    Does 'low speed' mean 1x? Can you reproduce this issue at 1x speed? If so, please follow up with us via email with exact steps on how to reproduce. The relevant ticket is "2021806 ATTN Patrick G". Make sure to include that when you write in to PlatformSupport[AT]NinjaTrader[DOT]com
                    Patrick G.NinjaTrader Customer Service

                    Comment


                      #11
                      Hello Roger_1120,

                      Thank you for sending in your note.

                      We will work with you on email and follow up here on the Support Forum when we have further details.
                      Patrick H.NinjaTrader Customer Service

                      Comment


                        #12
                        Hello Roger_1120,

                        Thank you for your response.

                        The internal tracking number for your feature request is SFT-3834. Please reference this internal tracking number if you ever have questions regarding this feature request.

                        When a feature request is implemented, you'll find it in the release notes: http://ninjatrader.com/support/helpG...ease_notes.htm

                        Please let me know if you have any questions.
                        Patrick H.NinjaTrader Customer Service

                        Comment


                          #13
                          Hello Roger_1120,

                          Thank you for providing the requested information via email.
                          Originally posted by Roger_1120 View Post
                          I don't know if it relates to this, but in the release notes for the newest version it says fixed to the issue #13442. Tried with the new version but same thing. The alarms always work the first time, just don't rearm on condition reversed.
                          I used playback connection, I know I wasn't supposed to but the alarms work there, just don't rearm.
                          We were able to reproduce the behavior of an indicator producing a single value, checking that value in the Market Analyzer Alerts against a Numeric value and not seeing it properly re-arm on reversal of the condition. I have reported this to our development team and I will follow up with you here when I have further details.

                          Patrick H.NinjaTrader Customer Service

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by jrm999, Today, 07:44 PM
                          0 responses
                          2 views
                          0 likes
                          Last Post jrm999
                          by jrm999
                           
                          Started by Iargo, Today, 05:53 PM
                          0 responses
                          3 views
                          0 likes
                          Last Post Iargo
                          by Iargo
                           
                          Started by kadan, Today, 05:24 PM
                          1 response
                          5 views
                          0 likes
                          Last Post kadan
                          by kadan
                           
                          Started by mntemel, Today, 04:17 PM
                          0 responses
                          8 views
                          0 likes
                          Last Post mntemel
                          by mntemel
                           
                          Started by guigs88, Today, 02:57 PM
                          2 responses
                          4 views
                          0 likes
                          Last Post guigs88
                          by guigs88
                           
                          Working...
                          X