• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT8 historical backtesting calculates forever with no results

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    NT8 historical backtesting calculates forever with no results

    I am backtesting a strategy on NT8. The strat uses a combination of indicators to determine entry and exit. I ran historical backtesting on the CL contract and after a few minutes it gave me strategy results. I then ran it on the NQ contract. It's been 30 minutes and it still says "calculating" it shows some trades simulated but seems to have stopped calculating additional trades. Both contracts were run on 90 days of data. Is this a k a own issue? Is there a fix?

    #2
    What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.X.X)

    So I may be of better assistance, can you please tell me the following?
    • Do you see results when running the same test on the SampleMaCrossOver strategy in NinjaTrader with the same settings as your strategy?
    • Who are you connected to? This is displayed in green on lower left corner of the Control Center window.
    • Are you connected to your data feed provider when running this test?
    • What Data Series Type have you selected? Example: Tick, Minute, Day
    • Is your strategy a multi instrument or multi time frame strategy?
    • Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Its version 8.0.16.3 64 bit

      when I run the cross over strat it is slow but not anywhere near as slow. Similar to the results that I got when I ran oil.

      I am connected to ninjatrader continuum.

      I am connected to tick data.

      The strat is neither multi instrument or multi time frame.

      There are no error messages anywhere.

      Additionally, after stopping and restarting the strat several times I was able to get it to do the complete run and get results.

      Comment


        #4
        Can you tell me more about your PC? CPU, RAM, and whether you're using a SSD or HDD would be the relevant details.

        If you reduce the days to load, does the behavior change?

        If you perform the same tests using a time based interval, like 5 minutes, does the behavior change?

        How many workspaces are open when you run the backtest? If you close all open workspaces and also disconnect from live data, does the behavior change?
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          Sorry for the delayed response. It appears that the problem was a combination of an unusually high number of trades during the testing period combined with a section of code in the strategy that caused a high CPU load. I think the problem has been solved.

          Thanks

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by Arkadiy_B, Today, 06:43 AM
          0 responses
          2 views
          0 likes
          Last Post Arkadiy_B  
          Started by leontancfa, Today, 06:09 AM
          1 response
          8 views
          0 likes
          Last Post NinjaTrader_PatrickG  
          Started by soulfx, 12-01-2017, 08:44 AM
          3 responses
          1,019 views
          0 likes
          Last Post NinjaTrader_EricB  
          Started by Parmenides48, 04-09-2019, 03:32 AM
          10 responses
          49 views
          0 likes
          Last Post NinjaTrader_PatrickG  
          Started by NinjaCustomer, Today, 01:48 AM
          1 response
          13 views
          0 likes
          Last Post NinjaTrader_EricB  
          Working...
          X