Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

sim 101, there is no market data available to drive the simulation engine

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    sim 101, there is no market data available to drive the simulation engine

    Hi,

    I have NT8 running on my old pc and purchased and installed NT8 on my new machine. It uses a different sim license key (both accounts are demo)

    I setup a demo account for new machine and logged in successfully but when I tried to place an order, I got this message.

    sim 101, there is no market data available to drive the simulation engine

    I did install the latest windows 10 updates and installed NT8 later.
    Other than NT8, I haven't installed any other software.
    Is there a special program that I should install along with NT8 in order to receive live data feed for demo trading?

    I have no problem getting a data on my old machine by the way.

    Please help and I would appreciate your support in advance.


    Thank you.

    #2
    Hello,

    Thank you for your post.


    Glad to assist. To test, please reset your instruments, this will ensure that the internal setting for the instruments are up-to-date with server specifications: Disconnect and go to the Tools menu, select the Options menu item, select the Data tab, and then click on 'Reset Instruments'.

    You will need to close and restart NinjaTrader for the settings to take effect.

    If you're still unable to get data, please let me know the instrument selected when the error is received.

    We look forward to assisting further.
    Eric B.NinjaTrader Customer Service

    Comment


      #3
      Thanks for your quick response.
      I don't see Data. Instead, I have Market data. But there is no reset instrument option there. I'm on NT8 and is there other way around?

      Thank you

      Comment


        #4
        Thank you for your reply.

        Sorry for the oversight, please use the steps below instead.

        1. First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
        2. Next, reset your instruments by navigating to the Control Center > Tools > Database Management
        3. In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
        4. Lastly, restart NinjaTrader for the changes to occur
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          It works !!!
          Greatly appreciated.

          Comment


            #6
            I'm having the same problem, but updating the instruments did not resolve the issue for me. Is there other steps I can take? I'm using NT8.

            Comment


              #7
              Hello epete,

              Thank you for your post.


              What version of NinjaTrader are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.X.X)


              Who are you connected to? This is displayed in green on lower left corner of the Control Center window.


              What instrument (and expiry if applicable) have you selected? For example, ES 06-19, AAPL, EURUSD, etc.


              (For a chart) what interval is selected? For example, 5 minute, 1 day, 2000 volume, 4 Renko, etc.

              Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?

              We look forward to assisting further.
              Eric B.NinjaTrader Customer Service

              Comment


                #8
                Hello! I am having the same problem and it still doesn´t work. I am connectet in My Ninjatrader Continuum in demo version. In the control center is a message that says: REJECTED, THERE IS NO MARKET DATA AVAILABLE TO DRIVE THE SIMULATION ENGINE

                Comment


                  #9
                  This can occur for a few reasons:
                  • You're attempting to trade an instrument which is not provided by the demo
                  • You're attempting to trade an expired instrument
                  • Other simulator corruption issues
                  Please answer Eric's question from post #7 so I may hopefully isolate the root cause of what you're experiencing.
                  Patrick G.NinjaTrader Customer Service

                  Comment


                    #10
                    I'm sorry. I'm having the same problem. On my sim101 account I have the ES 06-21 open, but it does not update the data. It only shows where it is at the moment that I open. I have NT8; it's on a 2000 tick; my green light is on showing I am connected to live data.
                    I tried doing the "update instruments" as described above, but it still doesn't work

                    Comment


                      #11
                      brogobaggins , I suspect your connection is not enabled for real-time data.
                      • Who are you connected to? Have you confirmed with this data provider that you are enabled for real-time data? If not, please do so now.
                      • Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?
                      Patrick G.NinjaTrader Customer Service

                      Comment


                        #12
                        Thank you for getting back to me. It may well be I'm confused about my connections. I thought I had it good to go. I had received a username and password upon funding my account. And I followed the instructions to configure the connection. Stupidly, I renamed the connection; I say stupidly because now I can't remember what the connection was called, but I believe it was Ninja Trader Continuum. I even thought I was connecting my live account, but then I realized I only have sim101 listed on the "accounts" tab.
                        In any event, the sim account is what I want to focus on for right now. I thought the connections was correct, but now I realize it is not keeping up with the price action; it just stays in place at the moment that I connect, even though the green light is on. If I place an order it says "there is no market data available to drive the simulation engine"
                        I think I've made a mess of it. Is there a way to start all over? would I be able to talk with someone over the phone?
                        Thank you

                        Comment


                          #13
                          If you're connecting to a live funded brokerage account but you're not receiving real-time data, the most likely root cause is that your live account is not enabled for real-time data. This is typically accompanied by a message in the Control Center's log tab that looks something like:
                          • Failed to resolve instrument for market data: xxxx is not enabled for real-time quotes and trading.
                          This is not a technical issue and you've configured your connection correctly based on the information you've provided. I don't believe 'going nuclear' and starting over is necessary. You need to speak to your broker about enabling real-time data in your account. If your broker is NinjaTrader Brokerage then you should see something regarding this in the same email you received your username in. If you no longer have this email or need further assistance, please contact your broker directly or any of my colleagues on the Brokerage Support team via email:
                          • BrokerageSupport[AT]NinjaTrader[DOT[com
                          Patrick G.NinjaTrader Customer Service

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by abctrader, Today, 06:03 PM
                          1 response
                          24 views
                          0 likes
                          Last Post NinjaTrader_ChelseaB  
                          Started by Liquidfusion, Today, 06:16 PM
                          0 responses
                          19 views
                          0 likes
                          Last Post Liquidfusion  
                          Started by fscabrera03, Today, 04:58 PM
                          0 responses
                          24 views
                          0 likes
                          Last Post fscabrera03  
                          Started by patpat, Today, 03:56 PM
                          2 responses
                          34 views
                          0 likes
                          Last Post patpat
                          by patpat
                           
                          Started by joselube001, Yesterday, 07:40 PM
                          3 responses
                          88 views
                          0 likes
                          Last Post NinjaTrader_ChelseaB  
                          Working...
                          X