• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT8 won't start

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    NT8 won't start

    Hi
    I have had an occasional problem where NT8 fails to start which has persisted over many months, probably years now
    The startup seems to proceed past the 'Initialising Database' stage, but then the platform opens but hangs on a blank 1min chart and is largely unresponsive
    Task Manager usually reports three NinjaTrader processes running, with approx 360MB of RAM committed to them, which gradually ticks up and down but remains approx the same indefinitely
    If I force quit I can usually get NT to restart successfully after a few attempts, failing that rebooting my laptop has always done the trick
    Today though even multiple reboots seem to be unsuccessful in getting the platform to start
    I reinstalled the latest version of NT8 and again attempted to start the program, but still the same problem
    Would you be able to help please, this one-off is acute, but the general problem has persisted for such a long time now
    Thanks

    #2
    Hello Bend70,

    For this question I would suggest to email our support directly so we can collect log and trace files from your PC to further diagnose what may be happening here. Could you use the following steps to manually attach your log and trace files and email our support?
    • Open Windows File Explorer (hotkey = Windows key + E) Then navigate to Documents > 'NinjaTrader 8' folder
    • Right click on the 'log' and 'trace' folders and select Send To> Compressed (zipped) Folder.
    • Send the 2 compressed folders as attachments to this email.
    • Once complete, you can delete these compressed folders.

    Send an email to: platform support [at] ninjatrader.com in addition to these files and we could further assist with the startup problems.

    One additional item you can do before sending our support an email would be to test safe mode, this would help identify if the startup problem is related to a workspace, template or other custom items which are being loaded at startup.

    To enable safe mode, please use the following steps:

    Exit NinjaTrader.
    • Hold the CONTROL key and double click the NinjaTrader icon.
    • Keep the CONTROL key held down until you see the Control Center.
    • You can verify you are in safe mode by going to Help -> About.


    Thanks in advance; I look forward to resolving this item.
    JesseNinjaTrader Customer Service

    Comment


      #3
      thanks Jesse
      I got around the problem before reading your reply by starting 32bit NT8 rather than the 64bit NT8 I usually use. This platform started normally, and I was then able to uncheck the 'connect on startup' option for my datafeed, and then after exiting 32bit I was able to start 64bit NT8 normally
      The problem now seems completely intermittent, but some times when starting fine without a data feed and then attempting to connect I am getting a failure to connect message, perhaps this is what is hanging my platform and why I've never been able to trace the behaviour consistently?
      Is this a known issue please?
      I did try starting in safe mode as you suggested, first attempt (with connect on startup enabled) resulted in a hung platform again. Second attempt worked. So seems not related to safe mode
      I will monitor behaviour tomorrow and email files as you suggest if I get more problems, thanks

      Comment


        #4
        Hello Bend70,

        Thank you for your reply.

        I would be unsure if this is a known item as I don't have enough details about the installation and connection used at this point, however, it sounds like you potentially have a way to cause this with connect on startup enabled.

        This would be a good item to report through email so that we can review this case further. I would guess this is not going to be expected that the platform hangs in this situation, however, we would want to review if you are getting errors in that specific use case before trying to determine anything.

        If you are able to recreate the problem using the steps you mentioned, I would suggest doing that again (in case errors are logged they will be in the most recent file) and then emailing our support with the log and trace files. We would also need the details surrounding the steps used to cause the problem and also what connection provider is being used.

        After reviewing the log and trace files, we can determine if any errors were happening during that situation that may be the cause, otherwise, we can do testing such as a clean user folder/clean install test to confirm this is not related to anything imported or user data. If the connection just does this when connect on startup is enabled and the connection fails, we can very likely report that to development with the details you provide as a bug report.


        I look forward to being of further assistance.
        JesseNinjaTrader Customer Service

        Comment


          #5
          thanks for the helpful replies Jesse, I will test some more and then if necessary email in as you suggest

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by NinjaCustomer, Today, 01:01 AM
          0 responses
          3 views
          0 likes
          Last Post NinjaCustomer  
          Started by mohdqallaf, Today, 12:55 AM
          0 responses
          3 views
          0 likes
          Last Post mohdqallaf  
          Started by dvcpro4, Yesterday, 07:08 PM
          2 responses
          25 views
          0 likes
          Last Post NT-Roland  
          Started by chrismcdermut, Yesterday, 01:46 PM
          3 responses
          19 views
          0 likes
          Last Post MojoJojo  
          Started by Bricolico, Yesterday, 09:28 PM
          0 responses
          5 views
          0 likes
          Last Post Bricolico  
          Working...
          X