• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Trading Hours Error Message

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Trading Hours Error Message

    Recently, when I start NT8 I get a series of error messages - around 4 for various never traded instruments - to the effect, "Unable to load trading hours from file 'liffe gilt futures.xml' system.xml.exception: root element is missing...". there are about 4 error windows for different instruments. I just "x" them to close them, but I don't know why these are showing up.

    Any ideas?

    TIA

    #2
    This is a known symptom from a program called 'Acronis' running on your PC. This program accesses NinjaTrader's files and prevents NinjaTrader from accessing them causing the error. Is 'Acronis' running on your PC? Check your Windows Task Manager and make sure to check the 'background processes' as well.
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Arrrrrrrrrrrrrrggggggggggggggghhhhhhhhhh!

      Yes, it's running... SOAB! Any suggestions for making everyone play nice?

      Comment


        #4
        There are two known solutions and one probable solution. The solution you'll want to try will depend on if you're using Acronis purposefully or not:
        • Uninstall Acronis
        • Click on your start menu > Type "run" then press enter > Type "msconfig" then press enter > Disable all instances of Acronis services then make sure Acronis does not startup in the startup menu.
        • Add exceptions to Acronis so that it does not interfere with NinjaTrader
          • https://kb.acronis.com/content/36429
          • Relevant locations of NinjaTrader files/folders on your PC:
            • Documents > 'NinjaTrader 8' folder
            • Program Files (x86) > 'NinjaTrader 8' folder
          • If you choose this step instead of the other two, please follow up and let us know if it worked or not - we do not yet have confirmation from any users that this resolves the issue.
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          Patrick,

          Thanks for the suggestions. I tried both. Added Exceptions to Acronis. and Uninstalled Acronis. In each case, the behavior persisted. I even shut down Windows Defender and my Main Antivirus program. I believe that the problem lies in NT8. So this weekend I'm going to Uninstall NT8 and reload it. Strange.

          This goes along with one of my recent posts where NT locks up and can't be shut down after a period of sustained inactivity. Task Manager shows the Status as 'Suspended'.

          I don't know if these are related or different issues.

          D

          Comment


            #6
            Originally posted by dmking View Post
            "Unable to load trading hours from file 'liffe gilt futures.xml' system.xml.exception: root element is missing..."
            Should not NinjaTrader fix the .xml files so that they contain a root element?

            Would not that solve the problem?

            Comment


              #7
              OK, I got everything working, but I don't like the fix because there is no closure.

              I uninstalled/reinstalled NT8 and the problem remained. I looked in the Documents Folder for NT8, found the Templates folder and found the 3 files that were causing the problem. Oddly, they were all zero byte files. I had a recent backup of this Template folder and copy and replaced the offending XML files. Restarted Ninja and the problem was solved.

              So were the zero byte XML files 'corrupted'? If so, what caused the corruption? Why only 3 files? Why these 3? Was this random? Did something else happen? Was this a ninja only problem?

              I'd like an answer on this? Am I the only one to have experienced this?

              This is a mission critical piece of software. There should be an answer. Things like this make me nervous.

              Comment


                #8
                Yes, it sounds like you experienced a combination of two issues - Acronis may have caused the XML files to install incorrectly, so a 'soft' uninstall/reinstall likely would have resolved after making those changes to Acronis.
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  Thanks Patrick,

                  I think that you misunderstood. The "soft" uininstall/reinstall did NOT resolve the problem. It was AFTER that the problem STILL persisted.

                  I looked at the template folder and found the zero byte files and manually replaced them. I have been using Acronis for over a year with no problems (maybe a minor one earlier in the year) and the problem popped up out of the blue. Even after completely uninstalling Acronis and doing the "soft" procedure the problem persisted.

                  I don't think it was Acronis.

                  Comment


                    #10
                    Acronis is known to affect NinjaTrader's files in this exact way and produce this exact symptom. I misspoke previously - the reason the 'soft' uninstall/reinstall does not work, is that the installer sees that the files are there (but doesn't check the integrity of those files) and moves on.
                    Patrick G.NinjaTrader Customer Service

                    Comment

                    Latest Posts

                    Collapse

                    Topics Statistics Last Post
                    Started by deblanka, Today, 08:56 AM
                    0 responses
                    3 views
                    0 likes
                    Last Post deblanka  
                    Started by Boonfly8, Yesterday, 12:30 PM
                    7 responses
                    18 views
                    0 likes
                    Last Post sledge
                    by sledge
                     
                    Started by Sohal, Today, 05:02 AM
                    2 responses
                    10 views
                    0 likes
                    Last Post techmint  
                    Started by danitralla, Today, 03:33 AM
                    0 responses
                    5 views
                    0 likes
                    Last Post danitralla  
                    Started by yeshujbp, Today, 12:37 AM
                    0 responses
                    16 views
                    0 likes
                    Last Post yeshujbp  
                    Working...
                    X