• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Lynx (Interactive Brokers) connection

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Lynx (Interactive Brokers) connection

    Hi!
    I'm using NT with TWS. I have a subscription for Xetra live data from Lynx.
    In the Trader Workstation the live data access works fine. But in Ninjatrader I get an error when I want to load stock data.
    Does anyone know, why Ninjatrader doesn't show any data?
    Everytime I get a connection error "Historical Market Data Service error message: No market data permissions for IBIS STK".
    Thanks for your help!
    David

    #2
    What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.?.?)

    What instruments specifically are producing this error?

    Did you manually create these instruments, or did they appear to be within NinjaTrader already?
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      My Ninjatrader Version is "8.0.17.2 64-bit".
      Forex works fine but Dax30 doesn't work. When I choose e.g. Adidas AG (ADDS) in Dax30 I get an empty chart with a error message (see link). I already have a live data subscription for Dax30 and in TWS it works fine.
      I didn't create manually these instruments.
      Attached Files

      Comment


        #4
        Please clarify - you're certain you have a live subscription and not a delayed data subscription for these instruments? Delayed data will look and appear 'live' except it's delayed by a certain amount of time.
        • Once you've confirmed that you do have live (not delayed) data for this instrument, let's check the exchange mapping within NinjaTrader:
        • Control Center > Tools > Instruments
        • Search for and select 'ADDS' > Edit
        • Hover over 'X exchanges' > Click on 'Configure exchanges...'
        • There should be two exchanges selected:
          • Default
          • Xetra
        • Do you observe that only these two exchanges are selected? If there are more or different exchanges selected, which ones are they?
        Patrick G.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by Newtrader101, Today, 04:50 AM
        3 responses
        16 views
        0 likes
        Last Post NinjaTrader_ChrisL  
        Started by utilizator, Today, 06:31 AM
        2 responses
        9 views
        0 likes
        Last Post utilizator  
        Started by digibob, Today, 01:13 AM
        3 responses
        13 views
        0 likes
        Last Post digibob
        by digibob
         
        Started by calebsandfort, Yesterday, 05:16 PM
        2 responses
        9 views
        0 likes
        Last Post NinjaTrader_PaulH  
        Started by StevenNelson, Yesterday, 05:45 PM
        3 responses
        19 views
        0 likes
        Last Post NinjaTrader_Jermaine  
        Working...
        X