• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Volume Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Volume Problem

    I compared the volumes and bars between the NT8 platform and the CME chart. GC and YM charts in some places on the daily timeframe can do different bar closure and volume. Sometimes even an extra bar can appear. I looked at tradingview and thinkorswim, there the schedule is exactly the same as on CME.
    ​​​​​​ Can this be fixed somehow? (demo license type)

    #2
    Hello DariusDeck,

    Thanks for posting to the forums.

    Your PC's clock may be out of sync which can cause an extra bar or slightly different bars that what a web platform is reporting.

    Please use the steps below to change/check your Time Zone and sync the PC clock:
    • Shutdown NinjaTrader
    • Right-click the clock in the lower right corner of your desktop
    • Select Adjust date/time
    • For Windows 10 click 'Additional date, time, & regional settings' -> then click 'Set the time and date'
    • Select the 'Internet Time' tab at the top
    • Set the server to time.nist.gov and then click Update.
    • If the message that appears says successful your PC clock should now be updated.
    • If not, select a different server from the Server: drop-down and try again (repeat until one of the servers is successful)

    After updating the PC clock, please restart NinjaTrader, then right-click the chart and select Reload All Historical Data.

    Please let us know if we may be of further assistance.
    Marco G.NinjaTrader Customer Service

    Comment


      #3
      Originally posted by NinjaTrader_Marco View Post
      Hello DariusDeck,

      Thanks for posting to the forums.

      Your PC's clock may be out of sync which can cause an extra bar or slightly different bars that what a web platform is reporting.

      Please use the steps below to change/check your Time Zone and sync the PC clock:
      • Shutdown NinjaTrader
      • Right-click the clock in the lower right corner of your desktop
      • Select Adjust date/time
      • For Windows 10 click 'Additional date, time, & regional settings' -> then click 'Set the time and date'
      • Select the 'Internet Time' tab at the top
      • Set the server to time.nist.gov and then click Update.
      • If the message that appears says successful your PC clock should now be updated.
      • If not, select a different server from the Server: drop-down and try again (repeat until one of the servers is successful)

      After updating the PC clock, please restart NinjaTrader, then right-click the chart and select Reload All Historical Data.

      Please let us know if we may be of further assistance.
      My computer successfully synchronized the time with the server - time.nist.gov but nothing has changed. I tried other servers, but the schedule is still the same.

      Comment


        #4
        Thank you for your reply.

        So I may accurately assist you, please answer the following question:
        • Who are you connected to? This is displayed in green on lower left corner of the Control Center window.
        We look forward to assisting further.
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          Originally posted by NinjaTrader_EricB View Post
          Thank you for your reply.

          So I may accurately assist you, please answer the following question:
          • Who are you connected to? This is displayed in green on lower left corner of the Control Center window.
          We look forward to assisting further.

          Comment


            #6
            Thank you for your reply.

            Daily charts are loaded in NinjaTrader using the session times as reported via the data provider; NinjaTrader 8 also receives daily bars for ETH trading hours. To view outside of these times, try loading the daily chart alternatively as a 1440-minute interval.

            Let me know if I may assist further.
            Eric B.NinjaTrader Customer Service

            Comment


              #7
              Originally posted by NinjaTrader_EricB View Post
              Thank you for your reply.

              Daily charts are loaded in NinjaTrader using the session times as reported via the data provider; NinjaTrader 8 also receives daily bars for ETH trading hours. To view outside of these times, try loading the daily chart alternatively as a 1440-minute interval.

              Let me know if I may assist further.
              Changed the time and nothing has changed. I put different trading hours on the date series, the result does not change, the same dips in the volume

              Comment


                #8
                The chart you are viewing on the CME website is the YM 06-19 contract as opposed to the YM 09-19 contract which is selected in NinjaTrader. Can you please select the September contract on the CME website which should be YMU2019 and let me know if the volume matches for that day.
                Christopher J.NinjaTrader Customer Service

                Comment


                  #9
                  Originally posted by NinjaTrader_ChristopherJ View Post
                  The chart you are viewing on the CME website is the YM 06-19 contract as opposed to the YM 09-19 contract which is selected in NinjaTrader. Can you please select the September contract on the CME website which should be YMU2019 and let me know if the volume matches for that day.
                  Well, I opened the September contract for CME and the volume there corresponds to the volume in NT8. Then I have a question, why volumes for both contracts are shown in thinkorswim or on tradingview, but not shown in HT8. So, in order to see the correct volume, do I need to include the previous contract?

                  Comment


                    #10
                    Within NinjaTrader by default historical data will be merged to build continuous data. For example if you open a YM 09-19 chart with 60 days set to load NinjaTrader will merge data from YM 06-19 into YM 09-19 to backfill your chart.

                    I am not familiar with the settings that Thinkorswim and Tradingview use however if they do not merge previous contracts you can change the Merge Policy in NinjaTrader under Tools->Options->Market Data->Merge Policy.

                    I have also provided a link below to our Help Guide that goes over the different Merge Policies that are available.

                    https://ninjatrader.com/support/help...rge_policy.htm

                    Christopher J.NinjaTrader Customer Service

                    Comment


                      #11
                      Originally posted by NinjaTrader_ChristopherJ View Post
                      Within NinjaTrader by default historical data will be merged to build continuous data. For example if you open a YM 09-19 chart with 60 days set to load NinjaTrader will merge data from YM 06-19 into YM 09-19 to backfill your chart.

                      I am not familiar with the settings that Thinkorswim and Tradingview use however if they do not merge previous contracts you can change the Merge Policy in NinjaTrader under Tools->Options->Market Data->Merge Policy.

                      I have also provided a link below to our Help Guide that goes over the different Merge Policies that are available.

                      https://ninjatrader.com/support/help...rge_policy.htm
                      I tried all the Merge Policies and nothing has changed.

                      Comment


                        #12
                        I cannot understand why NT8 cannot combine the volumes of the past and the present contract at the same time, when I watch the schedule for a year or two, as TOC or TV does. Why takes into account the volumes of the next contract, and the volumes from the previous one are swept away

                        Comment


                          #13
                          In order to merge previous contracts into the current expiry you would want to set the Merge policy to "Merge back adjusted" then right click in your chart and select "Reload All Historical Data.
                          If you do not see any changes go to the Control Center->Select YM->edit->confirm Merge policy is set to "Use global settings"->Click ok then reload historical data.
                          Christopher J.NinjaTrader Customer Service

                          Comment

                          Latest Posts

                          Collapse

                          Topics Statistics Last Post
                          Started by ct, Today, 01:57 PM
                          0 responses
                          2 views
                          0 likes
                          Last Post ct
                          by ct
                           
                          Started by 7robert, Today, 01:13 PM
                          1 response
                          5 views
                          0 likes
                          Last Post NinjaTrader_Jim  
                          Started by Newtrader101, Today, 12:52 PM
                          2 responses
                          6 views
                          0 likes
                          Last Post Newtrader101  
                          Started by 7robert, Today, 12:23 PM
                          3 responses
                          12 views
                          0 likes
                          Last Post NinjaTrader_Tyler  
                          Started by brownsfan019, Today, 12:52 PM
                          3 responses
                          8 views
                          0 likes
                          Last Post NinjaTrader_Tyler  
                          Working...
                          X