• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Market Replay WAAAY faster on my old 2500K PC vs newer 6700K PC

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Market Replay WAAAY faster on my old 2500K PC vs newer 6700K PC

    Is this due to hyperthreading not being a thing on the 2500K? I was amazed to see how fast Market Replay ran -- what took a few days before on my 6700K PC (as well as a laptop I have with an i5 8250), now takes less than an hour on the 2500K PC... which I'm very happy about, but don't understand... any ideas? I'm wondering if disabling hyperthreading on the 6700K would provide a speed boost?

    #2
    Hello,

    Thank you for your post. Unfortunately we do not have specific resources or testing on this matter. In general, additional PC resources will allow for quicker processing of data.

    To confirm, is this the speed it is taking to connect, or complete a backtest?


    So I may accurately assist you, please answer all of the following questions:
    • What version of NinjaTrader are you using? Please provide the entire version number. This can be found under Help -> About (Example: or 8.0.?.?)
    • What instrument (and expiry if applicable) have you selected? For example, ES 09-19, AAPL, EURUSD, etc.
    • (For a chart) what interval is selected? For example, 5 minute, 1 day, 2000 volume, 4 Renko, etc.
    • Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?
    We loook forward to assisting further.
    Eric B.NinjaTrader Customer Service

    Comment


      #3
      Time it takes to run a market replay across a contract period (ES, various periods). Takes over a day on the 6700K/8250, less than an hour on the 2500K.

      Same version on all machines, latest: 8.0.18.0. 16GB of RAM on all machines. Range charts set at 5. No errors.

      Is there a way to disable hyperthreading in NT8? I know I can system wide in the BIOS, but would rather not do that.

      Thanks!

      Comment


        #4
        Compare cpu activity manager. Hyperthreading is your friend.

        you might have to many open workspaces on your new machine.

        I too have previous generation hardware that is faster, but not at that scale. You have something else going on.

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by learningnt, Today, 10:52 PM
        0 responses
        2 views
        0 likes
        Last Post learningnt  
        Started by CandySNK, Today, 10:24 PM
        1 response
        6 views
        0 likes
        Last Post jiva12
        by jiva12
         
        Started by user1986, Today, 07:28 PM
        2 responses
        11 views
        0 likes
        Last Post NinjaTrader_EricB  
        Started by ericson, Today, 08:14 PM
        0 responses
        7 views
        0 likes
        Last Post ericson
        by ericson
         
        Started by jertrade, Today, 06:57 PM
        0 responses
        5 views
        0 likes
        Last Post jertrade  
        Working...
        X