• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

TOS ^ADD no longer working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    TOS ^ADD no longer working

    I am able to load stocks and other indices using my TDAmeritrade / TOS connection, but ^ADD has stopped working the last few days. Is there any reason this could be happening?

    #2
    So I may accurately assist you, please answer all of the following questions:
    • What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.?.?)
    • (For a chart) what interval is selected? For example, 5 minute, 1 day, 2000 volume, 4 Renko, etc.
    • Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Originally posted by habibalex View Post
      I am able to load stocks and other indices using my TDAmeritrade / TOS connection, but ^ADD has stopped working the last few days. Is there any reason this could be happening?
      What do you have it mapped to?

      TDA has been out right abusive lately with their data feed.

      Comment


        #4
        They screwed their feed up. NT7 and NT8 both are affected. This is going to take a strongly worded email to their tech support to get them clowns to fix it. They've been screwing with it for the last month (late starts ~9:20am instead of 8:00am EST).

        Comment


          #5
          • What version of NinjaTrader 8 are you using? 8.0.17.2
          • (For a chart) what interval is selected? 1 minute
          • Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report? No errors reported in output or log tab
          symbol is $ADD in TDAmeritrade symbol mapping

          Comment


            #6
            $ISSU is jacked too.

            Comment


              #7
              sledge , can you elaborate? What interaction have you had so far with TD Ameritrade about this symptom? Can you attach your emails here so I may better understand what you're referring to (or send them to PlatformSupport[AT]NinjaTrader[DOT]com ATTN 2195232)?
              Patrick G.NinjaTrader Customer Service

              Comment


                #8
                TOS ^ADD seems to have started working again.

                Comment


                  #9
                  So I am getting data right now, but the data is incorrect. In both trading view and the actual TOS platform, ADD is at 1200 but in ninja's ADD it is actually saying 709. Do you know what is going on?

                  Comment


                    #10
                    I would contact TD Ameritrade first and make sure that your account is in good standing (it seems your feed is cutting in and out recently). Also confirm that you're enabled for real-time data and not delayed.

                    After that, does the symptom persist if you restart NinjaTrader and test with your normal workspaces closed (so a new blank chart with no add-ons or templates)?
                    Patrick G.NinjaTrader Customer Service

                    Comment


                      #11
                      Originally posted by habibalex View Post
                      So I am getting data right now, but the data is incorrect. In both trading view and the actual TOS platform, ADD is at 1200 but in ninja's ADD it is actually saying 709. Do you know what is going on?
                      I would not expect them to match.

                      even TDA does not match TOS.

                      Comment


                        #12
                        i talked to support today they told me to contact ninja again and ask them what is going on with the symbol mappings. Many of those listed on https://research.tdameritrade.com/gr...N0Um93IjowfQ== do not work. In addition, those that do work like $TICK and $ADD do not match the TOS platform. not sure what is going on to be honest...

                        Comment


                          #13
                          Because its not ToS, but TDA feed with a touch of ToS added in recent years.

                          Comment


                            #14
                            Agree with habibalex

                            Comment

                            Latest Posts

                            Collapse

                            Topics Statistics Last Post
                            Started by madams212121, Today, 12:10 PM
                            5 responses
                            13 views
                            0 likes
                            Last Post NinjaTrader_Jim  
                            Started by jvanelli, Today, 12:19 PM
                            1 response
                            11 views
                            0 likes
                            Last Post NinjaTrader_BrendanC  
                            Started by raaxus, Today, 11:17 AM
                            2 responses
                            14 views
                            0 likes
                            Last Post raaxus
                            by raaxus
                             
                            Started by login_dejavu, Today, 02:22 AM
                            1 response
                            16 views
                            0 likes
                            Last Post NinjaTrader_Jesse  
                            Started by Leeroy_Jenkins, Yesterday, 09:17 AM
                            1 response
                            66 views
                            0 likes
                            Last Post NinjaTrader_Melissa  
                            Working...
                            X