• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Strategy "Exclude From Compilation" state is not saved

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Strategy "Exclude From Compilation" state is not saved

    I have a strategy which has been excluded from compilation a couple of days ago.

    Now I decided to include it back to compilation.
    I do this from NinjaTrader Editor -> Strategies -> Right click on the strategy for the Contextual Menu -> Exclude From Strategy.

    The state is temporarily set to "included" in the compilation, the name of the strategy changes from gray to white, but it is shown as "excluded" (and grayed out) from compilation once I close NinjaTrader Editor and reopen it. It seems like the state is not properly saved into the database or something.

    Also, I do not know if the second problem is related to the one above, but if I open the existing strategy with Strategy Builder and press View Code from within the wizard, NinjaTrader does not show any code (empty black window). It displays the source code only after I explicitly go to Strategies (on the right side) and choose to open the source code from there.

    #2
    Never mind, it seems the problem was on my side. I had another version of the strategy, with an identical name. I was able to create it since my original version was Excluded From Compilation at the time, in which case, the strategy filename on the hard drive has @@ as a prefix, so the second filename could be created without a problem.

    On my disk drive, I had something like this, when my problem occurred: @@SampleStrategy.cs (my original version, Excluded From Compilation) and SampleStrategy.cs (a new version).
    For some reason, NinjaTrader saw my SampleStrategy as Excluded From Compilation, although, in reality, I had two versions with identical name (without taking the @@ prefix into account).

    I could not find a way to delete this topic (false alarm). Anyway, in case somebody else stumbles across this problem, this might be a thing to check.

    Comment

    Latest Posts

    Collapse

    Topics Statistics Last Post
    Started by ralett, Yesterday, 07:29 PM
    1 response
    5 views
    0 likes
    Last Post NinjaTrader_Marco  
    Started by bboyle1234, Yesterday, 10:46 PM
    1 response
    3 views
    0 likes
    Last Post bltdavid  
    Started by swcooke, Yesterday, 04:29 PM
    0 responses
    5 views
    0 likes
    Last Post swcooke
    by swcooke
     
    Started by bboyle1234, Yesterday, 04:27 PM
    0 responses
    2 views
    0 likes
    Last Post bboyle1234  
    Started by swcooke, Yesterday, 03:31 PM
    2 responses
    12 views
    0 likes
    Last Post swcooke
    by swcooke
     
    Working...
    X