• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Horizontal lines disappear

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Horizontal lines disappear

    Using NT 8, I added several horizontal lines on across several charts that have instrument links set.

    Instrument = TSLA

    All lines showed up on all charts.

    I even have "Global drawing objects across workspaces" = true and I verified that the lines drawn between the 2 workspaces for the same instrument showed up on all charts.

    Today, I opened NT and my charts showed ZERO lines!!

    I added 1 line today, double clicked on it and the Drawing Objects popup window opened and on the left hand side in the Configured field, all the lines that I had drawn yesterday appeared with the visible property = FALSE. So the lines are there but hidden.


    WHY?????????

    Thx,
    Peter

    #2
    The visible property being set to false without any sort of manual change would be unexpected. I'll need more information to find out why you experienced this.

    So I may accurately assist you, please answer all of the following questions:
    • What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.?.?)
    • Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?
    • Were all the visible=false objects set to attach to all charts? Or were some also 'local' objects?
    Are you able to reproduce this symptom? If so, what exact steps would I need to follow?
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      8.0.17.2 64-bit

      I see I am 1 release behind.

      The issues below are sort of similar but in my case they are hidden, not removed.

      How about I upgrade and try again and see if this happens again...

      13601 Fixed Playback, DrawingTool Resolved a scenario where drawing objects could be removed when opening/closing workspaces
      13641 Fixed Playback, DrawingTool Global drawing objects drawn on historical bars while connected to live data could be removed from closed workspace when you connect/play playback data

      No screen errors

      I believe they were all set to "attach to all charts"

      I uploaded some errors I saw in the Log tab but I don't know if it is related.

      I first noticed this a few days ago and so I deleted all drawing objects and started over but there's obviously something wrong.

      I will upgrade to the latest release and report back if this happens again.

      If it does, do I open a new post or reply to this one?

      thx,
      Peter

      Attached Files

      Comment


        #4
        I would definitely recommend updating to the latest version before we attempt any further troubleshooting;
        • First, copy your license key from NinjaTrader under Help> License Key then exit NinjaTrader
        • Click on the link: http://ninjatrader.com/PlatformDirect
        • Enter your license key and press Submit
        • Select 'NinjaTrader 8'
        • Select 'Download'
        • Critical: Before running the installer, ensure NinjaTrader is closed.
        'Chart rendering failed' errors can have various root causes, but I would also make sure that you have all Windows updates installed and that you're running the latest non-beta graphics drivers available for your graphics card. If you're unsure how to check for/install either of these, please contact your PC manufacturer or an IT professional.

        Reply back to this post if you either A) experience this again and or B) can reproduce the symptom by following specific steps (post those steps).
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          After upgrading to 8.0.18.1 64-bit , I found 2 other instruments that I drew horizontal lines on but the old lines are not visible.

          All invisible lines show "Attach To: All Charts"

          Since these lines were drawn before the upgrade, does this not count?

          Are you only concerned with invisible lines drawn with the latest release?

          thx,
          Peter

          Comment


            #6
            Yes, lets see if it's possible to recreate the symptom on the newest version of NinjaTrader.
            Patrick G.NinjaTrader Customer Service

            Comment


              #7
              This keeps happening.

              Yesterday I deleted all old horizontal lines that were added before the upgrade to the latest version.

              I added a line on a TSLA chart that appeared on all linked charts including one in a different workspace.

              Today, the line wasn't there.

              I added a new one, double clicked on it and I could see another invisible line.

              It's also not visible in the other charts or in the other workspace.

              What's going on? This used to work.


              Comment


                #8
                If I understand correctly, the steps to reproduce this are:
                1. Open NinjaTrader
                2. Connect to data
                3. Create a chart
                4. Draw a horizontal line and set to attach to all
                5. ??? - What should I do at this point? Shut down and restart NinjaTrader? If so, does it happen immediately? Or does it seem to only occur if a day has passed?
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  I have 2 workspaces.

                  Each workspace has a market analyzer and several charts with different timeframes all linked up with an instrument link.

                  Every chart has "Show global draw objects = true"

                  The global options "global drawing objects across workspaces = true".

                  I put the same instrument in all charts. Either by clicking on an instrument in the Market analyzer or manually typing it in the chart.

                  I draw a line on workspace1 Chart1 and make sure it shows up in workspace1 Chart2 and Workspace2 Chart1 and 2.

                  That works but it seems that the next day they are not there. That's what I've been seeing lately anyways. I closed and re-opened NT right away and the lines are still there.



                  Where is the line information stored? Workspace, DB, somewhere else?? Trying to figure out if the NT DB and/ore workspaces are corrupt.
                  Keep in mind the settings below
                  "global drawing objects across workspaces = true".
                  "Show global draw objects = true"

                  I just deleted all lines in my old workspaces and created 2 brand new workspaces to test this but I can't know for sure that there isn't old line data hanging around so if u can tell me where the data is stored I can verify just to make sure. I'm guessing I have to wait until tomorrow to see what happens.

                  I will set lines in my old workspaces using different instruments to see what happens as well


                  Comment


                    #10
                    Local drawing objects would be stored as part of a chart within the workspaces files (Documents > NinjaTrader 8 > Workspaces folder), however, global objects are handled differently and are stored in files per instrument in Documents > NinjaTrader 8 > templates > GlobalDrawingObject. For example, you'll fine an 'ES 09-19.xml' file in this folder if you drew a global object on that instrument/expiry.

                    I would not expect the previous global object information to have been removed with the steps you've taken so far. Let's try this:
                    • Shut down NinjaTrader
                    • Navigate to Documents > NinjaTrader 8 > templates > GlobalDrawingObject folder
                    • Move all of the files in this folder to your desktop (or any location outside of the NinjaTrader folders)
                    • Restart, draw global lines, and test for the behavior
                    Patrick G.NinjaTrader Customer Service

                    Comment


                      #11
                      Do I have to re-create any workspaces before adding lines or use existing workspaces?

                      Comment


                        #12
                        From a technical perspective, it would be best to start from as 'clean' a state as possible, so a new workspace would be ideal. However, I do understand that may be a lot of work, so I think the test I've proposed would be acceptable while still using the same workspace if you feel that a new workspace would take too much effort to reproduce.
                        Patrick G.NinjaTrader Customer Service

                        Comment


                          #13
                          I figure I will try with 2 existing workspaces and 2 new ones.

                          I deleted Workspace 1 and Workspace 2 that had lines on TSLA charts and the TSLA file remained in the C:\Users\Peter\Documents\NinjaTrader 8\templates\GlobalDrawingObject folder even though no other workspaces have lines for TSLA. Is that a problem/bug?

                          I am creating Workspace 3 and 4 just in case since the GlobalDrawingObject folder files reference workspace names.

                          I will use another instrument instead of TSLA.

                          Comment


                            #14
                            Actually, the TSLA file in GlobalDrawingObject disappeared...

                            Comment


                              #15
                              Keep in mind that Windows File Explorer may not update in real-time. To refresh a location, go back to another folder then back to the location you want to view, or use the 'refresh' button.
                              Patrick G.NinjaTrader Customer Service

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by Slaywer, Today, 05:17 AM
                              0 responses
                              1 view
                              0 likes
                              Last Post Slaywer
                              by Slaywer
                               
                              Started by Balage0922, 10-01-2019, 11:09 AM
                              5 responses
                              71 views
                              0 likes
                              Last Post Fecdzo
                              by Fecdzo
                               
                              Started by Knortzsch, Today, 12:36 AM
                              2 responses
                              12 views
                              0 likes
                              Last Post Knortzsch  
                              Started by Wick Wrangler, Today, 12:42 AM
                              0 responses
                              9 views
                              0 likes
                              Last Post Wick Wrangler  
                              Started by saltminer, Yesterday, 11:06 PM
                              0 responses
                              5 views
                              0 likes
                              Last Post saltminer  
                              Working...
                              X