Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Missing commission during backtest

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NickyD
    replied
    Resetting Sim101 + Rebooting seems to have fixed it. ( The commission templates were always correct and applied)


    Thanks,
    Nick

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    Please double check that the commission template is configured correctly and that the simulator has the commission template selected.

    First, make sure that the commission template itself has a commission value for your specific instrument and/or futures in general. You'll find these settings within the Control Center > Commissions. You can find details on how to configure commission templates here. Can you provide a screenshot which demonstrates this is configured correctly?

    Next, ensure that the commission template is selected within the SIm101 account settings. To find these settings, go to the Control Center > Accounts tab > Right-click on the Sim101 account > Select 'Edit account'. Can you also provide a screenshot confirming that this is configured correctly?

    Then, before running the backtest, confirm that 'Include commissions' is enabled.

    Finally, If the issue persists after ensuring everything is configured correctly, try resetting your SIm101 account. Resetting a simulation account will clear all historical trade data from this account. Please follow the instructions below to reset a simulation account:
    • From the NinjaTrader Control Center window select the Accounts tab
    • Right click on your simulation account and select 'Edit Account'
    • Press the "Reset" button

    Leave a comment:


  • NickyD
    replied
    Yes, it does.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    Does the issue persist if you run a test with the 'Sample MA Crossover' strategy?

    Leave a comment:


  • NickyD
    replied
    Yes, it is checked.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    I've moved the thread and deleted your duplicate post.

    Is 'Include commission' enabled within the strategy in the Strategy Analyzer?

    Leave a comment:


  • NickyD
    replied
    Sorry, yes, I am using NT8. 8.0.13.1 64-bit

    Do I need to make a separate post there?

    Update:

    I resubmitted to the correct forum as this is off topic here:
    https://ninjatrader.com/support/foru...d.php?t=109194

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    You've posted in the NinjaTrader 7 forums. From the way you're describing how you've applied your commissions, it sounds like you may be talking about NinjaTrader 8.

    Please clarify - What version of NinjaTrader are you using? Please provide the entire version number. This can be found under Help -> About (Example: 7.0.1000.X or 8.0.X.0)

    Leave a comment:


  • NickyD
    started a topic Missing commission during backtest

    Missing commission during backtest

    Hi,

    My commissions are always showing as $0.00 on the strategy analyzer during back testing. It used to display the proper commission, I don't know what I did to it.

    I have the lifetime license commission template applied to the Sim101 account and I have a minimum and per unit rate defined for both Futures and NQ specifically ( which is the instrument I am backtesting). What am I missing?

    Thanks,
    Nick

Latest Posts

Collapse

Topics Statistics Last Post
Started by Eddie De Meira, Today, 11:26 AM
0 responses
2 views
0 likes
Last Post Eddie De Meira  
Started by pilotfo, Today, 10:59 AM
1 response
5 views
0 likes
Last Post NinjaTrader_Jesse  
Started by UltraNIX, Today, 10:38 AM
1 response
7 views
0 likes
Last Post NinjaTrader_Jim  
Started by torch2k, Today, 10:17 AM
1 response
6 views
0 likes
Last Post NinjaTrader_BrandonH  
Started by Photon66, Today, 09:49 AM
1 response
13 views
0 likes
Last Post NinjaTrader_BrandonH  
Working...
X