• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

adding @CHN50 to ninjatrader

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    adding @CHN50 to ninjatrader

    CHN50 exists in the FXCM Trading Station Platform

    is there a way to add this symbol to ninjatrader? all other FXCM CFDs seem to be defined in NT8 , just not @CHN50

    #2
    Hello NinjaCustomer,

    Thank you for your post.

    Glad to assist. First, go to Connections > Configure > Select the FXCM connection in the lower left, which will display the settings to the right. To make sure FXCM data is requested, unselect "NinjaTrader historical data servers" > Press OK. Disconnect and reconnect to complete the process.

    NinjaTrader comes pre-loaded with the most commonly traded instruments. Should you wish to add an instrument to your database that is not located in the preloaded lists, please follow these steps:

    Navigate to the Control Center > Tools > Instruments window.
    Left-click on the ‘add’ button that appears near the lower right-hand corner of the Instruments window.
    Enter instrument-specific symbol mapping, exchanges, Currency, and other information on the Instrument editor that appears. This information will largely depend on your broker or data feed provider’s specific settings regarding the instrument in question.

    For @CHN50, Enter "CHN50" as the symbol map, Default for the Exchange.


    Left-click the OK button once each field has been filled out with correct information.
    The new instrument has now been created in your database. Should you wish to add this instrument to an instrument list:

    Navigate to the Control Center > Tools > Instruments Lists window.
    Left-click to select the instrument list that you wish to add this instrument to in the left panel, then left-click on the ‘add’ button at the bottom of the right-hand panel.
    Type the name and (if applicable) front month of your instrument in the search field that appears. Press the Enter button on your keyboard to confirm this change.
    Left-click the OK button to close the Instrument Lists window.
    Your new instrument is now added to the instrument list of your choice.

    Please let us know if we may be of further assistance.
    Eric B.NinjaTrader Customer Service

    Comment


      #3
      thanks i tried to do as you said but I got an error

      Error on requesting bar series: "Unable to request historical data for @CHN50 Default, no symbol map is available"

      Comment


        #4
        Thank you for your reply.

        To test, please try the attached configuration. After making the changes, please disconnect/reconnect and open a new @CHN50 chart.

        We look forward to assisting further.
        Attached Files
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          did as you suggested, still get that same error.

          historical ninja servers are off also, as you mentioned.I tried to turn them on after this error and all hell broke loose (pure virtual function call runtime error and crashing of ninjatrader).. so I turned it back off again.

          But I still get that same error message from my last post

          Comment


            #6
            Thank you for your reply.

            Sorry to hear that didn't help. Are you able to receive @CHN50 data via FXCM Trading Station?

            Can you please also post a screen shot of the Tools > Instrument window settings?

            We look forward to assisting further.
            Eric B.NinjaTrader Customer Service

            Comment


              #7
              yes, however I use the a different demo account for trading station.

              The demo fxcm I use on ninjatrader is via the ninjatrader site.The trading station demo is via the fxcm site.
              Attached Files

              Comment


                #8
                Thank you for your reply.

                I see, this may be due to backend items with each respective demo. The NinjaTrader FXCM demo will be able to login to FXCM Trading Station as well - please test the login there and pulling up #CHN50 data.

                On my end, I am able to receive data off a recent demo with these settings. If you are not able to receive data with the current demo, try requesting and setting up a new one via the link below.

                https://ninjatrader.com/FreeLiveData

                We look forward to assisting further.
                Eric B.NinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by RedDuke, Today, 06:14 PM
                0 responses
                4 views
                0 likes
                Last Post RedDuke
                by RedDuke
                 
                Started by DariusDeck, Today, 04:22 PM
                1 response
                10 views
                0 likes
                Last Post NinjaTrader_Marco  
                Started by pstrusi, Today, 05:05 PM
                1 response
                3 views
                0 likes
                Last Post pstrusi
                by pstrusi
                 
                Started by saeed, Today, 10:20 AM
                4 responses
                19 views
                0 likes
                Last Post saeed
                by saeed
                 
                Started by priceisking, Yesterday, 07:44 PM
                1 response
                27 views
                0 likes
                Last Post NinjaTrader_Kate  
                Working...
                X