• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

TD data shows first bar of day as Zero

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    TD data shows first bar of day as Zero

    This is the second week in a row that the first bar on my charts for Monday are showing up as zero. See the attachments.

    I'm connected to TD Ameritrade. Last week the bar resolved itself by the end of the day. Today I noticed the issue again around 1am eastern time even though the bar's time now registers 7:15am for all the charts shown in the attached Word document.

    It appears to only be happening to instruments I've loaded into a NT chart during the last week or this morning after I noticed this issue began. Instrument's I've never loaded into a chart before and checked after 9am this morning look fine.

    Note these zero bar charts are not using any indicators. It's worth noting that all of the zero bar charts are using the "Default 24 x 7" Trading Hours and if I change Trading Hours to use "<Use instrument settings>" then the zero bar disappears. Also the zero bar shows up on all the various minute charts (ie. 1, 2, 15, 30, 60) for the problematic instruments but it doesn't show up on the daily, weekly charts. It's also interesting that the issue does not show up using the "Default 24 x 5" Trading Hours (keeping in mind I've never selected that hour type).

    Any ideas out there?
    Attached Files

    #2
    It sounds like your cache may be contributing to the symptom if only specific trading hours templates have the symptom. To delete the cache, follow the steps below.
    • Shut down NinjaTrader.
    • Open the Documents > NinjaTrader 8 > db folder.
    • Delete the sub-folder named 'cache'.
    • Restart NinjaTrader and test.
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Shut down NT, Deleted Cache and restarted. The issue remains.

      Comment


        #4
        I cannot reproduce this symptom on my end when connected to TD Ameritrade. Please send me your log and trace files so that I may look into what occurred.
        • You can do this by going to the Control Center-> Help-> Email Support
        • Ensuring 'Log and Trace Files' is checked will include these files. This is checked by default.
        • Please reference the following ticket number in the body of the email: 2312381 ATTN PatrickG
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          Sent! I think you would need to connected to TD on Sunday afternoon and leave NT open and connected overnight. Then check it first thing Monday morning.

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by MARTIN MARTIN, Yesterday, 01:01 PM
          3 responses
          39 views
          0 likes
          Last Post MARTIN MARTIN  
          Started by NickyD, Today, 11:42 AM
          1 response
          9 views
          0 likes
          Last Post NinjaTrader_Jim  
          Started by cupir2, Today, 11:25 AM
          3 responses
          15 views
          0 likes
          Last Post NinjaTrader_Jesse  
          Started by 7robert, Today, 11:15 AM
          2 responses
          7 views
          0 likes
          Last Post 7robert
          by 7robert
           
          Started by meandthetrio, Today, 10:52 AM
          0 responses
          11 views
          0 likes
          Last Post meandthetrio  
          Working...
          X