• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Alerts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Alerts

    I have a chart with some 20 tabs open, all different instruments but the same layout. I have 2 alerts assigned to each. When I change connection to Simulated Data Feed, it turned off my Alerts. I would like for them to be turned back on all at once. Is there a way to turn them all off and all on at one time at will? Clicking through 20+ tabs and reactivating 2 Alerts each is a real pain in the gazoo.

    Dolfan

    #2
    Hello,
    Thank you for your post. Unfortunately there is not a method to auto enable all alerts. What Rearm type is in use with the alerts? Is this occurring every time the simulated data feed is used?

    We look forward to assisting further.
    Eric B.NinjaTrader Customer Service

    Comment


      #3
      I set the Rearm to "On condition reversed". They stay armed otherwise and I would also note that when I made the simulated connection, I was asked if I wanted to keep the alerts. I chose no and so they all turned off. I cannot say about "every time the simulated data feed is used" because this is the first time I have used it with Ninja 8.

      Dolfan

      Comment


        #4
        Thank you for your reply.

        I see, switching Instruments will show a message of this nature, but it would be unexpected to do the same when switching to the simulated data feed. Can you please try setting up an a test alert and switching to the simulated data feed again? Testing on my end, this does not prompt the alerts to be moved.

        Please let me know the behavior you see with these steps.

        We look forward to assisting further.
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          Will do a little later today. Will also record video of it all for clarity.

          Dolfan

          Comment


            #6
            Eric,

            I hope this video https://www.screencast.com/t/IzLeGGPB explains things clearly. This time I chose to re-enable the Alerts and you can see they came back. Let me know if you need more.

            Dolfan

            Comment


              #7
              Thank you for your reply and additional information Sorry for the oversight, this is expected when the Alert action in question is set to Submit an order.
              Eric B.NinjaTrader Customer Service

              Comment


                #8
                OK, so I have this alert set to run on some 30 instruments and I was getting alerts/orders just fine. They seem to have stopped for some reason. I have checked to make sure they are all there and all enabled. Any thoughts on why they suddenly stopped working for me?

                Dolfan

                Comment


                  #9
                  Never mind. Rebooted my machine and orders are popping up everywhere now.

                  Comment

                  Latest Posts

                  Collapse

                  Topics Statistics Last Post
                  Started by ntbone, Yesterday, 08:10 PM
                  0 responses
                  8 views
                  0 likes
                  Last Post ntbone
                  by ntbone
                   
                  Started by chrislou, 08-28-2015, 03:27 AM
                  14 responses
                  2,881 views
                  0 likes
                  Last Post nkhoi
                  by nkhoi
                   
                  Started by outofstock, Yesterday, 06:40 PM
                  2 responses
                  8 views
                  0 likes
                  Last Post outofstock  
                  Started by saeed, Yesterday, 12:32 PM
                  3 responses
                  41 views
                  0 likes
                  Last Post NinjaTrader_PatrickG  
                  Started by motog4, Yesterday, 11:42 AM
                  3 responses
                  21 views
                  0 likes
                  Last Post NinjaTrader_PatrickG  
                  Working...
                  X