• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Weeky/Daily charts: merge bug

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weeky/Daily charts: merge bug

    Hi,

    Something very strange has happened to to some of my charts, and I cant put my finger on the root cause. I can see the isuse most clearly in 6J, 6M, 6E, 6B, ZT, ZF, but its possible other symbols are affected too, but now i see it only affecting US Bond Futures and FX futures > my weekly/daily charts dont look anything like they did a few days ago, some just look wrong.

    *** 6J: Hopefully you'll noticed straight away that the weekly chart looks wrong and so does the daily chart, with all the gaps (even though this is set to merge backadjusted).
    The scale also goes into negative numbers. See attached "6J"

    *** 6M: Seeing the same issue in 6M, but looks like the most recent part of the weekly chart is fine, anything further back (to the left of the yellow line) is busted. Once again, scale goes into negative numbers. See attached "6M"

    *** 6E, 6B,Weekly chart - These seem fine at first glance, but I am sure there is something is wrong here too... the weeky chart 'look very different' to the way they looked a few days ago. Keen to see whether you chart looks different. See attached "6B and 6E".

    *** ZT: Looks completely wong too. Weekly is off, gaps all over daily chart.
    See attached ZT.

    *** ZF: Looks completely wong too. Weekly is off, gaps all over daily chart, also see gaps in the scale here.See attached "ZF". What ever is affecting ZF is also affecting ZN... although its less obvious in ZN, but something has changed.


    Nothing has changed on my end (I havent upgraded or touched the database), apart from a weekend restart and rolled over futures contracts as and when required. I suspect the issue is due to a backend change on your side.. something like tick size/scales/merge policy setting.

    I use Continuum as my datafeed, and Options > Market Data > Global Merge Policy > is set to Merge back adjusted.

    Please advise

    Thanks
    AK
    Attached Files

    #2
    Hello akvevo,

    Thank you for your post.

    Glad to assist. What version of NinjaTrader are you using? Please provide the entire version number. This can be found under Help -> About 8.0.X.0)

    To test, please reset your instruments, this will ensure that the internal setting for the instruments are up-to-date with server specifications: To reset your instruments please follow the steps below.




    1.
    First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
    2.
    Next, reset your instruments by navigating to the Control Center > Tools > Database Management
    3.
    In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
    4.
    Lastly, restart NinjaTrader for the changes to occur

    We look forward to assisting further.
    Eric B.NinjaTrader Customer Service

    Comment


      #3
      Hi EricB,

      I am on 8.0.12.0 64-bit (Standard).
      I followed your steps 1-4, but this hasn't made a difference.
      The charts still look out of line.

      A

      Comment


        #4
        Thank you for your reply.

        Please shut down and update with your license key (Help > License key) to the current version from the below link.

        https://ninjatrader.com/PlatformDirect

        Once this is complete, please restart and right click in the chart > select Reload All Historical Data.
        Eric B.NinjaTrader Customer Service

        Comment


          #5
          Hi,

          I upgrade to 8.0.14.2 64-bit.
          I right clicked in the chart > selected Reload All Historical Data.
          This hasn't made a difference, the charts still look out of line.

          A

          Comment


            #6
            What trading hours template are your charts using? Right-click on your chart > Data Series > look for the 'Trading Hours' property.

            If you change this to 'Default 24/7, do your charts look more 'normal'?
            Patrick G.NinjaTrader Customer Service

            Comment


              #7
              Thanks Patrick,

              Right-click on chart > Data Series > 'Trading Hours' set to <Use instrument Settings>.
              If I navigate to the instrument via Tools > Instrument > I see "CME FX Futures ETH" (for all FX futures, the one with the chart problem, and the ones without).

              If I take one of the bad chart like (6M), and right-click on chart > Data Series > 'Trading Hours' set to Default 24/7 >> nothing changes.
              If I reload historical data > nothing changes.

              Also tried on ZN to be sure, nothing changes here either.

              Comment


                #8
                It definitely looks like an issue which would've been resolved via an instrument update, but let's see if clearing the cache helps resolve this issue.
                • Shut down NinjaTrader.
                • Open the Documents > NinjaTrader 8 > db folder.
                • Delete the sub-folder named 'cache'.
                • Restart NinjaTrader and test.

                Does the issuer persist?
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  Thanks Patrick,

                  Followed your instructions. Still seeing the same issue with the same symbols
                  Curious whether you are able to replicate

                  Comment


                    #10
                    Please send me your log and trace files so that I may look into what occurred.

                    You can do this by going to the Control Center-> Help-> Email Support

                    Ensuring 'Log and Trace Files' is checked will include these files. This is checked by default.

                    Please reference the following ticket number in the body of the email: 1931365 ATTN Patrick G
                    Patrick G.NinjaTrader Customer Service

                    Comment


                      #11
                      Thanks Patrick, I sent these over

                      Comment

                      Latest Posts

                      Collapse

                      Topics Statistics Last Post
                      Started by Martin89, Today, 02:09 AM
                      0 responses
                      6 views
                      0 likes
                      Last Post Martin89  
                      Started by Trade95, Yesterday, 05:38 PM
                      1 response
                      8 views
                      0 likes
                      Last Post NinjaTrader_EricB  
                      Started by Karelgp7, Yesterday, 03:16 PM
                      1 response
                      16 views
                      0 likes
                      Last Post NinjaTrader_ChelseaB  
                      Started by orenytz, Yesterday, 01:18 PM
                      1 response
                      23 views
                      0 likes
                      Last Post NinjaTrader_PaulH  
                      Started by des.kkeng, Yesterday, 01:10 PM
                      1 response
                      16 views
                      0 likes
                      Last Post NinjaTrader_PatrickG  
                      Working...
                      X