Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Plotting MA's based on a oscillator in a market analyzer.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Plotting MA's based on a oscillator in a market analyzer.

    Hi I'm brand new to NT and to platforms that require coding also. Trying to create a column in an analyzer window that plots the value of an average that is based on an indicator. Seems intuitive but am getting no values populating. Come to think of it, The analyzer's showing no price data or any other indicator values either. Have reloaded historical data, and nothing. I'm using Kinetck EOD data and it's connected. What am i doing wrong?
    Thanks
    Swing
    Last edited by Swing123; 01-03-2020, 05:54 AM.

    #2
    I suspect the issue is the use of Kinetick EOD since this only provides daily historical data and no real-time data. The Market Analyzer requires real-time data to function.

    Below I have provided a link to our site where you can request a free demo for futures and/or forex data.

    http://ninjatrader.com/FreeLiveData


    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Hi Patrick
      Thanks for the reply. I'll be signing up to Kinetick live data in due course. Thanks for the link. I must have a false memory, i was sure i'd had EOD data showing in an analyzer.
      Thanks
      Swiing

      Comment


        #4
        I've got live data connected. It is populating the price columns, but the RSI value is 0, which is incorrect. What could i be dping wrong?
        Thanks

        Comment


          #5
          Odd as stochastics will update. Revisiting setting for RSI...

          Comment


            #6
            I'm using daily settings for the RSI and Stoch is based on 1 min. If i change RSI to 1 min it plots. Why is it not plotting for daily data as the "type" in the data series section?

            Comment


              #7
              Have got it to draw the plot indicator values by changing the timeframe to bars instead of days - but to get the correct value for RSI to show it requires 100 bars - why is this and how do i know how many bars are required for each different indicator to ensure accurate values being plotted in the analyzer?

              Comment


                #8
                Please clarify - the RSI indicator column calculating on daily data prints a zero? Or prints an ellipsis (...)?
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  AS i've progressed it did both. I now have it priting correct values, but to do so i have to do the following (did this by trial and error - not entirely sure what i am doing).
                  1. Set the data series section, "type" field as day.
                  2. Set the Time Frame series section, "load data based on" field as to bars (instead of day - i don't understand why i have to do this).
                  3. But the value plotted for RSI varies dependant upon the no i enter in the "bars to load" field of the time frame section.

                  So, could you please tell me, 1. why i have to set "load data based on" as bars and not days? Also, why the rsi value varies depending upon the no. of bars loaded? And 3, how can i know in future that i have the correct data plotting, i.e. how many do i set the "bars to load" at?

                  Thanks

                  Comment


                    #10
                    Apologies! I have discovered that i do not need to do the above.

                    Comment


                      #11
                      I was getting confused with the plotting of the RSI and it's smoothing average vs an average based on it. All sorted now. Cheers.

                      Comment


                        #12
                        No i don't have it sorted. (Getting v confused here). Ignore my last post saying things are fine - my initial numbered questions still stand. Can you please help.

                        Comment


                          #13
                          Any there is an additonal complication - the number of bars to load to get the right RSI value on ZW gives the wrong RSI value on GC!

                          Comment


                            #14
                            1. As of today, 21 days to load would give us the 14 days needed for the RSI to make a first plot
                            2. Days to load and bars to load are fundamentally different and I would expect different values. For example, 'days to load' would include Saturdays (when there is no futures trading) while 'bars to load' would not.
                            Patrick G.NinjaTrader Customer Service

                            Comment


                              #15
                              1. You would think this is the case - but if put 21 days i get an incorrect value for RSI.
                              2. Thanks for the clarification.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by trader252, Today, 06:04 PM
                              0 responses
                              7 views
                              0 likes
                              Last Post trader252  
                              Started by tradesmart27, Today, 05:29 PM
                              0 responses
                              5 views
                              0 likes
                              Last Post tradesmart27  
                              Started by nothingtrader, Today, 05:10 PM
                              0 responses
                              9 views
                              0 likes
                              Last Post nothingtrader  
                              Started by SuperDude123, Today, 02:54 PM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_ChelseaB  
                              Started by mohawkTrader, Today, 02:12 PM
                              2 responses
                              20 views
                              0 likes
                              Last Post mohawkTrader  
                              Working...
                              X