Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Start Up Error - Object Reference

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Start Up Error - Object Reference

    I am getting an error upon start up - Unhandled Exception: Object Reference not set to an instance of an object.

    I had this problem once before when I deleted a strategy and was open in the strategy analyzer. Once I closed all the strategy analyzer tabs the error went away.

    This time it happened after I deleted a sim account -
    I couldn't open one of the workspaces and got that error message again. I tried to delete the workspace from inside NT but it would not let me. I deleted the workspace from the NT folder itself (I am not sure if I got all the references/folders to that workspace) but I am still getting the error message on startup. I the only workspace I have left is the one named untitled.

    I do not know if the above has anything to do with the problem but any assistance would be appreciated.


    Click image for larger version

Name:	Object Reference error.JPG
Views:	192
Size:	15.8 KB
ID:	1082747
    Click image for larger version

Name:	Object Reference Log.JPG
Views:	136
Size:	80.2 KB
ID:	1082749
    Attached Files

    #2
    Hi sdauteuil, thanks for your note.

    Please first try moving all of the workspaces out of your Documents\NinjaTrader 8\workspaces to your desktop or some other folder and delete the Workspaces.xml file as well. If the problem does not occur then move your workspaces back into the workspaces folder and try to open them.

    If this continues please re-install NinjaTrader by running the installer from the link below:

    https://ninjatrader.com/GetStarted
    Chris L.NinjaTrader Customer Service

    Comment


      #3
      The workspace did not work.

      What is the best way to re-install in terms of backup?

      I have active strategies I use - I do keep a separate backup of these. I also have a large amount of historical data.

      Should I run a NT backup - re-install - restore from backup
      or
      Make a copy of the Ninja Trader 8 folder - re-install - replace the copy of the Ninja Trader 8 folder.

      Thanks again

      Comment


        #4
        Hi sdauteuil, thanks for your reply.

        Before doing a backup you should try doing a full reset of your database. If this does not work it means there is some problem within the bin/custom folder (the folder that holds all of the NinjaScript files) Your NinjaScripts should be re-installed if this is the case.

        To reset your database:
        • Close out of NT
        • Select My Documents--> NinjaTrader 8--> db--> "NinjaTrader.sdf" file (may only say 'NinjaTrader' depending on your Windows File Explorer settings)
        • Right click on NinjaTrader.sdf and select "Rename" *Name it "OLDNinjaTrader.sdf"
        • Restart NT and test with a new database.
        • If the problem continues to reverse this procedure (delete the newly created db and re-name the old one back to normal).

        If there is something within the NinjaTrader 8/bin/custom folder causing the problem then you should create a restore point that does not include the custom scripts and re-install them after you run the backup procedure.

        https://ninjatrader.com/support/help...p__restore.htm - Backup and restore


        Chris L.NinjaTrader Customer Service

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by b16_aln, Today, 10:18 AM
        0 responses
        2 views
        0 likes
        Last Post b16_aln
        by b16_aln
         
        Started by luisjmh, Today, 10:14 AM
        0 responses
        1 view
        0 likes
        Last Post luisjmh
        by luisjmh
         
        Started by bc24fl, Today, 09:57 AM
        0 responses
        6 views
        0 likes
        Last Post bc24fl
        by bc24fl
         
        Started by sidlercom80, 11-30-2020, 11:52 AM
        1 response
        29 views
        0 likes
        Last Post bltdavid  
        Started by Impeesa, Today, 09:52 AM
        1 response
        5 views
        0 likes
        Last Post NinjaTrader_Kate  
        Working...
        X