• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Problem Connecting to License Servers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem Connecting to License Servers

    NT8 had been working fine yesterday, but for some reason it's saying it's having issues connecting to the license servers. My internet is working fine, and I tried restarting PC, and internet.

    #2
    Hello HinduMVP,

    Thank you for your note.

    Please follow the steps below to manually attach your log and trace files to an email to platformsupport[AT]ninjatrader[DOT]com with "ATTN CHRIS S" in the subject line so I may investigate this matter further.

    * Open your NinjaTrader folder under Documents.
    * Right click on the 'log' and 'trace' folders and select Send To> Compressed (zipped) Folder.
    * Send the 2 compressed folders as attachments to this email.
    * Once complete, you can delete these compressed folders.

    I look forward to your reply.
    Chris Sch.NinjaTrader Customer Service

    Comment


      #3
      Thanks Chris, just sent the email.

      Comment


        #4
        Me Too

        Same problem here.
        Any thing to report?

        Comment


          #5
          Our licensing servers have not experienced any recent downtime. We'll need to figure out why certain users cannot reach our servers successfully.

          I would recommend the following steps:
          • Restart NinjaTrader
          • Restart your modem and (if applicable) router
          • Restart your PC
          • Clear your DNS - Open the Command Prompt and run this command: ipconfig /flushdns
          • If you are not already and the option is available to you, connect to the internet using an ethernet cable. Wireless connections are significantly more unreliable.
          • Ensure exceptions have been added into any firewall/antivirus/backup programs for the (My) Documents/NinjaTrader 8 folder.
          • If the above steps do not help, contact your ISP and let them know you are experiencing a highly unstable connection. An issue of connectivity may exist on their end.
          Patrick G.NinjaTrader Customer Service

          Comment


            #6
            Originally posted by NinjaTrader_PatrickG View Post
            Our licensing servers have not experienced any recent downtime. We'll need to figure out why certain users cannot reach our servers successfully.

            I would recommend the following steps:
            • Restart NinjaTrader
            • Restart your modem and (if applicable) router
            • Restart your PC
            • Clear your DNS - Open the Command Prompt and run this command: ipconfig /flushdns
            • If you are not already and the option is available to you, connect to the internet using an ethernet cable. Wireless connections are significantly more unreliable.
            • Ensure exceptions have been added into any firewall/antivirus/backup programs for the (My) Documents/NinjaTrader 8 folder.
            • If the above steps do not help, contact your ISP and let them know you are experiencing a highly unstable connection. An issue of connectivity may exist on their end.
            Hey Patrick,

            I've tried every single one of those suggestions, and nothing still works. Restarted NT, restarted mode, restarted PC, cleared DNS, tried ethernet, checked firewall and even tried disabling it, contacted ISP and said everything was fine (internet is working perfectly fine, only NT application is not working). I'm also on sim if that means anything. This is very weird as it was working fine just last night.

            Thanks for your help.

            Comment


              #7
              Originally posted by 123tangerine View Post
              Same problem here.
              Any thing to report?
              Whereabouts are you from? I'm from Toronto.

              Comment


                #8
                We've been finding out through email support of clients that their anti-virus/firewall is the root of the issue.

                Specifically, I worked a case just now where Kaspersky was blocking NinjaTrader even with exceptions added. The only way to resolve the issue was to disable Kaspersky.

                What anti-virus/firewall programs are you using?
                Patrick G.NinjaTrader Customer Service

                Comment


                  #9
                  Connection failed

                  Hello,

                  I tried to connect NT7 and NT8 and it says: contact support

                  Is this a known issue? Because it worked all morning.

                  How to solve?

                  Comment


                    #10
                    Originally posted by martinforsure2 View Post
                    Hello,

                    I tried to connect NT7 and NT8 and it says: contact support

                    Is this a known issue? Because it worked all morning.

                    How to solve?
                    What is the entire specific message? Does it mention your license key at all? If not, what you're experiencing is a separate issue. Please reach out via email to solve the separate issue.
                    Patrick G.NinjaTrader Customer Service

                    Comment


                      #11
                      Originally posted by NinjaTrader_PatrickG View Post
                      We've been finding out through email support of clients that their anti-virus/firewall is the root of the issue.

                      Specifically, I worked a case just now where Kaspersky was blocking NinjaTrader even with exceptions added. The only way to resolve the issue was to disable Kaspersky.

                      What anti-virus/firewall programs are you using?
                      Oh that's interesting. I'm also using Kaspersky. I'll try disabling it and check.

                      Comment


                        #12
                        Originally posted by NinjaTrader_PatrickG View Post
                        We've been finding out through email support of clients that their anti-virus/firewall is the root of the issue.

                        Specifically, I worked a case just now where Kaspersky was blocking NinjaTrader even with exceptions added. The only way to resolve the issue was to disable Kaspersky.

                        What anti-virus/firewall programs are you using?
                        Hey Patrick,

                        I just disabled and I'm finally able to connect to the license servers! However, I'm not able to connect to my CQG data feed for some reason.

                        It says "An unspecified Error has Occurred. Please Contact Support Desk (Logon failed)".

                        So thank you very much for solving the root cause of the issue, but now I think we have a different issue.

                        Also, is there any way I can enable Kaspersky and still get it to work? I had a tech support member add NT onto the exceptions as well and it didn't work.

                        Thanks!

                        Comment


                          #13
                          Potential Workaround

                          Originally posted by HinduMVP View Post
                          It says "An unspecified Error has Occurred. Please Contact Support Desk (Logon failed)".

                          This is precisely the error I was getting too. It was working fine just a few hours ago.


                          I'm in UK.
                          I traced the route to demo.cqgtrader.com with pingplotter (basically a traceroute with more statistics)
                          All hops look fine except the last one, which is demo.cqgtrader.com. It is not reachable.
                          I'm using ESET Internet Security.
                          The firewall is set to interactive and rules for the software have been added.


                          I got it to work after resetting the dns cache.


                          Here is what I did:


                          Open the cmd (command line) as previously mentioned
                          type the following
                          ipconfig /release
                          ipconfig /flushdns
                          ipconfig /renew


                          Brief explanation
                          /release will basically disconnect your adapter so you will LOSE the internet connection
                          /flushdns will delete the dns cache

                          /renew will activate/connect the adapter again


                          Sometimes the dns cache can be populated with the "wrong" data again if the command is triggered while a connection is active.
                          Deleting the cache while the adapter is disconnected/deactivated can help in such cases.


                          Best of luck!


                          EDIT: Curiously enough, even after being connected to the demo server, pingplotter still has packet losses at the last hop (at demo.cqgtrader.com)
                          This however can be due to the server configuration etc, which could simply not send a reply to your ping/tracert.
                          This means that results from a traceroute are insignificant if you can connect to all hops but the last one.


                          To add a bit more depth, you might see several "Request timed out"s while still being able to connect to your destination.
                          Again, the reason is that the connection is perfectly fine, while the router or server simply blocks or doesn't reply to your tracert request, which gives you the "timed out"
                          message as it didn't receive any positive response.
                          Last edited by klasterer; 07-03-2018, 09:34 AM.

                          Comment


                            #14
                            ISSUE FIXED! Step-By-Step provided below. Essentially Patrick was right; disabling Kaspersky did the trick. I had a tech support member add NT onto the exclusion and it still didn't work for some reason. I ended up calling Kaspersky tech support and they allowed me to add it on successfully since I'm sure you still want your anti-virus protection.

                            1. Open Kaspersky.

                            2. Click the Settings button on the bottom left corner (gear looking button).

                            3. Click on the 'Additional' tab.

                            4. Click 'Threats and Exclusions'.

                            Here, my NT tech support member clicked on 'Manage Exclusions' and added the NT files. However you have to click "Specify trusted Applications" instead.

                            5. Click "Specify trusted applications".

                            6. Click brown, and find the NinjaTrader.exe file under Program Files (x86) > NinjaTrader 8 > bin64 > NinjaTrader 8

                            7. Once adding it, check the first five boxes on Kaspersky, and click Add.

                            8. Restart PC, and it will work.

                            Hope that helps anyone else with the issue.

                            Comment


                              #15
                              Originally posted by klasterer View Post
                              This is precisely the error I was getting too. It was working fine just a few hours ago.


                              I'm in UK.
                              I traced the route to demo.cqgtrader.com with pingplotter (basically a traceroute with more statistics)
                              All hops look fine except the last one, which is demo.cqgtrader.com. It is not reachable.
                              I'm using ESET Internet Security.
                              The firewall is set to interactive and rules for the software have been added.


                              I got it to work after resetting the dns cache.


                              Here is what I did:


                              Open the cmd (command line) as previously mentioned
                              type the following
                              ipconfig /release
                              ipconfig /flushdns
                              ipconfig /renew


                              Brief explanation
                              /release will basically disconnect your adapter so you will LOSE the internet connection
                              /flushdns will delete the dns cache

                              /renew will activate/connect the adapter again


                              Sometimes the dns cache can be populated with the "wrong" data again if the command is triggered while a connection is active.
                              Deleting the cache while the adapter is disconnected/deactivated can help in such cases.


                              Best of luck!
                              Thanks a lot!!

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by alextrd, Today, 01:51 PM
                              0 responses
                              3 views
                              0 likes
                              Last Post alextrd
                              by alextrd
                               
                              Started by Boonfly8, Today, 12:10 PM
                              1 response
                              5 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Started by NinjaTrader_PaulH, Today, 11:24 AM
                              0 responses
                              4 views
                              0 likes
                              Last Post NinjaTrader_PaulH  
                              Started by catulopc, Today, 10:58 AM
                              1 response
                              7 views
                              0 likes
                              Last Post NinjaTrader_SergeyS  
                              Started by swcooke, Today, 09:20 AM
                              7 responses
                              22 views
                              0 likes
                              Last Post NinjaTrader_Jesse  
                              Working...
                              X