• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

CFD instruments

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    CFD instruments

    I want to use the following CFDs from Interactive Brokers.


    IBUST100
    IBUS500
    IBUS30


    I have looked at the standard instruments. Found NAS100, USTECH100, USSP500, SPX500, WALLSTREET, US30


    However when I want to add one of these instruments to an instrument list I get the error message : Invalid instrument name

    #2
    The following instruments you mentioned have built-in mapping for Interactive Brokers and should function as long as the connected Interactive Brokers account has a real-time data subscription for the appropriate exchange to receive this data:
    • NAS100 has a mapping for Interactive Brokers of IBUST100||||USD
    • SPX500 has a mapping for Interactive Brokers of IBUS500||||USD
    • US30 has a mapping for Interactive Brokers of IBUS30||||USD


    USTECH100, USSP500, and WALLSTREET do not have built-in mapping for use with Interactive Brokers.

    Do all instruments produce the same message in your log? Or do you receive different messages for one set versus the other set? Do you receive real-time (not delayed) data for these instruments within Interactive Brokers Trader Workstation?

    What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.X.0)

    What version of Interactive Brokers Trader Workstation are you using?
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Hi, I am using TWS 960 2.g . Within TWS the CFDs are working fine. However when I try to use the instruments mentioned in Ninja Trader (either add them to an instrument list or directly, I get the error message : Instrument Invalid

      Comment


        #4
        Please clarify - all 6 of these instruments produce the same message? Is this a pop-up message, or do you see this message in the log tab of the Control Center? When you say 'directly', do you mean trying to create a chart? Please elaborate.

        Do other instruments work in real-time without issue or messages? Or do no instruments at all work?

        What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.X.0)
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          Originally posted by NinjaTrader_PatrickG View Post
          Please clarify - all 6 of these instruments produce the same message? Is this a pop-up message, or do you see this message in the log tab of the Control Center? When you say 'directly', do you mean trying to create a chart? Please elaborate.

          Do other instruments work in real-time without issue or messages? Or do no instruments at all work?

          What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.X.0)

          I am using NT 8.0.14.1 64-bit



          I get the same message with all thes 6 instruments. Other instruments (including currency CFDs are working fine). I get a pop-up error message (when wanting to create a chart with the instrument or adding the instrument to a instrument list).

          Comment


            #6
            To be clear here, I would expect NAS100, SPX500, and US30 to work as long as your IB account has the appropriate data enablements, but we'll have to figure out the right mapping for the other three instruments once we get passed this initial error.

            To reset your instruments, please take the steps below.
            • First, disconnect from any data providers by navigating to the Control Center > Connections menu, and left-click on “disconnect” that appears to the right when hovering your mouse over any active connection
            • Next, reset your instruments by navigating to the Control Center > Tools > Database Management
            • In the Database Management window, under the “Update instruments” section, ensure that “General properties”, "Futures expiries" and “Symbol mappings” options are checked and then click Update
            • Lastly, restart NinjaTrader for the changes to occur

            If the issue persists after the reset, please go into further detail about exactly how you're selecting the instrument.
            Patrick G.NinjaTrader Customer Service

            Comment


              #7
              The issue persists. Two scenarios where it happens.


              - Go to Control Center
              - Go to Tools
              - Go to Instruments Lists
              - Select a List and Add
              - Type in NAS100
              - Than the pop-up error message with "Invalid Instrument name" displays


              Other scenario


              - Go to a chart window
              - Type in NAS100 in the upper left hand Instrument box
              - Error pop-up message. Invalid Instrument. Please select a different instrument


              Note in both scenarios when I select a different instrument like EURUSD or MSFT it works fine.
              Also the CFDs including NAS100 work fine within IB TWS.

              Comment


                #8
                If you instead use the magnifying glass to select the instrument instead of typing it manually in either scenario, does the issue persist? Here is a video example of the steps I'd like you to take:

                https://www.screencast.com/t/VNJpsTFP2
                Patrick G.NinjaTrader Customer Service

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by yikccv, Today, 08:49 PM
                0 responses
                2 views
                0 likes
                Last Post yikccv
                by yikccv
                 
                Started by supernova0219, Today, 07:48 PM
                0 responses
                5 views
                0 likes
                Last Post supernova0219  
                Started by qwfxny, Today, 07:20 PM
                0 responses
                3 views
                0 likes
                Last Post qwfxny
                by qwfxny
                 
                Started by bouncetherubble, Today, 04:48 PM
                0 responses
                3 views
                0 likes
                Last Post bouncetherubble  
                Started by johnnybegoode, Today, 11:35 AM
                1 response
                11 views
                0 likes
                Last Post NinjaTrader_ChrisL  
                Working...
                X