• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Price marker delay on charts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lucero
    started a topic Price marker delay on charts

    Price marker delay on charts

    I always get a delay about 0.3-0.4 sec of the price marker on charts compared to the one on the DOM. Also, with fast movements of the DOM marker, the chart marker often skips the price changes. It can't be an issue with my computer, because the total CPU load is about 20%, while Ninjatrader's CPU load is about 3%. I am on an integrated graphics card, though, so could it be the culprit? Does anyone with a dedicated graphics card experience the same issue? If so, the usefulness of Ninjatrader for high-frequency trading becomes questionable.

  • NinjaTrader_ChelseaB
    replied
    Hello Community,

    Please note the TickRefresh indicator uses code that is directly stated not to use in the NinjaTrader Help Guide.

    Line 73: ChartControl.InvalidateVisual();

    From the help guide:
    "It is NOT recommended to invalidate the chart control directly as this could cause issues with threading which result in dead locks."
    https://ninjatrader.com/support/help...rcerefresh.htm

    This indicator may cause undesired performance and is not recommend by the NinjaTrader Support Staff.

    Leave a comment:


  • hurleydood
    replied
    For you guys who are seeing a price marker delay check out my TickRefresh indicator.
    It will force a refresh on each tick or each price change. It also has an adjustable refresh interval in case your computer cannot keep up.
    https://ninjatraderecosystem.com/use...d/tickrefresh/

    Check out this video to see the difference https://youtu.be/0sb8OANbcyo
    Last edited by hurleydood; 03-29-2019, 11:09 AM.

    Leave a comment:


  • NinjaTrader_ChelseaB
    replied
    Hello otislauwaert,

    I've forwarded your vote on SFT-1536 as well.

    Thank you for your feedback on this.

    Leave a comment:


  • otislauwaert
    replied
    Hello,

    Please add my vote to the SFT-1536.
    I am using high-frequency strategies on a chart and the delay between chart and DOM is causing "slippage".

    Thank you.

    EDIT:

    I also want to say that for me it's the opposite that is happening. I recorded my chart and the T&S and then replayed it in slow motion, I could see that the chart updated before the T&S did.

    Another question, what is the delay in Ninjatrader 7? If the difference is lower I should probably go back to 7.
    Last edited by otislauwaert; 11-14-2018, 08:34 AM.

    Leave a comment:


  • Lucero
    replied
    Then it looks like a dead end: NT7 could do it, but it's single-threaded; NT8 could do it, but this feature is missing. Too bad.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    NinjaTrader 7 is single-threaded. In other words, it cannot use all of your CPUs cores. I would never expect your total CPU utilization to reach 100% when using NinjaTrader 7. A rough rule-of-thumb is to divide 100 by the amount of cores your CPU has. For example, if your CPU has 8 cores, we would arrive at a value of 12.5 after doing that math. This would mean ~13% utilization for NinjaTrader means it is working at 100% capacity of one of your CPUs cores. This is a scenario you want to avoid.

    Leave a comment:


  • Lucero
    replied
    Ok. For me, an issue it is, though, because it certainly feels not as it should be. As to my pc/nt7 capabilities being overwhelmed, I'll have to check, but my cpu load with nt8 has never been more than 5-10 %, so I don't think it will be a problem.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    I'd like to clarify that this is not an 'issue' or 'bug'. This was a purposeful change by the Development Team. We are tracking interest in re-implementing this as a user-configurable option in the feature request that I've added your vote to.

    A quicker chart update speed will quickly cause your workspace(s) to lag as the processing needed to update charts at that speed will likely overwhelm the capabilities of your PC/NinjaTrader 7. If you experience performance issues, increase the update speed until the performance issues disappear.

    Leave a comment:


  • Lucero
    replied
    I've just compared NT7 with the update interval of 0.1 to NT8, and it's so much faster! Almost synchronous. So I am downgrading to NT7 until this issue gets fixed. And I would personally request the minimal chart update interval of at least 0.01 sec instead of 0.1, if not 0.001.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    I've added your vote to SFT-1536, Lucero.

    Leave a comment:


  • Lucero
    replied
    Hi gurko,

    Thanks for your feedback. I may well save some money on a graphics card now! As I vaguely remember, NT7 had this feature, a configurable display update frequency, and it is a shame NT7 doesn't have it. It's like a step back. I have been quite satisfied with NT8 charts, and I have been unable to find another trading program that would satisfy my needs (like 1 tick horizontal grid lines with very small spacing), but as my trading style has been moving towards faster and shorter term trades, this low chart update frequency is becoming more and more an obstacle. I will sure join the vote, and hope it will be fixed, otherwise I might have to look elsewhere again.

    Leave a comment:


  • gurko
    replied
    Hi Lucero,

    I have a dedicated graphics card (GeForce 1060 3GB). I am seeing a similar effect (a visual difference between the faster 25ms DOM updates and the slower 250ms chart updates). Recording a screen video and examining that frame-by-frame seems to confirm that chart updates take a little over 0.25 or 0.3sec, maybe max 0.4sec sometimes, while DOM updates happen more frequently.

    This creates a "visual hiccup" in my brain, as DOM and chart are not "in sync". I'd need a faster update frequency. Other users have requested a slower update frequency (that's users having hundreds of daily charts open, where a 250ms update is just wasted). As a consequence, a configurable display update frequency (tracking id SFT-1536) has been requested by a number of users. You might want to add your vote.

    Side note: I have actually adapted my manual trading style to the 250ms chart update period, after leaving X_TRADER (which did things "visually instant") for NT8 and learning about the slow chart updates. Now, instead of watching the chart for the activities of market participants, my eye is glued to the DOM and only glances at the chart from time to time. Well, humans are adaptable... but adaptable software would be nice, too.

    Please let us know if you discover a solution that works for you.

    Kind regards,
    Gurk.

    Leave a comment:


  • Lucero
    replied
    Latest, 8.0.14.2.
    I started Ninjatrader in safe mode with just 1 chart and 1 DOM, but I didn't notice much difference from when I have 3 charts in 1 workspace with 10 workspaces open. Sometimes the delay is not so noticeable, but the skipping really is, which makes you feel the chart is very slow and is not reflecting the actual price movements. I am really curious if this behavior can be fixed with a dedicated graphics card, and am looking forward to receiving feedback from dedicated graphics card users.
    Last edited by Lucero; 07-16-2018, 09:16 AM.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    What version of NinjaTrader 8 are you using? Please provide the entire version number. This can be found under Help -> About (Example: 8.0.X.0)

    The SuperDOM updates more quickly than the chart window (25ms vs. 250ms), so it sounds like you're experiencing this expected update difference with perhaps a slight lag due to some other influence.

    The integrated graphics card could certainly cause this symptom. NinjaTrader 8 uses your graphics adapter heavily for chart rendering and a more powerful dedicated graphics card can improve performance.

    To make sure it's not chart/workspace complexity that is causing the issue, I'd recommend testing for the behavior in safe mode:
    • Safe Mode will prevent NinjaTrader from:
    • Loading workspaces.
    • Connecting on start-up.
    • Loading custom assemblies.
    • Getting instrument updates from the server.
    • To enable safe mode, please use the following steps:
    • Exit NinjaTrader.
    • Hold the CONTROL key and double click the NinjaTrader icon.
    • Keep the CONTROL key held down until you see the Control Center.
    • You can verify you are in safe mode by going to Help -> About.

    Once in safe mode, connect to a data feed then open a new chart and SuperDOM (with no templates or indicators) and test for the behavior. Is the delay the same? Less? Not noticeable?

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by Mike3238, Today, 07:09 PM
0 responses
4 views
0 likes
Last Post Mike3238  
Started by sambo81, Today, 06:57 PM
0 responses
7 views
0 likes
Last Post sambo81
by sambo81
 
Started by erichuff, Today, 04:53 AM
1 response
27 views
0 likes
Last Post NinjaTrader_ChrisL  
Started by stevenev1, Today, 01:43 PM
0 responses
8 views
0 likes
Last Post stevenev1  
Started by shinuvu, Today, 11:05 AM
3 responses
21 views
0 likes
Last Post NinjaTrader_ChrisL  
Working...
X