Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT8-TDA orders submitted never get an updated status

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bertochi
    replied
    Dear Patrick,

    As said this TDA-API issue/bug happens in the first part of the day. No order gets past the submitted status.

    Yesterday, it started working with no issues from 13hs Eastern time. Today it started working fine at 11hs Eastern time.

    This is something very specific and I hope this information help you get to the root cause of the problem.

    Thanks again

    Leave a comment:


  • bertochi
    replied
    Dear Patrick,

    Today, exactly the same thing is happening, and there is a pattern, which is this happens in the first part/hours of the day. At some point, yesterday at 13hs Eastern it gets fixed and all orders are updated as they should. In the meantime, all orders can not get past the "submitted" status.

    Thank you for your help

    Leave a comment:


  • loremont
    replied
    You need no special code to reproduce this. It happens even when one sends orders with SuperDOM. I use three SuperDOM (one for each of three accounts I operate) almost simultaneously (just clicking on each of the three windows one after the other. The orders are sent and executed fairly fast or when conditions are met (if using LIMIT) but often the SuperDOM does not recognize the executions or recognize it partly (not the whole number of shares that were executed). Sometimes two of the three SuperDOMs are updated correctly and one of them (randomly) is not.

    Leave a comment:


  • loremont
    replied
    Originally posted by bertochi View Post
    Sorry Patrick, I am not experiencing an unstable connection. Thinkorswim is rock solid and I have no other issues.
    I hope another user comes up and shows you the same issue.
    Thank you for your help.
    I have the same problem that bertochi reported. I also find myself having to close NT often (not all the time). I have very stable and fast Internet service (I pay extra for it). I run Ameritrade's ThinkorSwim simultaneously and this does not ever have a hiccup. Furthermore, this problem with NT never happened before until the version (and it got worse lately) that required to get Credentials Authorized by Ameritrade to connect NT. In my view, it has to do with the changes made to the Ameritrade API made at the time of that requirement. There likely is a stringent timeout embedded with the order and execution message passing between the API and NT. It appears to affect the feedback as the orders are apparently sent without a glitch to the API but the feedback often fails.

    Leave a comment:


  • bertochi
    replied
    Dear Patrick,
    Any code will do the same.
    The question for TDA is this, why this issue before 13hs eastern time, and now it is working with no problems. My suspicion is this might have something to do with their servers or something at their end. I honestly do not think there is a problem with NT itself.
    Thank you

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    Those would be the same people that our Development Team speaks with. I imagine they would tell you to contact us since you're not directly developing an API. What would be useful is a bit of sample code that can reproduce the symptom 100% of the time. I am not necessarily asking you to produce this, but that would help us determine quite quickly whether or not the new API fixes what you're experiencing.

    Leave a comment:


  • bertochi
    replied
    Dear Patrick,

    Should I try contact TDA API (in writing only as they don't take calls) and see what they say, or shall I leave this with you and your team?

    Thanks

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    I'll follow up when I have more information about the new TD Ameritrade API in development to see if there is relevant tweaks or improvements to address what you're experiencing.

    Leave a comment:


  • bertochi
    replied
    Dear Patrick, this error/bug happens most of the time in the early hours until about this time 12:55hs Eastern time. For example, I just sent a few orders and they are getting updated correctly now. In the previous days, it also happened in the first hours of trading.
    Thanks again

    Leave a comment:


  • bertochi
    replied
    Dear Patrick,
    I understood, no worries.
    Once again, I hope one of the many TDA users who wrote on the post about not being able to login to TDA the other.day, confirm or not, this issue.
    I confirm to you my connection is rock solid, TOS works flawlessly, and I have no other issues. My understanding is this issue is an API miscommunication between NT8-TDA.
    Thank you

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    To clarify, I am not saying that your connection in general is unstable. I am saying that the connection between NinjaTrader and TD Ameritrade through the API may be unstable.

    Leave a comment:


  • bertochi
    replied
    Sorry Patrick, I am not experiencing an unstable connection. Thinkorswim is rock solid and I have no other issues.
    I hope another user comes up and shows you the same issue.
    Thank you for your help.

    Leave a comment:


  • NinjaTrader_PatrickG
    replied
    This sounds like a networking issue in which NinjaTrader is unable to maintain a consistent connection to TD Ameritrade. A new TD Ameritrade adapter is actually in development, however, I do not believe it would resolve a symptom where the root cause is simply intermittent network issues.

    There also may be an element of overwhelming the routing technology. I notice when you started the dozens of automated strategies you're running that 17 out of 26 orders are submitted almost instantly (within one second).

    In an attempt to mitigate this symptom, please try this network troubleshooting:
    • Restart NinjaTrader (you've already done this)
    • Restart your modem and (if applicable) router
    • Restart your PC
    • Clear your DNS
    • If you are not already and the option is available to you, connect to the internet using an ethernet cable. Wireless connections are significantly more unreliable.
    • Ensure exceptions have been added into any firewall/antivirus/backup programs for the Documents > "NinjaTrader 8" folder.
    • Ensure that your computer is not turning off your Network Adapter to conserve power:
      • Right-click on your Start button
      • Select 'Device Manager'
      • Expand 'Network Adapters'
      • Right-click on your Network Adapter and select Properties > Power Management
      • Uncheck 'Allow the computer to turn off this device to save power' option
      • Click 'OK' to save the changes
      • Do this for all Network Adapters
    • If the above steps do not help, contact your ISP and let them know you are experiencing a highly unstable connection. An issue of connectivity may exist on their end.

    Leave a comment:


  • bertochi
    replied
    Disconnect and connect would not fix the broker position, but I am not 100% sure, I seem to recall I did this and it was worse because my strategy is acting on a wrong broker position. Only cure is a restart, so both positions and orders can start fresh.

    Leave a comment:


  • bertochi
    replied
    Yes Patrick, 50 times I had to restart NT today since the orders would not get an updated status, and you can see that on both the trace/log files.
    I appreciate your help.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by op1031, Today, 05:16 PM
0 responses
1 view
0 likes
Last Post op1031
by op1031
 
Started by fscabrera03, Today, 01:18 PM
1 response
11 views
0 likes
Last Post fscabrera03  
Started by BottomShark77, Today, 12:20 PM
1 response
10 views
0 likes
Last Post NinjaTrader_ShawnB  
Started by bowling, Today, 06:16 AM
3 responses
29 views
0 likes
Last Post NinjaTrader_ShawnB  
Started by systemtrader4, Today, 01:54 AM
2 responses
88 views
0 likes
Last Post systemtrader4  
Working...
X