• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

NT8 Crashes Every Time When Trying to Add Indicator

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    NT8 Crashes Every Time When Trying to Add Indicator

    Hello,

    I was working with a NinjaScript file that I created from the Strategy Builder and then I changed some of the code and saved and compiled it.

    After that when I tried to add it to the chart, NT8 froze and I had to crash it. Every time I relaunched NT8 and tried to access the indicators on my chart, the program would freeze, forcing me to have to crash it.

    I also noticed that a couple of the indicators that I created were no longer in the indicators list, from the NinjaScript window.

    I think I might have saved the Strategy as an Indicator or something.

    I tried launching NT8, closing the problem workspace and then created a new chart and tried to access the indicators, but again, NT8 froze on me, forcing me to crash it.

    I have three cs files in the bin > Custom > Indicators folder (soRSIalerts.cs, soRSI1HLine1Alert1.cs, soParSAR1RSI1Alert.cs)

    I did create a backup earlier today. Should I restore the backup?
    Last edited by i2w8am9ii2; 08-28-2018, 09:09 PM.

    #2
    Hello,

    I removed the most recent cs file that I created from within the Strategy Builder; I moved it to my desktop and now NT8 works fine. I can access my indicators.

    But one of the custom indicators that I created is not accessible when I try to add it to a chart, for some reason.

    But the cs file for that custom indicator is there in the directory: NinjaTrader 8 > bin > Custom > Indicators

    Comment


      #3
      Hello i2w8am9ii2,

      Thanks for your posts.

      On the indicator, please check that the file name is the same as the public class name and is the same as in the Name = field in State.SetDefaults.

      If they are all the same, please recompile the indicator and if no errors see if you can then add to a chart.
      Paul H.NinjaTrader Customer Service

      Comment


        #4
        Hi Paul,

        Thanks for the reply.

        You were spot on. I did rename the class when I was tired and got confused regarding what I was doing.

        I forgot that I was working on a strategy and tried to rename it based on the naming convention that I was using for indicators.

        Newbie mistake.

        I ended up deleting that strategy and creating it from scratch.

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by ballboy11, Today, 05:22 PM
        0 responses
        3 views
        0 likes
        Last Post ballboy11  
        Started by ballboy11, Today, 04:33 PM
        2 responses
        4 views
        0 likes
        Last Post ballboy11  
        Started by dedouglas, Today, 03:16 PM
        1 response
        7 views
        0 likes
        Last Post NinjaTrader_ChelseaB  
        Started by TradeMyth, Today, 02:45 PM
        3 responses
        26 views
        0 likes
        Last Post NinjaTrader_ChelseaB  
        Started by Ticnician, Today, 01:46 PM
        1 response
        9 views
        0 likes
        Last Post NinjaTrader_Jim  
        Working...
        X