• If this is your first visit, you will have to register before you can post. To view messages, please scroll below and select the forum that you would like to visits. Questions? Be sure to check out the Forum FAQ.

Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Chart data not refreshing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Chart data not refreshing

    Since about 2+ weeks ago my charts haven't been automatically ticking/refreshing as they should, this being on all intervals. The level 2s work fine, however. The same problem persists with empty charts (meaning no indicators). Strangely enough, I caught $GERN working as it should just now (tighter spread, larger volume perhaps?) whereas, say, $NBEV doesn't. It'll simply not refresh the chart unless I right click -> reload all historical data, at which point I will get all the bars up until to the point where I refreshed but no more (doesn't keep ticking -- it just gets stuck). They're both NASDAQ stocks.

    Version: 8.0.15.1 64-bit
    Connected to: Kinetick

    #2
    Do you receive an error on screen? Are there errors on the Log tab of the Control Center? If so, what do these errors report?

    When you say 'Kinetick', are you referring to 'Kinetick end-of-day (free)'? Or are you referring to a paid Kinetick subscription? If the latter, have you spoken with Kinetick to ensure you have the appropriate data subscriptions to receive real-time Level I data for the instruments you're referring to? If not, please do so now:

    https://kinetick.com/Help#!Help_Request
    Patrick G.NinjaTrader Customer Service

    Comment


      #3
      Hi Patrick, thanks for your reply.

      I don't receive any errors on the screen, as for the log tab it's filled with messages like "RequestOfL2Data TICKER Hash : 23323232". Whether they're errors or not, I don't know. Category: ninjascript, there are tons of them. I'll upload the logs if you want, there's nothing in there that'd I'd be able to classify as an error anyway.

      As for my data, yes I have it and like I said, I can see level 2 data in NinjaTrader so I have no reason suspect to suspect that's the problem (paid suscription with Kinetick including NASDAQ level 1 & 2s as well as market depth currently). Might be worth mentioning that I use Jigsaw Daytradr too, although I'm not sure how that'd affect chart data.

      Comment


        #4
        So we can further diagnose your system, please start NinjaTrader in Safe Mode.

        Safe Mode will prevent NinjaTrader from:
        • Loading workspaces.
        • Connecting on start-up.
        • Loading custom assemblies.
        • Getting instrument updates from the server.

        To enable safe mode, please use the following steps:
        • Exit NinjaTrader.
        • Hold the CONTROL key and double click the NinjaTrader icon.
        • Keep the CONTROL key held down until you see the Control Center.
        • You can verify you are in safe mode by going to Help -> About.

        Once NinjaTrader has started in safe mode, connect to Kinetick then create a chart. Does the issue persist? If so, please contact us at PlatformSupport[AT]NinjaTrader[DOT]com so we may investigate further.
        Patrick G.NinjaTrader Customer Service

        Comment


          #5
          Hi Patrick,

          I can confirm that the tickers do indeed tick as intended with NinjaTrader 8 running in Safe Mode. For this test I tried $TLRY and switched back and forth a few times. Strangely enough I also did have the charts ticking/refreshing/updating as they should yesterday at some point, though I can't pin it down to having done anything differently.

          I should note that I tend to get an error on start-up, namely "Main (my profile name): Unable to login, please check your user name/password. (Logon failed)." though seeing as I am connected to Kinetick and am getting live level 2 data just fine, I'm not sure this has any bearing on my problem. (Edit: This seemed to just be an old connection, I removed it and am no longer getting the error but the problem persists.)
          Last edited by Ouais; 10-02-2018, 09:09 AM.

          Comment


            #6
            I'd like for you to write in with your log and trace files so we can combat these symptoms you're reporting.
            • You can do this by going to the Control Center-> Help-> Email Support
            • Ensuring 'Log and Trace Files' is checked will include these files. This is checked by default.
            • Please reference the following ticket number in the body of the email: 1979957 ATTN PatrickG
            Patrick G.NinjaTrader Customer Service

            Comment


              #7
              Alright, I went ahead and did it.

              So another update, after having created a new workspace (and deleting some old ones) it seems to be working as it should again. I'm not sure why, quite odd, but at least for now it seems to have been resolved. I'll let you know if I run into it again. Thank you for your help and patience.

              Comment


                #8
                So I updated to NinjaTrader 8.0.16.1 and I'm still having the same issue (it came back). I went ahead and sent you the log files just now.

                Comment

                Latest Posts

                Collapse

                Topics Statistics Last Post
                Started by tecmisc1, Today, 09:57 AM
                0 responses
                2 views
                0 likes
                Last Post tecmisc1  
                Started by mbesha, Today, 09:26 AM
                0 responses
                1 view
                0 likes
                Last Post mbesha
                by mbesha
                 
                Started by Brillo, Today, 08:58 AM
                0 responses
                6 views
                0 likes
                Last Post Brillo
                by Brillo
                 
                Started by avrege, Today, 01:48 AM
                2 responses
                13 views
                0 likes
                Last Post avrege
                by avrege
                 
                Started by markbb10, Today, 07:14 AM
                0 responses
                7 views
                0 likes
                Last Post markbb10  
                Working...
                X