Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Odd behaviour by Indicator/Platform

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Odd behaviour by Indicator/Platform

    Click image for larger version

Name:	Capture laptop.PNG
Views:	35
Size:	109.2 KB
ID:	1124202I I had an indicator that I designed in NT7 - found NT8 script too difficult so I paid for it to be converted.
    Used it for 6 months on my machine absolutely faultless.
    Transfer on to a new machine and my laptop and it no longer plots correctly - see above ( the rectangle should be at the prices shown - as should the text).
    Same version of NT8.

    The guy who wrote it says it works perfectly on his and it still runs like clockwork on my original machine?


    What is going on?





    #2
    Hello Mindset,

    Thanks for your post.

    If you remove the lower panel indicator, does the suspect price panel indicator work as expected?

    If you create a new chart with only the price panel and add that suspect indicator, does the indicator work as expected?

    Paul H.NinjaTrader Customer Service

    Comment


      #3
      yes and yes - I really can't fathom it. Other indicators that I have written had to be recoded as well but this one refuses to budge lol.(consisitently it doesn't like the old logic of min max, etc.
      when telling it where to plot something). So f I change the above from Low to HIgh - the rectangle doesn't move - and that can't be right.

      I would add on one of the 'non working' machines I get odd data series values as well - it doesn't look healthy like my other machine - a nontechnical term I know.
      I have decided to re install windows and then NT* - see if that will work.

      Comment


        #4
        Hello Mindset,

        Thanks for your post.

        I suspect the issue relates to how the code was written relative to chart coordinates. The code is likely not accounting for when another panel is added to the chart and is using an absolute position. I would suggest going back to your programmer and see if when he adds an indicator panel if he also sees the same thing.
        Paul H.NinjaTrader Customer Service

        Comment


          #5
          Ended up completely rewriting the code myself ( so I suppose a learning exercise).
          Using GetYByValue and GetXbyIndex solved the issue.

          Comment

          Latest Posts

          Collapse

          Topics Statistics Last Post
          Started by pdeering100, 07-14-2019, 09:43 AM
          9 responses
          1,159 views
          0 likes
          Last Post Joshua 1:8  
          Started by LeroyO, Today, 04:09 PM
          0 responses
          5 views
          0 likes
          Last Post LeroyO
          by LeroyO
           
          Started by sidlercom80, Today, 04:57 AM
          2 responses
          31 views
          0 likes
          Last Post NinjaTrader_Jim  
          Started by Tartagliagroup, Today, 02:11 PM
          1 response
          10 views
          0 likes
          Last Post NinjaTrader_Jesse  
          Started by rickyblah12, Today, 01:33 PM
          1 response
          12 views
          0 likes
          Last Post NinjaTrader_BrandonH  
          Working...
          X