Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Order Flow Cumulative Delta shows no data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Order Flow Cumulative Delta shows no data

    The Order Flow Cumulative Delta indicator frequently (~30%?) initializes with no data for me. See attached pic, the bars are all zero. In this case the indicator is added to the chart by my strategy, but I've also seen this when the indicator was manually attached to the chart. Sometimes removing and replacing the indicator gets it working; sometimes I have to entirely restart NinjaTrader. This is with version 8.0.19.0 64-bit.


    #2

    Hello aworldnervelink,

    Thank you for your note.

    I see that you're using an older version of NinjaTrader 8. To update NinjaTrader, please follow the steps below:
    • First, copy your license key from NinjaTrader under Help> License Key then exit NinjaTrader
    • Click on the link: https://ninjatrader.com/PlatformDirect
    • Enter your license key and press Submit
    • Select 'NinjaTrader 8'
    • Select 'Download'
    • Critical: Before running the installer, ensure NinjaTrader is closed.
    Please let me know if this issue persist after updating the Platform.
    Heath R.NinjaTrader Customer Service

    Comment


      #3
      I upgraded to 8.0.23.1 64-bit and immediately saw the issue. No errors appear in the recent logs.

      I suspect this is a problem with loading the tick data as another indicator that relies upon this is also DOA.

      Comment


        #4
        Hello aworldnervelink,

        Thank you for your note.

        Tick data is not available from all providers. Available data in the platform would depend on your data provider and specific enablements.

        For more information on what data is available from what provider please visit the link below:
        Please feel free to write in if you need additional assistance.
        Heath R.NinjaTrader Customer Service

        Comment


          #5
          Was the original post not clear? 70% of the time the indicator works as expected... 30% of the time it comes up with no data. I use solely one provider.

          Comment


            #6
            Hello aworldnervelink,

            Thank you for your note.

            To be able to assist further please let me know who you are connected to?

            Additionally, so we can further diagnose your system, please start NinjaTrader in Safe Mode.

            Safe Mode will prevent NinjaTrader from:
            • Loading workspaces.
            • Connecting on start-up.
            • Loading custom assemblies.
            • Getting instrument updates from the server.

            To enable safe mode, please use the following steps:
            • Exit NinjaTrader.
            • Hold the CONTROL key and double click the NinjaTrader icon.
            • Keep the CONTROL key held down until you see the Control Center.
            • You can verify you are in safe mode by going to Help -> About.
            Please let me know if you're able to load a chart with the order flow indicator manually without issue in safe mode.

            Thank you I'll await your reply.
            Heath R.NinjaTrader Customer Service

            Comment


              #7
              I use NinjaTrader Continuum as my data connection.

              I started NT in safe mode and applied the Order Flow Cumulative Delta to several charts. I was not able to replicate the issue. Since my strategy is not available in safe mode it is not a great test but it's a start. For reference, my strategy creates and adds the indicator to the chart automatically:

              Code:
              else if (State == State.Configure)
              
              {
              AddDataSeries(Data.BarsPeriodType.Tick, 1);
              } else if (State == State.DataLoaded) {
              orderFlow = OrderFlowCumulativeDelta(CumulativeDeltaType.BidAsk, CumulativeDeltaPeriod.Bar, 0); AddChartIndicator(orderFlow);
              }
              As mentioned this generally works but sometimes there is no data in the indicator.

              Thanks for the help!

              Comment


                #8
                Hello aworldnervelink,

                Thank you for your post.

                Does this occur only on certain instruments, or on all instruments?

                Can you replicate this using a strategy that is empty except for the above code?

                Thanks in advance; I look forward to assisting you further.
                Kate W.NinjaTrader Customer Service

                Comment


                  #9
                  I was just able to replicate the problem with a strategy containing only the code shown above. This was on a chart of the MES 12-20 with 500 tick bars. It's been a while since I have looked at other markets but I seem to recall the problem showing up on various micro currency charts as well.

                  I also noticed that the problem seems to be "sticky" to the chart... if it doesn't work the first time on the particular chart, it will continue to fail.

                  Click image for larger version

Name:	2020-12-07 08_58_21-.png
Views:	47
Size:	36.2 KB
ID:	1131069

                  Comment


                    #10
                    I removed all Strategies, selected "Reload All Historical Data", applied my Strategy, and it came up OK. Can't guarantee that this was the cure as the problem is intermittent but in this case it worked. Strategy code is attached.

                    Attached Files

                    Comment


                      #11
                      Hello aworldnervelink,

                      Thank you for your replies.

                      I've tested these on a number of instruments and haven't been able to replicate this on my end. I'd make sure you're on the current version of the software. You can check this under Help > About. The current version is 8.0.23.1. If you're on a different version, please update using the steps below and test:
                      • First, copy your license key from NinjaTrader under Help> License Key then exit NinjaTrader
                      • Click on the link: https://ninjatrader.com/PlatformDirect
                      • Enter your license key and press Submit
                      • Select 'NinjaTrader 8'
                      • Select 'Download'
                      • Critical: Before running the installer, ensure NinjaTrader is closed.
                      Thanks in advance; I look forward to assisting you further.
                      Kate W.NinjaTrader Customer Service

                      Comment


                        #12
                        See above in the thread, I am running 8.0.23.1. I have been seeing this problem for several months on at least two, possibly 3 different versions.

                        Comment


                          #13
                          Hello aworldnervelink,

                          Thank you for your reply.

                          I've been completely unable to replicate this on the current version using NinjaTrader Continuum data. I'd like to take a look at your log and trace files to see if there's any errors occurring when NinjaTrader tries to retrieve tick data. However, since these may contain personally identifiable information, I'd want you to send those in directly. You can do this by going to Help > Email Support. Log and Trace files should be automatically checked. Please put 2859461 ATTN Kate W. in the subject line.

                          Thanks in advance; I look forward to assisting you further.
                          Kate W.NinjaTrader Customer Service

                          Comment


                            #14
                            Hello aworldnervelink,

                            Thank you for sending in your log and trace files.

                            In looking these over, the only issue I'm seeing regarding data is the following:

                            2020-12-07 08:53:41:599|3|4|Failed to resolve instrument for market data: F.US.M6B.U20 could not be resolved.

                            Basically, this is saying you're not getting data for the M6B, which just means you have a window somewhere in the platform that is requesting data for that instrument but failing to get it.

                            Since we're looking at the MES 12-20, that doesn't help us much.

                            I suspect there may be a bar caching issue occurring, however. Do you see the same occur if you clear the cache?

                            To delete the cache, follow the steps below.
                            • Shut down NinjaTrader.
                            • Open the Documents > NinjaTrader 8 > db folder.
                            • Delete the sub-folder named 'cache'.
                            • Restart NinjaTrader and test.

                            Please let us know if we may be of further assistance.
                            Kate W.NinjaTrader Customer Service

                            Comment


                              #15
                              This turned out to be a good morning to test as I started up and several charts showed the data problem. I deleted the cache folder and restarted and was able to get all indicators to load normally. Seems like this could definitely be a factor.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by John Bogui, Today, 03:57 AM
                              2 responses
                              11 views
                              0 likes
                              Last Post John Bogui  
                              Started by Dolfan, 12-30-2020, 12:04 PM
                              9 responses
                              52 views
                              0 likes
                              Last Post timko
                              by timko
                               
                              Started by condorhero, Yesterday, 09:28 PM
                              0 responses
                              13 views
                              0 likes
                              Last Post condorhero  
                              Started by MaraAnkh, Yesterday, 08:44 PM
                              0 responses
                              15 views
                              0 likes
                              Last Post MaraAnkh  
                              Started by wooofad, Yesterday, 05:38 PM
                              0 responses
                              10 views
                              0 likes
                              Last Post wooofad
                              by wooofad
                               
                              Working...
                              X