Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Third party addon 'invalid license' error message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Third party addon 'invalid license' error message

    Hi all,
    I purchased an indicator, then sent the vendor details of my NT8 Machine ID. They sent me the zip file and advised the addon was licenced (to my Machine ID). I installed it successfully .

    I can get as far as getting the indicator on a chart (just the name of it, with no functionality), however an error message 'vendor notification' pops up, advising I do not have a valid licence for the indicator.

    I contacted the vendor, and they re-licenced the addon to my Machine ID, and I un-installed then re-installed the indicator. We've been through this a few times , but the same problem keeps coming up .

    Can anyone troubleshoot this? I'd be most grateful for any solution, as I have paid for this addon but can't get past this invalid licence error message.

    Thankyou.
    Last edited by southpacific001; 02-26-2021, 10:37 PM.

    #2
    Machine ID is supposed to remain the same, but there are times when the machine ID can change.

    Could you check to make sure your machine ID is still the same? Was the vendor re-licensing a different machine ID?
    The next time you open NinjaTrader, bring up the machine ID (go to Help --> About). Is the machine ID the same as what you sent to the vendor last?

    Here is a previous post about Machine IDs changing (https://ninjatrader.com/support/foru...-same-hardware)

    If I may, another option if your machine ID is constantly changing is to trade over a server instead of your home computer. A dedicated server for trading will always outperform a similarly spec'd home computer. Our servers are always on and configured to prevent machine IDs from changing.

    Would highly recommend checking out https://www.ninjamobiletrader.com/

    NinjaTrader ecosystem: https://ninjatraderecosystem.com/sea...biletrader-vps
    Last edited by Vendor_NT_Mobile; 02-27-2021, 09:25 AM.
    <span class="vendorName">Vendor_NT_Mobile</span>
    NinjaTrader Ecosystem Vendor - <a href="https://www.ninjamobiletrader.com/" class="external">Ninja Mobile Trader VPS</a>

    Comment


      #3
      Hello southpacific001,

      Thank you for your post.

      The latest version of NinjaTrader 8 is 8.0.23.2. If you are not using the latest version. Please also update NinjaTrader with the steps below. You can check your NinjaTrader version by going Help > About.

      NOTE: This will NOT remove any of your indicators, workspaces, charts, connections, or other settings provided you DO NOT delete the NinjaTrader 8 Folder in the My Documents directory of Windows.
      • First, copy your license key from NinjaTrader under Help > License Key
      • Go to Help > Download.
      • Enter your license key and press Submit
      • Select 'NinjaTrader 8'
      • Select 'Download'
      • Exit NinjaTrader
      • Critical: Before running the installer, ensure NinjaTrader is closed.
      Please do not hesitate to contact us for any other NinjaTrader inquiries you may have.
      Shawn B.NinjaTrader Customer Service

      Comment


        #4
        After I activate a Third Party LabVIEW Add-on in LabVIEW 2018 64 bits, teer target the add-on status in Third Party Add-on ... In order to fix it

        Comment


          #5
          Thanks for your responses. Throughout the process, dealing with the vendor back and forth , both they and I have been checking the Machine ID to make sure there is no discrepancy. I've just checked it now, and it is still the same Machine ID I sent to the vendor (from the Help/About tab).

          Also , the version is 8.0.32.2 64-bit.

          I've just tried again and still have the same problem with the Vendor Notification popping up, saying I do not have a valid licence for the indicator. The indicator name is on my chart, with the word 'calculating ' showing, however still no functionality for the indicator .

          I should say the indicator - a 'red light / green light ' dashboard system - has been around for years , and the vendor is well known and reputable.
          Last edited by southpacific001; 02-27-2021, 05:31 PM.

          Comment


            #6
            Hello southpacific001,

            Thank you for post.

            You could completely remove and reinstall NinjaTrader to resolve. NT8 can be completely removed and reinstalled for our tests without losing your saved information. Please follow the steps listed below to completely uninstall and reinstall NinjaTrader. Your Machine ID may change.
            • Close all running applications.
            • Navigate to your Documents folder > Right click on the 'NinjaTrader 8' folder > Rename > rename the folder to 'NinjaTrader 8 OLD'. DO NOT delete this folder.
            • Once these steps are completed, download and install NT8 from the link below.
            You can download the platform here

            Critical: Before running the installer, ensure NinjaTrader is closed.

            When you start NinjaTrader none of your saved files from the previous installation will be loaded. Then, please try to re-import your 3rd party scripts.


            Please let us know if we may be of further assistance.
            Shawn B.NinjaTrader Customer Service

            Comment


              #7
              Thankyou for that. I've uninstalled NT8 completely , then re-installed it. I have configured a connection successfully (via NT FXCM option) .

              Accessing the Help/About tab to check Machine ID, shows I still have the same Machine ID I supplied to the vendor originally.

              I reinstalled the indicator, however the same problem occurs when adding it to a chart, ie, the same Vendor Notification error message comes up, stating I do not have a valid licence .

              Comment


                #8
                I appreciate suggestions and troubleshooting thus far, however despite our efforts we haven't found a solution to the problem.

                Kindly, can this be escalated in some way , to avail specialist expertise (?). This is a pretty straight forward issue, which should not difficult to resolve. Thankyou, and I appreciate your time

                Comment


                  #9
                  After the vendor enables your machine, how long does the indicator work for before it disables?
                  <span class="vendorName">Vendor_NT_Mobile</span>
                  NinjaTrader Ecosystem Vendor - <a href="https://www.ninjamobiletrader.com/" class="external">Ninja Mobile Trader VPS</a>

                  Comment


                    #10
                    Hi there, it doesn't actually work in the sense of functioning as it should. The name of the indicator appears in the top left corner of the chart, with the word 'calculating...' after it in brackets. What should be showing is a dashboard with several tabs .

                    Comment


                      #11
                      I sympathize with you and know it can be frustrating when a paid indicator is not working as advertised.

                      Unfortunately I don't know if there is much NT support can do, and you've already reinstalled the latest version of NT8.

                      Specifically for this 3rd party indicator, it may be best for you to contact that vendor directly for support. It doesn't sound like a NT wide problem with 3rd party indicators in general because there doesn't appear to be other reports of licensing issues.

                      What did the vendor say when you contacted them? In the end, they have the relationship with you for providing support on their indicators, and I would think helping you would be their priority.

                      Originally posted by southpacific001 View Post
                      Hi there, it doesn't actually work in the sense of functioning as it should. The name of the indicator appears in the top left corner of the chart, with the word 'calculating...' after it in brackets. What should be showing is a dashboard with several tabs .
                      <span class="vendorName">Vendor_NT_Mobile</span>
                      NinjaTrader Ecosystem Vendor - <a href="https://www.ninjamobiletrader.com/" class="external">Ninja Mobile Trader VPS</a>

                      Comment


                        #12
                        Thanks again. I have been dealing with them back and forth, they have re-licensed the indicator to me, etc., to no avail. They would have sold thousands of these , and would presumably be aware of common problems with licencing, and we would have resolved the problem by now. I think as far as they are concerned they have done their part. They refer me back to NT support.

                        I am using a simulated account - would this pose an issue?
                        Last edited by southpacific001; 03-01-2021, 06:10 PM.

                        Comment


                          #13
                          I got to this post searching for "license activation error". I got a "license for indicator not yet activated" error tonight, after hearing same from another trader. First time in a decade. Two other indicators licensed just fine in last couple days, until today on a 3rd one. Southpacific001 - it seems you are not alone. Ask the vendor to confirm that a license was created on the NinjaTrader8 Vendor Licensing module ... if so, then a license appears to have been created from what the vendor sees, but not from what you see.

                          Comment


                            #14
                            Thankyou for the suggestion- I'll ask them.

                            Comment


                              #15
                              Excellent. I hope my meaning helps clarify the issue with NinjaTrader Support too (I emailed separately already). The posts until now suggested the fault may be yours ... or the Vendors. That is not what I am suggesting. For my 2 examples, valid free trial licenses were created consistent with Vendor settings to create 7-day free trials. They just don't work. Nothing a customer or Vendor can do with this bug.

                              It may be related to other users commenting on their machine IDs changing out of the blue. But I checked the machine IDs and they have not changed in my 2 cases.

                              I have also been observing in the evenings (3-4x) that NinjaTrader platform has failed to recognize my lifetime license and limited my access to platform features. But things were fine by morning.

                              In the interim, I rolled back a version which worked for one, still waiting to hear back for the other.

                              Comment

                              Latest Posts

                              Collapse

                              Topics Statistics Last Post
                              Started by neshnix89, Today, 10:27 AM
                              1 response
                              10 views
                              0 likes
                              Last Post NinjaTrader_BrandonH  
                              Started by bosajin, Today, 09:51 AM
                              2 responses
                              8 views
                              0 likes
                              Last Post bltdavid  
                              Started by Newant, Today, 08:13 AM
                              2 responses
                              26 views
                              0 likes
                              Last Post Newant
                              by Newant
                               
                              Started by alejandro888, Yesterday, 10:14 PM
                              1 response
                              13 views
                              0 likes
                              Last Post NinjaTrader_ChrisL  
                              Started by devro, Yesterday, 07:00 PM
                              1 response
                              8 views
                              0 likes
                              Last Post NinjaTrader_BrandonH  
                              Working...
                              X