Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Third party addon 'invalid license' error message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • southpacific001
    replied
    Hi again REI140205. Thanks . Going to Remove NinjaScript Assembly, only the indicator I purchased (the problem child) is there. SMMA doesn't appear there.
    SMMA does not appear in the indicators folder in Ninja Explorer either.

    Accessing '... documents / Ninja Trader 8 / bin / custom / indicators', SMMA isn't there either. However SMMA does appear in the list of indicators I can access from a chart, via right click, indicators.

    Regds

    Leave a comment:


  • REI140205
    replied
    From control panel, go to Tools menu, then Remove NinjaScript Assembly to see if it is listed.

    If you code it or import the raw code (that you can edit), then it will show up in NinjaScript Explorer, but if it is compiled code, you won't see it there, but instead have to remove it as an assembly.

    Leave a comment:


  • southpacific001
    replied
    Hi again community members,

    I have a specific question. I want to remove the SMMA indicator by going into NinjaScript Explorer / Indicators. The problem is, when I do this I do not see SMMA in the list of indicators. I can see SMA but that is a simple moving average, which I want to keep.

    However, from a chart, upon opening indicators and scrolling down the list, the SMMA does appear in the list. I don't want it to be there - kindly, anyone know how to remove it (?).

    Thanks for your time , as always.

    Leave a comment:


  • southpacific001
    replied
    REI140205 thanks for all your input, and for reaching out to me a fellow trader, albeit a novice.

    I will work through your suggestions in a systematic fashion.

    Also, I seem to be using a 'lite' version of NT8, not the full version ( a free trial). I'll upgrade to a full version and see what happens.

    I thank NT Support also . Sorry this is dragging on . I'd appreciate any further suggestions you may have.

    Thanks again all .

    Leave a comment:


  • REI140205
    replied
    Because you were asking:

    In my Config file, LastMachineId matches my machine ID listed in the platform Help/About window and is likely what you sent Vendor. I have no idea what MachineId2 is that you mentioned, and would not worry about it.


    Also in my Config file in the <Vendor Licenses> section, for the examples of a Vendor named XYZ and indicator Products called Indy1 and Indy2, my entries look like:
    <XYZ>
    <Indy1>@#$%#TGGHRTTY&TYHDFGHSYY%^^H==</Indy1>
    <Indy2>@#$%#TGGHRTTY&TYHDFGHSYY%^^H==</Indy2>
    </XYZ>

    I suspect this is the license for each of the two indicators, so if you are missing an entry here, then I think you are missing the license entry at your end that corresponds with what Vendor created at their end.

    Again, I assume they are a listed NinjaTrader 3rd Party Vendor using the NinjaTrader Licensing System. By listed I mean you can find the Vendor name listed in the NinjaTrader Ecosystem directory. If they are not, I have no idea how or what they used to license you so can be of no help.

    Vendor can use your machine ID to filter their license database to confirm the machine ID you provided to them is unique.

    In terms of troubleshooting, I still encourage you to try installing some other 3rd party vendor indicator (use one with a free trial). You need to confirm if this is a one off thing, or will be a recurring problem for you.

    Why do I keep pointing you back to NinjaTrader Support, contrary to everybody else (who keep saying it "should" work, which is of no help because it quite obviously doesn't)? Because you are on NinjaTrader platform, Vendor is presumably using NinjaTrader Licensing System, the config file is created by NinjaTrader code, you already uninstalled and reinstalled the platform, you are on most recent platform version, you have ensured your machine ID is correct and constant, and Vendor correctly entered the machine ID multiple times to create you a license at their end, and this was not a one off. Now are there a couple other things you can troubleshoot, yes, I can listed a couple, but overall you need to ask the big guns for help.


    ---
    For suggestions for alternative indicators, perhaps start by trying the built-in Candlestick Pattern indicator that can check for about 2 dozen things.

    Leave a comment:


  • southpacific001
    replied
    Thanks REI140205. Can you recommend any, eg, something I can create alerts from, which could be wave patterns, candlestick patterns such as bullish j-hook, pinball formation, etc anything you've done well with. I'm new to NT8 ,so I've only installed the one indicator thus far.
    Last edited by southpacific001; 03-04-2021, 11:05 PM.

    Leave a comment:


  • REI140205
    replied
    Confirm:
    - you have successfully installed other indicators coded by NinjaTrader 3rd party Vendors
    - your Vendor is a NinjaTrader 3rd party Vendor AND that they use the NinjaTrader Licensing System
    - your machine ID is unique (presumably in the Vendor's system)

    Then email images of your machine ID, error message, and relevant vendor section of your Config file to Vendor. Have Vendor forward by email to NinjaTrader Vendor support, along with image from NinjaTrader Licensing System showing they created a license for your machine ID.

    Yes, you are chasing your tail!!!

    Failing a swift, helpful and decisive outcome: get a refund, cut bait and move on to greener pastures. Good luck!

    Leave a comment:


  • southpacific001
    replied
    The clear instructions from the vendor were to go to Help/About, obtain the Machine ID , and forward it to Vendor admin for validation , per first scenario you refer to.

    The vendor would have sold thousands of these NT add-ons, I gather since around 2014 . The vendor has assured me they have licenced (and re-licensed ) it to the M ID I originally provided , so I think as far as they are concerned they have done their part.

    I'm wondering if the second M ID I found in the Config document has any relevance . BTW the indicator itself is mentioned in the Config file.

    Sorry this is dragging on. There must be a solution.. Cheers
    Last edited by southpacific001; 03-04-2021, 08:34 PM.

    Leave a comment:


  • -=Edge=-
    replied
    Originally posted by REI140205 View Post
    To clarify, are your suggestions for Customer, Vendor or NinjaTrader Support (assisting one or both)?
    Either customer or vendor.. doubtful this NinjaTrader issue..
    Everything depends on the vendor's authentication method..

    If this is an NT Eco-System approved vendor..
    It's likely they're using a tool provided by NT..
    But this tool can be utilized in different ways..

    First and easiest.. All the Vendor Needs is your Machine ID
    Your machine id can be found going to Control Center / Help / About
    (This can have issues as machine id's are not necessarily unique!)

    Second way.. bit more Cumbersome but eliminates above issue..
    Customer must utilize NT's build in 3rd Party Licensing Tool
    (located Control Center / Help / 3rd Party Licensing)
    Customers "Must" run this built in tool and provide generated mid to vendor.


    If vendor uses 1st way.. and customer runs 3rd Party Tool.. Things won't work!
    I would also "NOT Expect" to find VendorLicensing for Vendor/Product in Config.xml!
    (as long as the build in 3rd Party Licensing Tool is Not run)

    If 2nd method used.. and customer has not run 3rd Party tool .. Things won't work!
    and I "Would Expect" to find VendorLicensing Vendor/Product section in Config.xml!
    Also if the unique id used contains a space and/or special character.. "Might" not work!

    Just taking stab in dark and pointing out couple things I've run into over the years..

    Be Safe!


    Leave a comment:


  • southpacific001
    replied
    Thanks for your suggestion.

    I went into the Config file - I don't see a section 'Vendor Licences' at all, running my eye through the document. At the top there is a section pertaining to the NT licence.

    I do note I see two Machine IDs mentioned - the one I supplied to the vendor, and a second one which is different (I've deleted the actual Machine IDs and used asterix, as this is a public forum).

    <LastMachineId> *** </LastMachineId>
    <MachineId2> *** </MachineId2>


    Thanks for your time and hoping for more troubleshooting so we can resolve this. I didn't get time to attend to your sections 1) & 2) but I will check those later. Cheers.
    Last edited by southpacific001; 03-04-2021, 03:42 PM.

    Leave a comment:


  • REI140205
    replied
    Hi Edge (long time since we spoke last in Cash Room ... hope all is well with you).

    To clarify, are your suggestions for Customer, Vendor or NinjaTrader Support (assisting one or both)?

    In my 3 instances with same error, this was after multiple past successful installs with other indicators, using automatic free trial license generation, and then some overnight cure without us having done anything. I agree with you, I expect southpacific001 will get this same error each time he first tries to load the indicator on a chart because somewhere his indicator license that was created is being rejected, which should be a matter separate from platform licensing.

    Leave a comment:


  • -=Edge=-
    replied
    Originally posted by southpacific001 View Post
    Is anyone able to clarify whether I can use third party add-ons / indicators with a free trial version of NT8, ie, without getting vendor notifications stating I have an invalid license . This is the problem I'm having. Thankyou.
    Using a Sim or Purchased license key should not matter to 3rd party licensing..
    Here are couple things that come to mind I've had to deal with in the past..


    (w/NT8 closed) open ../documents/ninjatrader 8/Config.xml with notepad
    (Make backup of xml before making any changes!!!) (in "VendorLicenses")

    <NinjaTrader>
    <VendorLicenses>
    <VendorName>
    <VendorProduct>
    encryptedkey
    </VendorProduct>
    </VendorName>
    </VendorLicenses>


    1.) If vendor "Uses" NT's build in 3rd Party Licensing Tool
    (ChartControl / Help / 3rd Party Licensing)
    - Make sure there is an "Valid Entry" for vendor/product in xml
    (if not - Repeat built in 3rd Party Licensing steps)
    - ALSO - Unique ID is "Case Sensitive" no spaces or special char!


    2.) If vendor "Does Not Use" built in 3rd Party Licensing Tool
    - Make sure there is "NO Entry" for vendor/product
    ("delete" from xml if exists and restart NT8!)



    Leave a comment:


  • southpacific001
    replied
    Is anyone able to clarify whether I can use third party add-ons / indicators with a free trial version of NT8, ie, without getting vendor notifications stating I have an invalid licence . This is the problem I'm having. Thankyou.

    Leave a comment:


  • REI140205
    replied
    Yes, well at least you know you were not alone. Both you and Vendor should ask NinjaTrader for further assistance. In the meantime, have you tried installing indicators from other Vendors, perhaps ones with free trials or low cost to you to see if you can do so successfully or get same error? Might as well request a refund too.

    Leave a comment:


  • southpacific001
    replied
    Thanks - yes we've checked the Machine ID matches, etc. I gather the licensing is done manually at their end .

    I have paid for the indicator ( free trial not applicable).

    I am still in a free trial with NT8 though - maybe that has a bearing on this , ie the fact I keep getting Vendor Notifications about not having a valid licence for this indicator .
    Last edited by southpacific001; 03-03-2021, 03:03 PM.

    Leave a comment:

Latest Posts

Collapse

Topics Statistics Last Post
Started by ct, Today, 01:53 AM
0 responses
8 views
0 likes
Last Post ct
by ct
 
Started by SmartArtsStudio, Yesterday, 11:24 PM
0 responses
4 views
0 likes
Last Post SmartArtsStudio  
Started by kenz987, Yesterday, 10:06 PM
0 responses
8 views
0 likes
Last Post kenz987
by kenz987
 
Started by AaronKoRn, Yesterday, 07:24 PM
0 responses
9 views
0 likes
Last Post AaronKoRn  
Started by Aquatrade, 05-15-2021, 11:46 AM
1 response
18 views
0 likes
Last Post NinjaTrader_ChelseaB  
Working...
X