Announcement

Collapse
No announcement yet.

Partner 728x90

Collapse

Missing price info and fake Ghost Bars NT8 Continuum datafeed(w.FREE Indicator)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Missing price info and fake Ghost Bars NT8 Continuum datafeed(w.FREE Indicator)

    Been struggling with this issue ever since I switched to the NT platform about a year ago.
    I have been in contact with NT-support on multiple occasions in regards to the problem, but still missing answers/solutions.

    The main problem consists in missing bars of data as well as huge misprinted ghost bars (see attachments). The issue in regards to the ghost bars does only occure when using Tick replay with timebased BarsSeries
    The placement/point of where the misprinted bars shows/plots usally coinsides with times where i previously opened or closed the platorm at a certain point in time. Also, opening the platform during the weekend (or when the market is closed) seems to trigger the problem somewhat.
    For some reason the price series is restored trough manually adding one extra day to Bars to load in the DataSeries menu... It is like the memory is being compromised/"blocked" by earlier shutdown/startups, and that it needs atleast one "fresh" day not previously loaded to the memory in order to restore. Anyhow the platform clearly fails to resolve this with out intervention.

    Also, I struggle with missing price information, like the bigBar-problem this issue is usally reserved Tick replay with timebased BarsSeries. This issue is far less common then the first one, or at least i think, as it has been more difficult to detect (see indicator).

    Our last attempt to fix the issues described above was a teamviewer session. After some back and forth (deleting and re-installing the platform, etc) NT-support were able to detect/recreate a issue in regards to some missing bars at their end as well.
    Explanation: Incomplete price information delivered by the dataprovider.

    As for the "big bars" (which was not present after the re-installation) we agreed that I were to continue to use this "fresh" database, and to be aware of which of my previously used indicators that were loaded into the new platform, looking for a possible connection between certain indicators and the unexplainable error.

    In fact, I have not loaded any of my previously used indicators into this new platform. Instead, I have used this as an opportunity for a long awaited rewriting/clean up(from scratch) of my indicators. But lo and behold, both problems (missing and "big" bars) have now begun to reoccur....

    Being that this is a fresh installation, containing no 3rd party AddOn or custom BarsTypes it just boggles my mind that this is a error that applies only to me...??

    Even though I am "mildly" frustrated by these ongoing issues, it is not my intention to blame/"bury" or point any fingers here. The only thing I seek is a working platform. That being said, I am really not looking for any more input from NT-support in this request.

    Rather, all other users...

    Am I really THE ONLY ONE struggling with these kind of issues??

    Because if that being the case, then it's pointless to waste anymore time troubleshooting the platform, then ​​​​​the problem must reside somewhere else on my computer..?

    Anyways, with my now total disbelief in the Continuum datafeed I have made a indicator that compares price-series and locates holes/mismatching data between the two compared series.
    I would appreciate anyone taking their time to run this test and offer me their feedback of the outcome.
    I have tried to make it as easy to use as possible.
    (Mainly tested on CL and ES)

    How to use the indicator:
    1.This indicator compares Price series without Tick replay, to timeseries with Tick replay, searching for discrepancies between the two.
    2.Open two 5 min charts with the same amount of days loaded (say 50-100 days, but you can load as few or many days as you want),
    3.set the 1st chart to Calculate.OnEachTick and Tick replay disabled, on the 2nd chart enable Tick replay.
    4.Open NinjaScript Output window, then apply this indicator to both charts simultaneously before changing any of the Indicators Properties.
    5.Follow further instructions on the OutPut window.

    Attached is the outcome of my test ran earlier today 4/3-21 on CL 04-21.

    ​​​​​​​Cheers
    Attached Files

    #2
    Hello Mttzern,

    It seems like you're looking for community guidance on this issue and not a NinjaTrader technician, is that correct?

    If so I'll leave this post active for the community to respond, if you're looking for us to dig into it further and see if we are able to track anything down, please don't hesitate to let us know.

    The easiest way to reach us is at platformsupport (at) ninjatrader (dot) com.

    Thank you in advance!
    Manfred F.NinjaTrader Customer Service

    Comment


      #3
      External link to the indicator:

      https://futures.io/ninjatrader/56679...tml#post836173
      Attached Files

      Comment


        #4
        Hello Mttzern, we tried to replicate the problem but weren't able to on our trading servers.

        Unfortunately none of our users have ever reported this problem, but that could also be because they keep NinjaTrader running 24/7 on servers.

        Would highly recommend checking out https://www.ninjamobiletrader.com/ if you want to avoid problems with home computers, fix performance issues and avoid connection problems.

        Originally posted by Mttzern View Post
        Been struggling with this issue ever since I switched to the NT platform about a year ago.
        I have been in contact with NT-support on multiple occasions in regards to the problem, but still missing answers/solutions.

        The main problem consists in missing bars of data as well as huge misprinted ghost bars (see attachments). The issue in regards to the ghost bars does only occure when using Tick replay with timebased BarsSeries
        The placement/point of where the misprinted bars shows/plots usally coinsides with times where i previously opened or closed the platorm at a certain point in time. Also, opening the platform during the weekend (or when the market is closed) seems to trigger the problem somewhat.
        For some reason the price series is restored trough manually adding one extra day to Bars to load in the DataSeries menu... It is like the memory is being compromised/"blocked" by earlier shutdown/startups, and that it needs atleast one "fresh" day not previously loaded to the memory in order to restore. Anyhow the platform clearly fails to resolve this with out intervention.

        Also, I struggle with missing price information, like the bigBar-problem this issue is usally reserved Tick replay with timebased BarsSeries. This issue is far less common then the first one, or at least i think, as it has been more difficult to detect (see indicator).

        Our last attempt to fix the issues described above was a teamviewer session. After some back and forth (deleting and re-installing the platform, etc) NT-support were able to detect/recreate a issue in regards to some missing bars at their end as well.
        Explanation: Incomplete price information delivered by the dataprovider.

        As for the "big bars" (which was not present after the re-installation) we agreed that I were to continue to use this "fresh" database, and to be aware of which of my previously used indicators that were loaded into the new platform, looking for a possible connection between certain indicators and the unexplainable error.

        In fact, I have not loaded any of my previously used indicators into this new platform. Instead, I have used this as an opportunity for a long awaited rewriting/clean up(from scratch) of my indicators. But lo and behold, both problems (missing and "big" bars) have now begun to reoccur....

        Being that this is a fresh installation, containing no 3rd party AddOn or custom BarsTypes it just boggles my mind that this is a error that applies only to me...??

        Even though I am "mildly" frustrated by these ongoing issues, it is not my intention to blame/"bury" or point any fingers here. The only thing I seek is a working platform. That being said, I am really not looking for any more input from NT-support in this request.

        Rather, all other users...

        Am I really THE ONLY ONE struggling with these kind of issues??

        Because if that being the case, then it's pointless to waste anymore time troubleshooting the platform, then ​​​​​the problem must reside somewhere else on my computer..?

        Anyways, with my now total disbelief in the Continuum datafeed I have made a indicator that compares price-series and locates holes/mismatching data between the two compared series.
        I would appreciate anyone taking their time to run this test and offer me their feedback of the outcome.
        I have tried to make it as easy to use as possible.
        (Mainly tested on CL and ES)

        How to use the indicator:
        1.This indicator compares Price series without Tick replay, to timeseries with Tick replay, searching for discrepancies between the two.
        2.Open two 5 min charts with the same amount of days loaded (say 50-100 days, but you can load as few or many days as you want),
        3.set the 1st chart to Calculate.OnEachTick and Tick replay disabled, on the 2nd chart enable Tick replay.
        4.Open NinjaScript Output window, then apply this indicator to both charts simultaneously before changing any of the Indicators Properties.
        5.Follow further instructions on the OutPut window.

        Attached is the outcome of my test ran earlier today 4/3-21 on CL 04-21.

        ​​​​​​​Cheers
        <span class="vendorName">Vendor_NT_Mobile</span>
        NinjaTrader Ecosystem Vendor - <a href="https://www.ninjamobiletrader.com/" class="external">Ninja Mobile Trader VPS</a>

        Comment

        Latest Posts

        Collapse

        Topics Statistics Last Post
        Started by ttodua, Today, 03:05 PM
        0 responses
        2 views
        0 likes
        Last Post ttodua
        by ttodua
         
        Started by TigerKiger, Today, 01:12 PM
        0 responses
        11 views
        0 likes
        Last Post TigerKiger  
        Started by tonynt, Today, 12:46 PM
        0 responses
        5 views
        0 likes
        Last Post tonynt
        by tonynt
         
        Started by ntdev, Today, 12:19 PM
        0 responses
        3 views
        0 likes
        Last Post ntdev
        by ntdev
         
        Started by RubenCazorla, Today, 12:02 PM
        0 responses
        4 views
        0 likes
        Last Post RubenCazorla  
        Working...
        X